summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-06 18:23:20 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-06 18:23:20 +0000
commitd37b97a25b8b10f748eead6574b01f893f140b01 (patch)
tree13e2a142a31cd193a39c63042a64cab29a1f7ae9 /app-eselect/eselect-python
parenta833e3f4a431b8eea751b7420e127787f9c92117 (diff)
gentoo resync : 06.12.2017
Diffstat (limited to 'app-eselect/eselect-python')
-rw-r--r--app-eselect/eselect-python/Manifest4
-rw-r--r--app-eselect/eselect-python/eselect-python-20171204.ebuild40
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild5
3 files changed, 46 insertions, 3 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index e4a341fcf495..e264dd991817 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -1,4 +1,6 @@
DIST eselect-python-20160516.tar.bz2 46549 SHA256 bea0a39d9e5afb7513be47955a82efa636b983de6388965df517cb1eb7615fd2 SHA512 0ac310e13bca9e3cdfdd55820cc2956cacf28ade99c1b5048edadd48c6a04c2ae1037207aaac74fcd75e809cf993f88b52e463979b68bd123fe925e491a7030a WHIRLPOOL 66782323a455af7536592cf76c9fd9f57c8adf8a67b374c4e6bb96fdc21dfb8add4f74697139643c47561357a451d50b777f3e2e73db850176fc05d61ae6e54c
+DIST eselect-python-20171204.tar.bz2 46655 BLAKE2B f0bc46c796a1b9e01f964994219b9c7831f99844a12e97429b40482e28a590a2d825f7b6fbca27b0ca1ce616e5cfb388272af686ea2de65fda69da0319fddeda SHA512 f89183ca992bc38f2308a3217602d5ce6ec4b3b5b614f2aec48fb5b3b7e50a2e44dd18af36a7cfbd4b45d05346f2be97605e35fd274558e9173c6974681c8fa9
EBUILD eselect-python-20160516.ebuild 1101 BLAKE2B e189b7c13192a28b4e5adab450e41927f31cab66a447a0aae23a14ea02f09449351a5bc588a64df75858c7a341e173bed06ec7040fbd4a41bba2d1ac6fb29ec5 SHA512 a8ebae6634638f735adeb741f182aa10484225a6d5458f7bd08fa0b043d8160c9f164d64854d682e1b867c1be8c9a5a42c475efec9a784bce80fd9ac08054924
-EBUILD eselect-python-99999999.ebuild 1102 BLAKE2B 77b68661ebf8daa24892fee1739f6ee01c9fdd1c30bc4a91f02ba139ab5a878e8cd5e0f1e12868134cbcdd7ed1703d3e683ecd45ecd7d3c733ef03fbef7b3d60 SHA512 f7bf212d900b56e8a31fa83cfdb050a1f345f8ec9d9e864abc69857930f272637612a5f1a1c0eb7b2285237e6810002a830698ac5326be2d7446bf6ab0b180e1
+EBUILD eselect-python-20171204.ebuild 1122 BLAKE2B 0dc2853efa4a8058b511ba480722490a40dc927da820f40b02bcaf904b31c3712a46408b1566c73ed83d20116c76a8e0d00ebd40c8103f97bf5f4e3d0afecaa6 SHA512 baab9007d3839db2b08aa15ba533bbdb6f958020fb63364809ec8b1d0910ac35f7f609ef090302acfb3815dd385ca6d1d4a239f93c2815cf026e1ee6b3b676e2
+EBUILD eselect-python-99999999.ebuild 1123 BLAKE2B 8f4ee6df6062fcad95144c8442c1ca28573a1f987c8310f8786f188ba0c8f800649be00b0ff0c7290f28f68b7d2a19164dada26bf7561aec13813c3d4ec5e955 SHA512 a71ce16b06ec69cbe0c1ad3c33c4534ddde120995033f8fc6e64484f97b5b743e75a62df2baad531ac5767aaa9d1b8b885aa45fa00b44dbf2a9331403aba31d0
MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/app-eselect/eselect-python/eselect-python-20171204.ebuild b/app-eselect/eselect-python/eselect-python-20171204.ebuild
new file mode 100644
index 000000000000..1d093e2738ae
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20171204.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index 3b35998a3dc1..de64bdb6ec6e 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} == "99999999" ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
else
SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="Eselect module for management of multiple Python versions"
@@ -23,6 +23,7 @@ RDEPEND=">=app-admin/eselect-1.2.3
>=dev-lang/python-exec-2.4.2"
src_prepare() {
+ default
[[ ${PV} == "99999999" ]] && eautoreconf
}