summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-python/eselect-python-20200719.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-eselect/eselect-python/eselect-python-20200719.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-eselect/eselect-python/eselect-python-20200719.ebuild')
-rw-r--r--app-eselect/eselect-python/eselect-python-20200719.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20200719.ebuild b/app-eselect/eselect-python/eselect-python-20200719.ebuild
new file mode 100644
index 000000000000..745d4e05cb20
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20200719.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~chutzpah/dist/misc/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# python-exec-2.4.2 for working -l option
+RDEPEND="
+ >=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}