summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-php/eselect-php-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /app-eselect/eselect-php/eselect-php-9999.ebuild
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-9999.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild28
1 files changed, 3 insertions, 25 deletions
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index f695558d423a..e6b5ef3d8804 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -16,8 +16,7 @@ IUSE="fpm apache2"
# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )
- fpm? ( sys-apps/gentoo-functions )"
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
src_prepare() {
eapply_user
@@ -41,31 +40,10 @@ src_configure(){
src_install() {
default
- # This can be removed after a while...
- if use apache2 ; then
- insinto /etc/apache2/modules.d
- newins "${FILESDIR}/70_mod_php5.backcompat.conf" 70_mod_php5.conf
- fi
-
if use fpm ; then
systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
exeinto /usr/libexec
- newexe "${FILESDIR}/php-fpm-launcher-r2" php-fpm-launcher
- fi
-}
-
-pkg_postinst() {
- if use apache2 ; then
- elog
- elog "If you are upgrading, be warned that our mod_php configuration"
- elog "file has changed! You should now define -DPHP for the apache2"
- elog "daemon, and inspect the new 70_mod_php.conf which has been"
- elog "installed. Module loading involves eselect as of this version."
- elog
- elog "You must run eselect at least once to choose your apache2 target"
- elog "before the new configuration will work. Afterwards, and after you"
- elog "have reviewed your new configuration, you are advised to remove"
- elog "the obsolete 70_mod_php5.conf file."
- elog
+ doexe "${T}"/php-fpm-launcher
fi
}