summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild')
-rw-r--r--app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild b/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild
new file mode 100644
index 000000000000..6f0ea6b5c257
--- /dev/null
+++ b/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot readme.gentoo-r1
+
+DESCRIPTION="Eselect module to choose Freetype infinality-enhanced LCD filtering settings"
+HOMEPAGE="https://github.com/yngwin/eselect-lcdfilter"
+SRC_URI="${HOMEPAGE}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+PDEPEND="media-libs/freetype[infinality]"
+
+DOC_CONTENTS="Use eselect lcdfilter to select an lcdfiltering font style.
+ You can customize ${EPREFIX}/usr/share/"${PN}"/env.d/custom with your own settings.
+ See ${EPREFIX}/usr/share/doc/"${PF}"/infinality-settings.sh for an explanation and
+ examples of the variables. This module is supposed to be used in pair with
+ eselect infinality."
+
+src_install() {
+ dodoc README.rst infinality-settings.sh
+ readme.gentoo_create_doc
+
+ insinto "/usr/share/eselect/modules"
+ doins lcdfilter.eselect
+
+ insinto "/usr/share/${PN}"
+ doins -r env.d
+}