summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-eselect/eselect-electron/eselect-electron-2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-eselect/eselect-electron/eselect-electron-2.1.ebuild')
-rw-r--r--app-eselect/eselect-electron/eselect-electron-2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-eselect/eselect-electron/eselect-electron-2.1.ebuild b/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
new file mode 100644
index 000000000000..e355c30fd392
--- /dev/null
+++ b/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default Electron slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://github.com/elprans/${PN}/archive/v${PV}.tar.gz -> eselect-electron-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins electron.eselect
+ dosym eselect /usr/bin/electron-config
+}
+
+pkg_postinst() {
+ electron-config update
+}