summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-29 02:14:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-29 02:14:02 +0000
commita493ba7d75043e8e649ee8d6d4942c1f4b31d1c5 (patch)
treed9aef2725cb8f60bd6f5a47afa9778eb94114793 /app-emulation
parentd7ef5a07f47da6898dcb2d1503790c59b0470571 (diff)
gentoo auto-resync : 29:12:2022 - 02:14:02
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin14991 -> 14994 bytes
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.2.19-r1.ebuild95
3 files changed, 96 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 47b036215c41..375599daf668 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 8fb76a79579c..0a7eaf921316 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -2,5 +2,6 @@ AUX vagrant.in 1872 BLAKE2B c3c5acf65ef1187061609837ab7c3df429763b6561ec462f9ce9
DIST vagrant-2.2.18.tar.gz 1620261 BLAKE2B 8938801b383373967365ca64a79f70885a61c02221eeebf75f15fa40440dfdc585f0a0d0cafe9a01484d594dc49b98397a0724776586c2c9fe4f529b6891bb26 SHA512 4694ca499136b53fc5cbab1efd47c9175293ba84521614edbe545766b93e54dc8dc11278f7170c88f3bb05a4ca0a7c52e21deca285f848578a890858b8f21b64
DIST vagrant-2.2.19.tar.gz 1838272 BLAKE2B cb707254379f52db8571bfe132e5b852a11998d86b43ee707e03d442ca1313da7b2612af027a58f806e0b551a6f415d121dab51cf7ea5da4292e5c2afd198ab9 SHA512 24a2e5baeac5cf8c45c012cf70dd4132b1dc7a6a5bab19d1046c91cc88e669356e2e5676d96eda6ed7293ff19ada974954969a4a59b9e4a30e2d95de27fa64e4
EBUILD vagrant-2.2.18-r1.ebuild 2376 BLAKE2B bdc88c6507dc11cd55ea195dea180b49ead6fd603c5c64e49536af33406eb3d9f33701a922f441ad93ca498cf6ded0a25d62cca1c7faec5d85acba6778ffaf48 SHA512 a653040505f69b6c026cf568f014c174ff4d200a0b23d1589e7778b39345495a385eb01c77a24da70528e16e80d401be52cef0c59edbd809bc393c52c31d7667
+EBUILD vagrant-2.2.19-r1.ebuild 2383 BLAKE2B 7cf32ad46d575af8fa98f2b6e224509a7c177e221cd40b57c9892eddfd071ce7345a43b9eb88ce44e27ad1322ced9b983d8e03e3214941098229509491bf0953 SHA512 56feffee9624e5cbf4c7e023426d6f296af2b5e5df06b5e83cc01981c7b5d415f5723705fb3144870ffbecaf3552a3a7dbd818e5fb4dd0f6c56a084cd60500d3
EBUILD vagrant-2.2.19.ebuild 2383 BLAKE2B ef7cb68c4b922eb11ecae35a033db6f14cc26e3822d86f4d116469613d574a05b3a135f3a1298a80629100b70613d8c2fbfd5bdc2e3dceadfa3fe42ec35939ed SHA512 fd0dd133143c4573c38226e6d535f84303bcb2c9d76caf743d6554ea9443e6e891e5102542fa26810d9a4e49e5a2c1cd51065ce2434cdb602f0d8606550689ee
MISC metadata.xml 455 BLAKE2B 01bf09c745e55dcdf7241dfdae1349fbb403f61249c0b05944347cb2f5cdf7d6a5fc7807a3f351145a41e4a5a94a5ba22195acee7c352539144277fff4696faf SHA512 1117ae7aca289842ab10ec2cf4443bf36ef7bdcd9efd0b6d1df1879f253cc137fea027a939c52f8d6990cae7a83bffafeb69f7b10660f27d278f19578ecccabd
diff --git a/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild
new file mode 100644
index 000000000000..bb916546e995
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 optfeature ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.0.0
+ >=dev-ruby/childprocess-4.0.0
+ >=dev-ruby/ed25519-1.2.4
+ dev-ruby/erubi
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.8:1
+ >=dev-ruby/listen-3.6
+ <dev-ruby/log4r-1.1.11
+ >=dev-ruby/mime-types-3.3:*
+ >=dev-ruby/rubyzip-2.0
+ >=dev-ruby/net-scp-3.0.0
+ >=dev-ruby/net-sftp-3.0
+ >=dev-ruby/net-ssh-6.1.0
+ dev-ruby/rest-client:2
+ >=dev-ruby/vagrant_cloud-3.0.5
+ >=dev-ruby/rexml-3.2.5
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-12.3.3
+ test? (
+ dev-ruby/rspec
+ dev-ruby/rspec-its
+ dev-ruby/webmock
+ )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+ rm tasks/bundler.rake || die
+
+ sed -e ':rake\|rspec\|webmock: s:~>:>=:' \
+ -e ':bcrypt_pbkdf\|hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|net-sftp\|childprocess: s:~>:>=:' \
+ -e '/fake_ftp/ s:^#*:#:' \
+ -e '/wdm/ s:^#*:#:' \
+ -e '/winrm/ s:^#*:#:' \
+ -e '/rb-kqueue/ s:^#*:#:' \
+ -e '/ruby_dep/ s:^#*:#:' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+
+ optfeature_header "Optional emulation/container backends:"
+ optfeature "VirtualBox support" app-emulation/virtualbox
+ optfeature "Docker support" app-containers/docker
+}