summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 05:27:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 05:27:18 +0100
commit992aa50a54a56c9e705ca4e85d809ec8989d74a2 (patch)
tree163a97df1174c6bc492ee86ad54667f5267306cf /app-emulation
parentce5c22ea4ab2c848cb8e0fe7be18977d51f5f0bb (diff)
gentoo auto-resync : 22:09:2022 - 05:27:18
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15124 -> 15124 bytes
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.9.2.ebuild63
3 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 5676c260abb9..aa659a23bb46 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 3127b05938d6..547c133bcdc9 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,5 +1,7 @@
DIST protontricks-1.9.0.tar.gz 154202 BLAKE2B e998bd899ec953ed7ee0bb0f3944da0212b71f2d0eef6c6996040e4d9c607f7bc73b52df4cbc6a70480b308473fa8c0978415a6202f498247bf91662761adf5c SHA512 43ffd2a5cd4d58c44696a2a66da0223a93d553822fdc92a476c661d69f7522d2aef12787bfc33610751bc1171fb1a3da169e3d40a2b60863a9f37ed205771835
DIST protontricks-1.9.1.tar.gz 158292 BLAKE2B 0825fb03bb05604482c893e7dc399bf0223d76a29eff86f0dd407d89cc8f5b39e8fcfec752a2979a3127921dbdb6dc3d186cc61b53f96c544e9b1526ec5e2246 SHA512 85ab3b1f3d5ff73eee7a8bae2021409443e2f82414f42cfa03646415e53a76e0b853ff1a99cb2d5eed512833ac7a60a2718095161aa56864ca83fe9901786881
+DIST protontricks-1.9.2.tar.gz 158505 BLAKE2B ea4bc39d835d28c3f1ba50fa64d9a646ec9ef535b7369517b77bccaceb62cb922bed8844a8a4ea1d4561e248e302628379326a4760b25ac24411e679d018cee0 SHA512 75158c5a8a86edaafcb5be1b01053db91e45754488db0febe026ef0cbfbbb67fa6f3f17d60fec997c6dd19a73245ee408bd2220e09a3983ccd253e6e4c10457d
EBUILD protontricks-1.9.0.ebuild 1561 BLAKE2B 8e363eb3c10b00c76e33654b1435d0e94d27941d53f17666dfa8450e9bf9a40f913fa9c66bd7d1f9d8f35e625c46ab0c50b20953734c370dfd770004c7a2c4d8 SHA512 dc3a8f17876d26da53bb9a8018aa6b754e503782bdde6b464e3353ba67ea51c9405f1b93c3d3f63f9aaa91cb7bf6542318ed3eba7bd111cd54ea58108d88882e
EBUILD protontricks-1.9.1.ebuild 1562 BLAKE2B 301f4eb1b8aa3ca6801a560614f1eaee2f917791a74eeaf173a1f3373a9768c87d2308bd8089dcd7448c3658f580476063dbffc637a2b9aac82dadb2d55f761b SHA512 5152a113f79b6788996dceebe23a64ee3ff8db232c6d89fa02500e4f18013c96079e2aa58a441636d4286232a581744504a0c08e3b9338fac3fb7b7b590e4cb2
+EBUILD protontricks-1.9.2.ebuild 1562 BLAKE2B 301f4eb1b8aa3ca6801a560614f1eaee2f917791a74eeaf173a1f3373a9768c87d2308bd8089dcd7448c3658f580476063dbffc637a2b9aac82dadb2d55f761b SHA512 5152a113f79b6788996dceebe23a64ee3ff8db232c6d89fa02500e4f18013c96079e2aa58a441636d4286232a581744504a0c08e3b9338fac3fb7b7b590e4cb2
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.9.2.ebuild b/app-emulation/protontricks/protontricks-1.9.2.ebuild
new file mode 100644
index 000000000000..d33c17e8e46a
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}