summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
commit4d190a87291ace8503ad92c6b049d14660a14c72 (patch)
tree3c46c3d158d4e77a4c12d283a17bade041a9859f /app-emulation
parent3c7931f8c6c90aa813912d87c684d742e0c29a05 (diff)
gentoo auto-resync : 07:04:2024 - 18:30:54
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15468 -> 15472 bytes
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.11.1.ebuild58
3 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 2b00696ce21b..11d6ba00b21f 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 83d8c00d1288..7d0545dd609b 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,3 +1,5 @@
DIST protontricks-1.10.5.tar.gz 163931 BLAKE2B 299fd6c77460de3d2fa1b585a1ad3dae857e4b78898c753007b358cc25b82918d33cb31c2028a4b1b562ee6c20b95ebafc532d97e2bc1fa5358464c6a4c1da5c SHA512 305b27ceaf428946a0ed09994173c861da1097c0bd21eebcc8b255bed3c4c50a920f0cc422601fbd44e0af373b71e928096fdd6f4cc2aa05c88126212fb4401f
+DIST protontricks-1.11.1.tar.gz 166843 BLAKE2B af6692b081d1d819bef39fd69c2108454b6dfcc29b004415a73aa0c0463e3887ddffe0e10864799f665f81fc90e5365accab1722af046f50a08bb7ba221f7e23 SHA512 eb0233180ba41c91ba78072ea2aabe9e8fea5b452fba0fd56aaf17e0282b0ee04e81d3665a7be546e3112382e0b574bb077af6b6be6ad2156dabc3112a1b831b
EBUILD protontricks-1.10.5.ebuild 1392 BLAKE2B bcaa22442f44e84ff0fb0117aaf5435041df7d16238e41fd10619e980b7ce2f69bc92cecb4c083d9f127c93894197b39d0a295e410a20af5e483cf353164d382 SHA512 11a9db15347e952a110a90ccb4bb9de3bb9421d53abff6dfe4840d6aad65169a8728b6186f1d9405af24d503686d98c6c9f37537147ca73ad5741815093e441d
+EBUILD protontricks-1.11.1.ebuild 1393 BLAKE2B dba61e45813b3d7cbe12827f20ffcb953eb08a1bc2cd100b7b3d76466ae61d7d1f5aa015b747b0f5204480e99cea007cc135136c23655742eb37f51e9e7f7152 SHA512 85f87a608fb02f1277775aa9ed65906e339b3f65e29eb76c8d4951bb8189db260944c618050d7cf0b2376701a25e1d5342c6ddcb5ff5699eab74fc72f3a4dd9c
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.11.1.ebuild b/app-emulation/protontricks/protontricks-1.11.1.ebuild
new file mode 100644
index 000000000000..fc9689a51050
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.11.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}