summaryrefslogtreecommitdiff
path: root/app-emulation/xen-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 13:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 13:36:46 +0100
commit7b02e37a04e4051a91a109814d386711f41f9a4b (patch)
treed0689f14f1d1df3a6a2525512a6812b146064a9e /app-emulation/xen-tools
parent5c0c70d5917e66743293789a6d6fd7d72250eb32 (diff)
gentoo auto-resync : 13:07:2022 - 13:36:46
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/Manifest2
-rw-r--r--app-emulation/xen-tools/xen-tools-4.16.2_pre2-r1.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild)53
2 files changed, 32 insertions, 23 deletions
diff --git a/app-emulation/xen-tools/Manifest b/app-emulation/xen-tools/Manifest
index 42ed63f336ba..a472603f7acb 100644
--- a/app-emulation/xen-tools/Manifest
+++ b/app-emulation/xen-tools/Manifest
@@ -29,5 +29,5 @@ DIST xen-gentoo-patches-4.15.3-gentoo-patchset-2.tar.bz2 4681 BLAKE2B 59fe5c2d5f
DIST xen-gentoo-patches-4.16.1-gentoo-patchset-1.tar.bz2 4351 BLAKE2B 1ba306fbc4a55aa1fea71139f7a900c8c363cf948f34a2aabd1ff6f8a68f2e632154ea0e0289580c84328b372c4f8cfdb2879bc63ae3ec163bfb29487783a758 SHA512 8d8198fbf8d9d4b46a83cf46c965448cb47b30438518a70c9b552c7cd1b23616e50f615206ddb18603e8482d19b25ccb611904c404d445898928ecf88051b70d
DIST xen-upstream-patches-4.16.2-pre-patchset-1.tar.bz2 56760 BLAKE2B 4c8030347f9e1ad3c2c4f440645656452daa1f087c34b8a3baba3cae1e7623a910e5727395e8c6f4a8573f3a37e58a318c485fa2f878c8e2f3240fb75cee0c03 SHA512 5e279845052addfbf7681ad5ccab9e692e4a1d69b73e51e1782e498f98217de77bfc4f5158307ee90164393edb023165e032b9f9f7123c0c614ee2336c021259
EBUILD xen-tools-4.15.3.ebuild 16673 BLAKE2B 5564ae42258c6eb413b4b29730d6fa5823f4479dd8b483d2ef093ab1d1ae9e234d3b42bcfd1fdb1667f0584604cc54fcef76be6f2bb03e862fc8302053e89999 SHA512 9c774445827cca9995f488e1bd5ae37a6a3402774e45c62a984fc3331ba53f5546f664504fb487474e4dd856f541263dc1de1ffbd909b6a1318db24916e0dc65
-EBUILD xen-tools-4.16.2_pre2.ebuild 16785 BLAKE2B 3e63d46899687792f5816a061b563ec1133aff4fe2399f98b6af6a93d80441f0e5c049fb8b2b212fa2ab75db34bbdda6f28d7e77e628088a6ccc273c5c3aad26 SHA512 dc56dbd75e7d165f26a75264baf24d54dfe82278936612727581abe3f2c0a07f07dbdad9d74a3894d22165a3663137084390484b082c4e70206ae2024153e048
+EBUILD xen-tools-4.16.2_pre2-r1.ebuild 16745 BLAKE2B a3d0e4623ddf2b3f18f9a38177d8637d61268d6975a878ab1b1ab6d69170bf4efdc39e2daa112a4b7171fa8af470f37cbdb413b96baa2c5da8270e49eae6888d SHA512 b2ffc6ce29eaaabdba3d9e0a3a2748d10d4e6cd6d2c81d51beb303c1f646539b499d65fbdb1e12f185e17f48e3c817800de9b21cdabf8734e017cf18c2f67cce
MISC metadata.xml 1562 BLAKE2B a619e34e6fec4c6ffc00fd098dc040c5bb464ed7f2032db2e933fada0614e82c21269175f37720a123404551474e2aeeb2728b405ff93f9b4d9d092d027e0839 SHA512 f45c793a4b4819f0e50501ddc85acdaf99e4d675530712f8dccfb5166d071ae8ed07917a61d56037d6ba3a54123f72f4512d8c11643ea8c6e507feb9d29594e7
diff --git a/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild b/app-emulation/xen-tools/xen-tools-4.16.2_pre2-r1.ebuild
index 84cc9ef221d0..9c83ef861b78 100644
--- a/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.16.2_pre2-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='ncurses,xml,threads(+)'
-inherit bash-completion-r1 flag-o-matic multilib python-single-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic multilib python-single-r1 readme.gentoo-r1 toolchain-funcs
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -429,7 +429,16 @@ src_compile() {
local -x NO_WERROR=1
fi
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" build-tools ${myopt}
+ emake \
+ HOSTCC="$(tc-getBUILD_CC)" \
+ HOSTCXX="$(tc-getBUILD_CXX)" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ OBJDUMP="$(tc-getOBJDUMP)" \
+ RANLIB="$(tc-getRANLIB)" \
+ build-tools ${myopt}
if use doc; then
emake -C docs build
@@ -508,27 +517,27 @@ src_install() {
fi
python_optimize
-}
-pkg_postinst() {
- elog "Official Xen Guide and the offical wiki page:"
- elog "https://wiki.gentoo.org/wiki/Xen"
- elog "https://wiki.xen.org/wiki/Main_Page"
- elog ""
- elog "Recommended to utilise the xencommons script to config system at boot"
- elog "Add by use of rc-update on completion of the install"
+ local -x DISABLE_AUTOFORMATTING=true
+ local -x DOC_CONTENTS="Official Xen Guide and the offical wiki page:
+- https://wiki.gentoo.org/wiki/Xen
+- https://wiki.xen.org/wiki/Main_Page
- if ! use hvm; then
- echo
- elog "HVM (VT-x and AMD-V) support has been disabled. If you need hvm"
- elog "support enable the hvm use flag."
- elog "An x86 or amd64 system is required to build HVM support."
- fi
- if use qemu; then
- elog "The qemu-bridge-helper is renamed to the xen-bridge-helper in the in source"
- elog "build of qemu. This allows for app-emulation/qemu to be emerged concurrently"
- elog "with the qemu capable xen. It is up to the user to distinguish between and utilise"
- elog "the qemu-bridge-helper and the xen-bridge-helper. File bugs of any issues that arise"
- fi
+If you use OpenRC:
+It is recommended to utilise the xencommons script to configure the system at
+boot time.
+
+
+If you use QEMU:
+The qemu-bridge-helper is renamed to the xen-bridge-helper in the in source
+build of qemu. This allows for app-emulation/qemu to be emerged concurrently
+with the qemu capable xen. It is up to the user to distinguish between and utilise
+the qemu-bridge-helper and the xen-bridge-helper. File bugs of any issues that arise
+"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
}