summaryrefslogtreecommitdiff
path: root/app-emulation/x48
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/x48
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/x48')
-rw-r--r--app-emulation/x48/Manifest4
-rw-r--r--app-emulation/x48/metadata.xml22
-rw-r--r--app-emulation/x48/x48-0.6.4-r1.ebuild68
-rw-r--r--app-emulation/x48/x48-0.6.4.ebuild66
4 files changed, 160 insertions, 0 deletions
diff --git a/app-emulation/x48/Manifest b/app-emulation/x48/Manifest
new file mode 100644
index 000000000000..5fb25f70c84a
--- /dev/null
+++ b/app-emulation/x48/Manifest
@@ -0,0 +1,4 @@
+DIST x48-0.6.4.tar.bz2 227991 BLAKE2B 8db2962860eeb161a8efc9d46730c71d95d0331157e3e2481a978385ad54b04b7a4eb601c68e7df966194b23e0cd04bed4e80511d22695bb7ccdd3959d8fd8d7 SHA512 60fdba1171a02e4a5f9bcefb29fff9398fdbda50553c3d3b952fab0b4ebf87b219d4615139ca3673b1c61ff6d6559aab3e93218334aa6cdb442d4861347138ce
+EBUILD x48-0.6.4-r1.ebuild 1732 BLAKE2B f8b7e2da5f69ee7a95f36d800422a59007d3c3f887253e3e9725028bccd82c61605c20c78485e28829b12cef4f2ec55d15f7b183037a73ae9f9f8ce834d1ec25 SHA512 5ffd669ffa64e5c179a3791621830544cbe99935e465686b6be030173650080741a1f5e7a98a503b88218a609ef054941f42abf80148bcd491afa0df5b80229d
+EBUILD x48-0.6.4.ebuild 1658 BLAKE2B 188fa81f668f207fdf11b780dec7ed88d85aa361fe1d496a5e1aaa5c62525afce937c3fedae24927fd66746ceea936d5b7a0a0c2ca19181ec513234b4fd0ea91 SHA512 4c3d4048b5c51fa28d348c52ec61281eeca0a5765d69e96c2f978892f6760b6ba06dab713cd68483551022d3b08d5e74c4bca9ec47e03337bbdc59d16bba45eb
+MISC metadata.xml 716 BLAKE2B 6869cac178f0a9b87c943acbced134699bb4deb1309a14ceffd6ae71ec876224e50657b2adf8329c05f180f35317bccad048d4c4597b5945e940d98a734b1787 SHA512 518c89c4c0d49f9482a9dad05c0d6df7b28121807a9893dedd6448169c62f2719bf4bd1097ce88143bc44e80a782bf6ddb7897062fbce06a5c345b3efb8ffb14
diff --git a/app-emulation/x48/metadata.xml b/app-emulation/x48/metadata.xml
new file mode 100644
index 000000000000..b1e78a979e46
--- /dev/null
+++ b/app-emulation/x48/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nimiux@gentoo.org</email>
+ <name>Chema Alonso</name>
+ </maintainer>
+ <longdescription lang="en">
+ The x48 package is an emulator of the Saturn Processor and the I/O of an
+ HP48 calculator.
+ </longdescription>
+ <longdescription lang="es">
+ El paquete x48 es un emulador del procesador Saturn y de la E/S de una
+ calculadora HP48.
+ </longdescription>
+ <use>
+ <flag name="readline">Enables support for libreadline</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">x48.berlios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/x48/x48-0.6.4-r1.ebuild b/app-emulation/x48/x48-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..db232232d3ca
--- /dev/null
+++ b/app-emulation/x48/x48-0.6.4-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="HP48 Calculator Emulator"
+HOMEPAGE="http://x48.berlios.de/"
+SRC_URI="mirror://sourceforge/x48.berlios/${P}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sparc x86"
+IUSE="readline"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ readline? ( sys-libs/readline:5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-libs/libXt"
+
+src_unpack() {
+ mkdir -p "${S}"
+ cd "${S}"
+ unpack ${A}
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '698s/inline/static inline/' src/emulate.c || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto /usr/share/"${PN}"/romdump
+ doins -r romdump/{README,ROMDump*}
+ dodoc AUTHORS README ChangeLog
+}
+
+pkg_postinst() {
+ elog "The X48 emulator requires an HP48 ROM image to run."
+ elog
+ elog "If you own an HP-48 calculator, you can use the ROMDump utility"
+ elog "included with this package to obtain it from your calculator."
+ elog "The instructions of how to do this are included in the package."
+ elog
+ elog "Alternatively, HP has provided the ROM images for non-commercial"
+ elog "use only."
+ elog
+ elog "Due to confusion over the legal status of these ROMs you must"
+ elog "manually download one from http://www.hpcalc.org/hp48/pc/emulators/"
+ elog
+ elog "If you do not know which one to use, try 'HP 48GX Revision R ROM.'"
+ elog
+ elog "Once you have a ROM, you will need to install it by running:"
+ elog
+ elog "x48 -rom gxrom-r"
+ elog
+ elog "You will only have to do this the first time you run X48. The"
+ elog "ROM will be stored in ~/.hp48/rom for future runs."
+}
diff --git a/app-emulation/x48/x48-0.6.4.ebuild b/app-emulation/x48/x48-0.6.4.ebuild
new file mode 100644
index 000000000000..cc84f6518da5
--- /dev/null
+++ b/app-emulation/x48/x48-0.6.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="HP48 Calculator Emulator"
+HOMEPAGE="http://x48.berlios.de/"
+SRC_URI="mirror://sourceforge/x48.berlios/${P}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="readline"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-libs/libXt"
+
+src_unpack() {
+ mkdir -p "${S}"
+ cd "${S}"
+ unpack ${A}
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto /usr/share/"${PN}"/romdump
+ doins -r romdump/{README,ROMDump*}
+ dodoc AUTHORS README ChangeLog
+}
+
+pkg_postinst() {
+ elog "The X48 emulator requires an HP48 ROM image to run."
+ elog
+ elog "If you own an HP-48 calculator, you can use the ROMDump utility"
+ elog "included with this package to obtain it from your calculator."
+ elog "The instructions of how to do this are included in the package."
+ elog
+ elog "Alternatively, HP has provided the ROM images for non-commercial"
+ elog "use only."
+ elog
+ elog "Due to confusion over the legal status of these ROMs you must"
+ elog "manually download one from http://www.hpcalc.org/hp48/pc/emulators/"
+ elog
+ elog "If you do not know which one to use, try 'HP 48GX Revision R ROM.'"
+ elog
+ elog "Once you have a ROM, you will need to install it by running:"
+ elog
+ elog "x48 -rom gxrom-r"
+ elog
+ elog "You will only have to do this the first time you run X48. The"
+ elog "ROM will be stored in ~/.hp48/rom for future runs."
+}