summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/wine-staging-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /app-emulation/wine-staging/wine-staging-9999.ebuild
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-9999.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 86f05a0bdc36..9cfa7dc58db7 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -10,6 +10,7 @@ inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolcha
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
+GECKO_VERSION="2.47.3"
if [[ ${MY_PV} == "9999" ]] ; then
EGIT_REPO_URI="https://source.winehq.org/git/wine.git"
@@ -118,7 +119,7 @@ RDEPEND="${COMMON_DEPEND}
app-emulation/wine-desktop-common
>app-eselect/eselect-wine-0.3
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
- gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
+ gecko? ( app-emulation/wine-gecko:${GECKO_VERSION}[abi_x86_32?,abi_x86_64?] )
mono? ( app-emulation/wine-mono:7.3.0 )
perl? (
dev-lang/perl
@@ -281,6 +282,13 @@ src_prepare() {
done
}
+ if use gecko; then
+ local source_gecko_version=$( sed -n -e '/^#define GECKO_VERSION/p' dlls/appwiz.cpl/addons.c | grep -Eo -m 1 '[0-9.]+' )
+ if [[ ${source_gecko_version} != ${GECKO_VERSION} ]] ; then
+ die "app-emulation/wine-gecko version is not correct! Please file a bug."
+ fi
+ fi
+
local md5="$(md5sum server/protocol.def)"
if use staging; then