summaryrefslogtreecommitdiff
path: root/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
commitbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (patch)
treee255548891f2188ab2594eedde60d6f426ef24ed /app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
parentdef28ad1de5a6853465d7ff8f626cda6a774cd9e (diff)
gentoo auto-resync : 02:06:2023 - 09:28:30
Diffstat (limited to 'app-emulation/wine-proton/wine-proton-8.0.9999.ebuild')
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
index b2b9a61de3ff..4939eacc3879 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
@@ -28,10 +28,10 @@ HOMEPAGE="https://github.com/ValveSoftware/wine/"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
IUSE="
- +abi_x86_32 +abi_x86_64 +alsa crossdev-mingw custom-cflags debug
+ +abi_x86_32 +abi_x86_64 +alsa crossdev-mingw custom-cflags
+fontconfig +gecko +gstreamer llvm-libunwind +mono nls osmesa
- perl pulseaudio +sdl selinux +ssl udev udisks +unwind usb v4l
- +xcomposite xinerama"
+ perl pulseaudio +sdl selinux +ssl +strip udev udisks +unwind
+ usb v4l +xcomposite xinerama"
# tests are non-trivial to run, can hang easily, don't play well with
# sandbox, and several need real opengl/vulkan or network access
@@ -305,9 +305,13 @@ src_install() {
# don't let portage try to strip PE files with the wrong
# strip executable and instead handle it here (saves ~120MB)
dostrip -x ${WINE_PREFIX}/wine/{i386,x86_64}-windows
- use debug ||
+
+ if use strip; then
+ ebegin "Stripping Windows (PE) binaries"
find "${ED}"${WINE_PREFIX}/wine/*-windows -regex '.*\.\(a\|dll\|exe\)' \
- -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} + || die
+ -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} +
+ eend ${?} || die
+ fi
dodoc ANNOUNCE AUTHORS README* documentation/README*
readme.gentoo_create_doc