summaryrefslogtreecommitdiff
path: root/app-emulation/wine-desktop-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-emulation/wine-desktop-common
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-emulation/wine-desktop-common')
-rw-r--r--app-emulation/wine-desktop-common/Manifest1
-rw-r--r--app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/wine-desktop-common/Manifest b/app-emulation/wine-desktop-common/Manifest
index 4458c4986571..b6a2d8c46473 100644
--- a/app-emulation/wine-desktop-common/Manifest
+++ b/app-emulation/wine-desktop-common/Manifest
@@ -1,3 +1,4 @@
DIST wine-desktop-common-20150204.tar.gz 99491 BLAKE2B 7427c08d00a7ec11319908c908c5833e1a3fc297ec2ebfd942ccdf2adb9e657d1fd751da74bd67e7efb3d4b8ad769a11b1aa5e1a56e33e181f149f4f6245fac3 SHA512 1f3d7022c5cff87ed3b8fd3b7cd14397c6f23b98fe6a7c583ac0d2f439ff29d943f57375f23687aa6519ff1d84ff07624a9a712d6f19fa207fd26d01edcb6688
+EBUILD wine-desktop-common-20150204-r1.ebuild 969 BLAKE2B f24b5afc9671f24b61b48cb2c7818f5daf891a32591924a7e7351b5f014cd17f61969a297927737a9117a9fcb2258253ee5d5a8b54f679a51528d093a4a7242d SHA512 f44a92e254984d1aa6fce151694b0a38308a70e4c458f98b89dfb895ef124dbb89aaef364b03bb98799e0958a2e4cc8035d54dd2512e1fc279cf0e6567af7168
EBUILD wine-desktop-common-20150204.ebuild 1161 BLAKE2B 02c1f236cdb889d701ae7107947852b93ea5d8750a3aee9ce20bec3835b166a84e00020817aa81953f32a0775f742d58d2dd10ffae50671debd81f7cc4b359e1 SHA512 0366d63c67a2a8ac0afe200e2cbfc36c83931e63b462cd99ac99b8be487ef25bd721c98b6e43c7855060e730cda7b65d36ee197916e8ee40fd4003c9989915f6
MISC metadata.xml 439 BLAKE2B 5748ff1f9d8a97a6c0496f66672ba2131d46db6391003fdb2090b2627561e62519580c1ad78138857111963ec9ea56ff2491b56b63c0bf321ab7de88a3c2f445 SHA512 c9bb03bc6753c6c40c280d477ef343b1cc4bf79f49f0dcd83aab6c5c1f4770e93c65c33a51628453e326618b44fe2a18610667d7177e503366dbfdc882fa471d
diff --git a/app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild b/app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild
new file mode 100644
index 000000000000..d43b6fa3837d
--- /dev/null
+++ b/app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Various desktop menu items and icons for wine"
+HOMEPAGE="https://github.com/NP-Hardass/wine-desktop-common
+ https://bazaar.launchpad.net/~ubuntu-wine/wine/ubuntu-debian-dir/files/head:/debian/"
+SRC_URI="https://github.com/NP-Hardass/${PN}/archive/${PV//./}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!app-emulation/wine:0"
+PDEPEND="app-eselect/eselect-wine"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+S=${WORKDIR}/${PN}-${PV//./}
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}