summaryrefslogtreecommitdiff
path: root/app-emulation/wine-desktop-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/wine-desktop-common
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/wine-desktop-common')
-rw-r--r--app-emulation/wine-desktop-common/Manifest3
-rw-r--r--app-emulation/wine-desktop-common/metadata.xml15
-rw-r--r--app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild45
3 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/wine-desktop-common/Manifest b/app-emulation/wine-desktop-common/Manifest
new file mode 100644
index 000000000000..4458c4986571
--- /dev/null
+++ b/app-emulation/wine-desktop-common/Manifest
@@ -0,0 +1,3 @@
+DIST wine-desktop-common-20150204.tar.gz 99491 BLAKE2B 7427c08d00a7ec11319908c908c5833e1a3fc297ec2ebfd942ccdf2adb9e657d1fd751da74bd67e7efb3d4b8ad769a11b1aa5e1a56e33e181f149f4f6245fac3 SHA512 1f3d7022c5cff87ed3b8fd3b7cd14397c6f23b98fe6a7c583ac0d2f439ff29d943f57375f23687aa6519ff1d84ff07624a9a712d6f19fa207fd26d01edcb6688
+EBUILD wine-desktop-common-20150204.ebuild 1161 BLAKE2B 02c1f236cdb889d701ae7107947852b93ea5d8750a3aee9ce20bec3835b166a84e00020817aa81953f32a0775f742d58d2dd10ffae50671debd81f7cc4b359e1 SHA512 0366d63c67a2a8ac0afe200e2cbfc36c83931e63b462cd99ac99b8be487ef25bd721c98b6e43c7855060e730cda7b65d36ee197916e8ee40fd4003c9989915f6
+MISC metadata.xml 439 BLAKE2B 5748ff1f9d8a97a6c0496f66672ba2131d46db6391003fdb2090b2627561e62519580c1ad78138857111963ec9ea56ff2491b56b63c0bf321ab7de88a3c2f445 SHA512 c9bb03bc6753c6c40c280d477ef343b1cc4bf79f49f0dcd83aab6c5c1f4770e93c65c33a51628453e326618b44fe2a18610667d7177e503366dbfdc882fa471d
diff --git a/app-emulation/wine-desktop-common/metadata.xml b/app-emulation/wine-desktop-common/metadata.xml
new file mode 100644
index 000000000000..751c88a7bada
--- /dev/null
+++ b/app-emulation/wine-desktop-common/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>NP-Hardass@gentoo.org</email>
+ <name>NP-Hardass</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NP-Hardass/wine-desktop-common</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
new file mode 100644
index 000000000000..66ba3caad5c5
--- /dev/null
+++ b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit gnome2-utils
+
+DESCRIPTION="Various desktop menu items and icons for wine"
+HOMEPAGE="https://github.com/NP-Hardass/wine-desktop-common
+ https://dev.gentoo.org/~tetromino/distfiles/wine
+ https://bazaar.launchpad.net/~ubuntu-wine/wine/ubuntu-debian-dir/files/head:/debian/"
+SRC_URI="https://github.com/NP-Hardass/${PN}/archive/${PV//./}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!!app-emulation/wine:0"
+PDEPEND="app-eselect/eselect-wine"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+S=${WORKDIR}/${PN}-${PV//./}
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}