summaryrefslogtreecommitdiff
path: root/app-emulation/wine-desktop-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emulation/wine-desktop-common
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emulation/wine-desktop-common')
-rw-r--r--app-emulation/wine-desktop-common/Manifest3
-rw-r--r--app-emulation/wine-desktop-common/metadata.xml15
-rw-r--r--app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild45
3 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/wine-desktop-common/Manifest b/app-emulation/wine-desktop-common/Manifest
new file mode 100644
index 000000000000..a1dabc2c0e46
--- /dev/null
+++ b/app-emulation/wine-desktop-common/Manifest
@@ -0,0 +1,3 @@
+DIST wine-desktop-common-20150204.tar.gz 99491 SHA256 444ad6b52b5290ec7d160e2cc40e4ba0910b4c4983dba1ceb054b81b09b24b5e SHA512 1f3d7022c5cff87ed3b8fd3b7cd14397c6f23b98fe6a7c583ac0d2f439ff29d943f57375f23687aa6519ff1d84ff07624a9a712d6f19fa207fd26d01edcb6688 WHIRLPOOL e9810b2952d25c05d831000e00e423de86809ec31b9a033fd4c64a70709da7338a9afc9e632e678f49c789a8a3702fbd0113226770cdb806623f2de371a16f54
+EBUILD wine-desktop-common-20150204.ebuild 1161 SHA256 06d7af70852c6c23582f114d8115ec2515eaf959e0ebd17931266008fb41173c SHA512 0366d63c67a2a8ac0afe200e2cbfc36c83931e63b462cd99ac99b8be487ef25bd721c98b6e43c7855060e730cda7b65d36ee197916e8ee40fd4003c9989915f6 WHIRLPOOL 4e9a1cead29b9730eec094a8e3f31d2416f24da705d6f9f0fd6e872d4218e9535ca6fa7a11c587d8a5fbf6398cca0e35be7d1e505f512bbd2166c61fe18b4ea8
+MISC metadata.xml 439 SHA256 e62f96c0bc31b0c2ba1f3fbbdae174cfdec71aecd299ff2d5f103e76fbfcde42 SHA512 c9bb03bc6753c6c40c280d477ef343b1cc4bf79f49f0dcd83aab6c5c1f4770e93c65c33a51628453e326618b44fe2a18610667d7177e503366dbfdc882fa471d WHIRLPOOL f2c64775b1ff4a3ef9cf255e76ba45b1db3737a10c642e9f324a2ee6cd9cff4347c1072efb3fd6d94d58148dd57e1d832a78b27189c83195cf0e458e3dee40cf
diff --git a/app-emulation/wine-desktop-common/metadata.xml b/app-emulation/wine-desktop-common/metadata.xml
new file mode 100644
index 000000000000..751c88a7bada
--- /dev/null
+++ b/app-emulation/wine-desktop-common/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>NP-Hardass@gentoo.org</email>
+ <name>NP-Hardass</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NP-Hardass/wine-desktop-common</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
new file mode 100644
index 000000000000..66ba3caad5c5
--- /dev/null
+++ b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit gnome2-utils
+
+DESCRIPTION="Various desktop menu items and icons for wine"
+HOMEPAGE="https://github.com/NP-Hardass/wine-desktop-common
+ https://dev.gentoo.org/~tetromino/distfiles/wine
+ https://bazaar.launchpad.net/~ubuntu-wine/wine/ubuntu-debian-dir/files/head:/debian/"
+SRC_URI="https://github.com/NP-Hardass/${PN}/archive/${PV//./}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!!app-emulation/wine:0"
+PDEPEND="app-eselect/eselect-wine"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+S=${WORKDIR}/${PN}-${PV//./}
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}