summaryrefslogtreecommitdiff
path: root/app-emulation/vpcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/vpcs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/vpcs')
-rw-r--r--app-emulation/vpcs/Manifest3
-rw-r--r--app-emulation/vpcs/metadata.xml8
-rw-r--r--app-emulation/vpcs/vpcs-0.6.ebuild44
3 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/vpcs/Manifest b/app-emulation/vpcs/Manifest
new file mode 100644
index 000000000000..c480247c1846
--- /dev/null
+++ b/app-emulation/vpcs/Manifest
@@ -0,0 +1,3 @@
+DIST vpcs-0.6-src.tbz 131820 BLAKE2B de9216360bf666eed1b94ce4101fd47fac78845bba4c882d4855eae48652c61efc549b01968faab7212cff60bafe2b1586ede51c3be33bd5419834da13fca928 SHA512 a740f264551de9e8dd95de2fbba444d9525f63c4c5473aea6cf1016c99d7866f3d0623f9f934bda7a0b565c23179647734c400ce3bb685fdab8ec6c35f25d671
+EBUILD vpcs-0.6.ebuild 938 BLAKE2B bc78d5fd4fa8a3b5a2dd9931be491f16ab79292ae0dfb2d5a4311ce742c83a7c8f01b06bdd11fde0d7fdb7ac26da83e2bbe353e8008d4cb5905eea3791f63f0f SHA512 8472f2a22a93f1c6b65421c316e528eb57e3b25210324b700e23f828ca27a85c5eff305401b330d512243afcd0ee97cef530a8b373bcf674b01fec1e08de5160
+MISC metadata.xml 241 BLAKE2B 2cc47e12ef61022b2dbc00904091b1e35dbbeb5c4ab35dc697ae06adfc7e78782065e35b1ebebe2779f180b2b573dad22ba516a393f47c3e26e1be2ad6a3d65c SHA512 edc53eaf933b709bb0a2e8507209a85cc3901ce6e4db3bf40e061a01ece0e4b0f83d30b93b2131316c802def4a08081a5ac3b3606624271184680421b7f0323b
diff --git a/app-emulation/vpcs/metadata.xml b/app-emulation/vpcs/metadata.xml
new file mode 100644
index 000000000000..7012b6c468af
--- /dev/null
+++ b/app-emulation/vpcs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">gns-3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/vpcs/vpcs-0.6.ebuild b/app-emulation/vpcs/vpcs-0.6.ebuild
new file mode 100644
index 000000000000..6187e32e943d
--- /dev/null
+++ b/app-emulation/vpcs/vpcs-0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simulate up to 9 PCs in place of VMware boxes in a Dynamips network"
+HOMEPAGE="http://vpcs.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.tbz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${S}/src/"
+
+src_prepare() {
+ # move Makefile in place
+ cp Makefile.linux Makefile
+
+ # replace hardcoded CFLAGS with user set CFLAGS
+ # append -fno-strict-aliasing to CFLAGS to suppress QA issues from upstream
+ # add user $LDFLAGS in the front and remove -s that strips binary
+ sed -e "s/-D\$(CPUTYPE)/${CFLAGS} -fno-strict-aliasing/" \
+ -e "s/^LDFLAGS=/LDFLAGS=${LDFLAGS} /" \
+ -e "s/-s //" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ #put binary in /usr/bin
+ dobin vpcs
+
+ doman ../man/vpcs.1
+}