summaryrefslogtreecommitdiff
path: root/app-emulation/vov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
commit2929788def9a92c1eb237eed93fbdb0c02838bbf (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /app-emulation/vov
parentab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (diff)
Revert "gentoo resync : 13.10.2019"
This reverts commit ab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030.
Diffstat (limited to 'app-emulation/vov')
-rw-r--r--app-emulation/vov/Manifest3
-rw-r--r--app-emulation/vov/metadata.xml17
-rw-r--r--app-emulation/vov/vov-2.0.0.ebuild53
3 files changed, 73 insertions, 0 deletions
diff --git a/app-emulation/vov/Manifest b/app-emulation/vov/Manifest
new file mode 100644
index 000000000000..214ac56bb060
--- /dev/null
+++ b/app-emulation/vov/Manifest
@@ -0,0 +1,3 @@
+DIST vov-2.0.0.tar.gz 510667 BLAKE2B cb138fd5c1c28f958d01dbb7a717fe21595a57d06fdf2b7c18b3d68b9adaf4a349edc94a7d54e36e7367b69b9a92af5feb8fcc822a011ed7518a4113a255ac3c SHA512 67a3b552dc768dff57ed2b7119ff288f4ef120a5f48279a4a003ff39add051b7fec9f22c3278449c6e96b7b5da1cc40a5fefef7a320fbfceadddf73b317a57a7
+EBUILD vov-2.0.0.ebuild 1007 BLAKE2B a7006d4903ce0db53067d41cc9277f610558f9bced854a09415f6fb3873ad0bcfc1c6394d34a302a92a1ce2f602e6a738402b363757b4035de737371d3497eae SHA512 2912134a33c836d4a41ed1f45a18ded733c8a9eb1cb112bda3a84baadaa5d95329a75b22c8c5f81c4964ffbac92700963638484883b58b3e4f42ae55f8da3c0e
+MISC metadata.xml 739 BLAKE2B 0bf78d3a36024590426aa30d0e5cccdd6b31d44dfe332fdb12ff3bc26d6c8a3e223c3f9f43ca2048270a6da9c7f19067efe7944a848b55691fd2cfbfaac5568d SHA512 25a9a61adfac2afd4ea78a085bd0af09d6e160ee98fe172cc94562ced220ddea0523ea4087a8885fc602dde5930f867d6a7e0834ac1f61f498a284b62869e83a
diff --git a/app-emulation/vov/metadata.xml b/app-emulation/vov/metadata.xml
new file mode 100644
index 000000000000..ea5b19f45fc0
--- /dev/null
+++ b/app-emulation/vov/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <longdescription>
+ vov (Vov's Obsessive Von-Neumann) is a tool that emulates the behavior of a Von-Neumann machine.
+ It is basically an interpreter, which reads files in the form of memory assignments and executes
+ the encoded instructions. The vov's instructions make you able to perform simple arithmetic data
+ manipulation. It is a very useful tool to see if your programs work and how.
+ </longdescription>
+ <use>
+ <flag name="gprof">build with profiling support</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-emulation/vov/vov-2.0.0.ebuild b/app-emulation/vov/vov-2.0.0.ebuild
new file mode 100644
index 000000000000..17fe7ee6c79f
--- /dev/null
+++ b/app-emulation/vov/vov-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit flag-o-matic
+
+DESCRIPTION="A tool that emulates the behavior of a Von-Neumann machine"
+HOMEPAGE="http://home.gna.org/vov/"
+SRC_URI="http://download.gna.org/vov/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="debug gprof"
+
+RDEPEND=""
+DEPEND=">=sys-devel/flex-2.5.33-r3
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # do no install redundant documentation
+ cd "${S}"
+ sed -i 's/src scripts docs/src scripts/' "${S}/Makefile.in"
+}
+
+src_compile()
+{
+ local fp_support=""
+
+ if use gprof; then
+ filter-flags "-fomit-frame-pointer"
+ fp_support="--enable-frame-pointer"
+ fi
+
+ econf \
+ `use_enable gprof` \
+ `use_enable debug` \
+ ${fp_support} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ doman docs/vov.1
+}