summaryrefslogtreecommitdiff
path: root/app-emulation/virt-what
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/virt-what
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/virt-what')
-rw-r--r--app-emulation/virt-what/Manifest3
-rw-r--r--app-emulation/virt-what/metadata.xml15
-rw-r--r--app-emulation/virt-what/virt-what-1.18.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/virt-what/Manifest b/app-emulation/virt-what/Manifest
new file mode 100644
index 000000000000..c916d65abd2d
--- /dev/null
+++ b/app-emulation/virt-what/Manifest
@@ -0,0 +1,3 @@
+DIST virt-what-1.18.tar.gz 173703 BLAKE2B c1ab6f331ca370572cedef06fd3eb9177ca8ef4302446eb46c737446a001e77a0825ec8771aade903e6194af3f4f745c3f35f1d9dbbb8a0550b493296878ade3 SHA512 8085a38111d5664f411f5bb9d2ee221bc22e5b0f2d993e8d518718b3f63b16ba73e052b1623c090493cf8fef52fd237ba823377503a32b4b7d03cc5380d5c613
+EBUILD virt-what-1.18.ebuild 609 BLAKE2B c2e183482354a5623ee7ac84a0f50d36d80065f1f803a9086e687f16416be6f1b62482d67d99890f2f1f61c371f6053b03eb2eb71c099c309a049474494aa57b SHA512 56ee0708fa083bee61d82106227238cbce18027557b75ffed68fdaecf47f6cafe84766a03f0c55d0ed7060af90b929cd6fa80453ff355adb2f5f00e70dffa7ed
+MISC metadata.xml 456 BLAKE2B 7f4f5daff8e3d30e59981cb50fcc8da98ee032dc33c16cb441f9aec580c101eab57fb25257a7298e32d6093a7ddb25c292f35858b0392bde2a2ec5e528b49079 SHA512 9b3ce56970ef01166980d6e5275bf4d740c47c044ab531cedeaac4e606d369f2c65b22fd8d8387332f0428ed7d9970d8b7e6363b48cb73c5b3326c7b463906bd
diff --git a/app-emulation/virt-what/metadata.xml b/app-emulation/virt-what/metadata.xml
new file mode 100644
index 000000000000..7e3c0f29d1a5
--- /dev/null
+++ b/app-emulation/virt-what/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <use>
+ <flag name="dmi">Use <pkg>sys-apps/dmidecode</pkg> to read firmware data</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-emulation/virt-what/virt-what-1.18.ebuild b/app-emulation/virt-what/virt-what-1.18.ebuild
new file mode 100644
index 000000000000..59adce2a2542
--- /dev/null
+++ b/app-emulation/virt-what/virt-what-1.18.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Detects if the current machine is running in a virtual machine"
+HOMEPAGE="https://people.redhat.com/~rjones/virt-what/"
+SRC_URI="https://people.redhat.com/~rjones/virt-what/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="dmi"
+
+DEPEND="dev-lang/perl"
+RDEPEND="app-shells/bash
+ dmi? ( sys-apps/dmidecode )"
+
+src_prepare() {
+ default
+
+ # Pretends to be POSIX sh while it is not
+ sed -e 's:/bin/sh:/bin/bash:' -i virt-what.in || die
+}