summaryrefslogtreecommitdiff
path: root/app-emulation/vice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/vice
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/Manifest3
-rw-r--r--app-emulation/vice/metadata.xml17
-rw-r--r--app-emulation/vice/vice-3.1.ebuild173
3 files changed, 193 insertions, 0 deletions
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
new file mode 100644
index 000000000000..7773d3a62c2c
--- /dev/null
+++ b/app-emulation/vice/Manifest
@@ -0,0 +1,3 @@
+DIST vice-3.1.tar.gz 30714226 BLAKE2B 75c2cce5294dad5b954cd23b623b6b4610c8142a09aef05dbefed6b3e6b268077d375e644dde6a057682d41ab9cf15e93a9f4a9359bfa0d1567d6d1862053a0e SHA512 bc02a3597a17dadb37c487e6942192c0e9dc1a7d4e440fbf0dc8a165dbb2dee60ddf157697a020d2780ddef56a0a67802768d5c6d117b9cf5cdc124de45bc579
+EBUILD vice-3.1.ebuild 4030 BLAKE2B a7729152f7e43ac7624ebd19ab72499edf3b5f254dbc051a994e9408c4a0e452594f90e05d3da77cee0d8ce7148bccd5e32f80743ea7b8f1ac1cb0a1ad91ade0 SHA512 f822b9e80318c7bb1b64084c879189e76a1dd235f2ff3ee3415393df8b5bcf988cbf07f1677bc18529982cb9d80f63c47cffb6f4b4385ebb046f13bb1b745b9d
+MISC metadata.xml 646 BLAKE2B 94f3652c8e4217e34415b84f35b468febdefb688fe85b5b0b2ddafa0b3739bc36fbfaab12e4100df1cad3c5b4cd823b4af260811110da4410c09d32596ac7f43 SHA512 1d641f0e1ba5962aa7b9e230c20ade01595aed9f853be25ec4d5022aff22cbd75414a41fbf64427bf5a27485057ee3e767521561f396a5bf70ffa3e1da31739f
diff --git a/app-emulation/vice/metadata.xml b/app-emulation/vice/metadata.xml
new file mode 100644
index 000000000000..ff9234728a4e
--- /dev/null
+++ b/app-emulation/vice/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="ethernet">Enable ethernet emulation</flag>
+ <flag name="fullscreen">Enable the ability to run fullscreen</flag>
+ <flag name="sdlsound">Use <pkg>media-libs/libsdl</pkg> for sound support</flag>
+ <flag name="vte">Enable support for <pkg>x11-libs/vte</pkg> in the GTK+ interface</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">vice-emu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/vice/vice-3.1.ebuild b/app-emulation/vice/vice-3.1.ebuild
new file mode 100644
index 000000000000..6fe9e2623e27
--- /dev/null
+++ b/app-emulation/vice/vice-3.1.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://vice-emu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vice-emu/releases/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="Xaw3d alsa ethernet ffmpeg fullscreen +gtk ipv6 lame libav nls oss png pulseaudio sdl +sdlsound threads vte zlib"
+
+# upstream says gtk3 and sdl2 shouldn't be exposed yet.
+#REQUIRED_USE="?? ( gtk2 gtk3 sdl )"
+REQUIRED_USE="?? ( gtk sdl )"
+
+GTK_COMMON="
+ x11-libs/pango
+ x11-libs/cairo"
+# gtk3? (
+# x11-libs/gtk+:3
+# vte? ( x11-libs/vte:2.90 )
+# ${GTK_COMMON}
+# )
+RDEPEND="
+ virtual/jpeg:0
+ virtual/opengl
+ media-libs/giflib
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdlsound? ( media-libs/libsdl[sound] )
+ ethernet? (
+ >=net-libs/libpcap-0.9.8
+ >=net-libs/libnet-1.1.2.1:1.1
+ )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:= )
+ )
+ lame? ( media-sound/lame )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng:0= )
+ zlib? ( sys-libs/zlib:= )
+ sdl? (
+ media-libs/libsdl[joystick,video]
+ )
+ !sdl? (
+ x11-libs/libX11
+ x11-libs/libXext
+ sys-libs/readline:0=
+ fullscreen? (
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ !gtk? (
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXv
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ ${GTK_COMMON}
+ vte? ( x11-libs/vte:0 )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir
+ x11-base/xorg-proto
+ media-libs/fontconfig
+ nls? ( sys-devel/gettext )
+ !sdl? (
+ !gtk? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ )"
+
+PATCH=(
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/building//' \
+ doc/Makefile.am || die
+ sed -i \
+ -e "/^docdir =/s:=.*:=/usr/share/doc/${PF}:" \
+ doc/Makefile.am \
+ doc/readmes/Makefile.am || die
+ sed -i \
+ -e "/^docdir =/s:=.*:=/usr/share/doc/${PF}/html:" \
+ doc/html/Makefile.am || die
+ sed -i \
+ -e "s:/usr/local/lib/VICE:/usr/$(get_libdir)/${PN}:" \
+ man/vice.1 \
+ $(grep -rl --exclude="*texi" /usr/local/lib doc) || die
+ sed -i \
+ -e "/VICEDIR=/s:=.*:=\"/usr/$(get_libdir)/${PN}\";:" \
+ configure.ac || die
+ sed -i \
+ -e "s:\(#define LIBDIR \).*:\1\"/usr/$(get_libdir)/${PN}\":" \
+ -e "s:\(#define DOCDIR \).*:\1\"/usr/share/doc/${PF}\":" \
+ src/arch/unix/archdep.h \
+ src/arch/sdl/archdep_unix.h || die
+ rm -rf src/lib/{libffmpeg,liblame} || die
+ sed -i \
+ -e '/SUBDIRS/s/libffmpeg//;' \
+ -e '/SUBDIRS/s/liblame//;' \
+ src/lib/Makefile.am || die
+ AT_NO_RECURSIVE=1 eautoreconf
+}
+
+src_configure() {
+ local gui_arg=() snd_arg=()
+
+ snd_arg+=( $(use_with alsa) )
+ snd_arg+=( $(use_with oss) )
+ snd_arg+=( $(use_with pulseaudio pulse) )
+ snd_arg+=( $(use_with sdlsound) )
+
+ gui_arg+=( $(use_enable sdl sdlui) )
+ # The gtk UI code has raw calls to XOpenDisplay and
+ # is missing -lX11 if vte doesn't pull it in.
+ #if use gtk2 || use gtk3 ; then
+ if use gtk ; then
+ use vte || append-libs -lX11
+ fi
+ gui_arg+=( $(use_enable gtk gnomeui) )
+ #gui_arg+=" $(use_enable gtk3 gnomeui3)"
+ gui_arg+=( $(use_enable Xaw3d xaw3d) )
+
+ # --with-readline is forced to avoid using the embedded copy
+ # don't try to actually run fc-cache (bug #280976)
+ FCCACHE=/bin/true \
+ PKG_CONFIG=$(tc-getPKG_CONFIG) \
+ econf \
+ --enable-parsid \
+ --with-resid \
+ --with-readline \
+ --without-arts \
+ --without-midas \
+ $(use_enable ethernet) \
+ $(use_enable ffmpeg) \
+ $(use_enable ffmpeg external-ffmpeg) \
+ $(use_enable fullscreen) \
+ $(use_enable ipv6) \
+ $(use_enable lame) \
+ $(use_enable nls) \
+ $(use_enable vte) \
+ $(use_with png) \
+ $(use_with threads uithreads) \
+ $(use_with zlib) \
+ "${gui_arg[@]}" \
+ "${snd_arg[@]}" \
+ --disable-option-checking
+ # --disable-option-checking has to be last
+}
+
+src_install() {
+ default
+ dodoc FEEDBACK
+}