summaryrefslogtreecommitdiff
path: root/app-emulation/vagrant
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /app-emulation/vagrant
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'app-emulation/vagrant')
-rw-r--r--app-emulation/vagrant/Manifest2
-rw-r--r--app-emulation/vagrant/vagrant-2.2.3.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 65427adf638f..b5bcb78a4849 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,6 +1,8 @@
AUX vagrant.in 1872 BLAKE2B a129780601946f3c53b1cb84dfce33d6cc912069dd784cb49e971990aad3a0c89dfcb26a83e8841fc5bd6353bb1b7d525e0e6794d3192f34bef273360abad450 SHA512 983d479aafd7954ed5b3a7a7158b9b84925ff6d3d52251be52c86caa97b0f319c8d79902357d4c16822852a3bbc6db113ecf1c907a49de40c480871d906fd1d5
DIST vagrant-2.1.5.tar.gz 1238788 BLAKE2B 8e3dfeb4d830fde1984c08b16422c99b51ce455fcc63e1fad0eca7860efccbf2e77edc13537bfa495345e585b559fe5462ae872decce036b45c1f54c453983ea SHA512 544216eb25c06a1ebddbadcc9d2d6a6dd9932e33d2554e3d51dba0e24a339b9afe0b85d1322bdb67c5de3d070aa4c854f1ccc931b23ea80f0625eb4d1f120238
DIST vagrant-2.2.2.tar.gz 1223645 BLAKE2B 595d26a11f27a23a9e66386820dec7c23fbafe079e9e9750e7cbc928cac2e965782abbb062f6b04efd367b56297d040af2b4f4f56d6df06e604f018110e10329 SHA512 70c83fcd896ae3b84fac22c539eb85db9bf08c8f75108d5f2b86841821cf7a885b72565814519b6f2ef3422d84d2f67fc402b983b1a15c1edfd0dc78196cd957
+DIST vagrant-2.2.3.tar.gz 1236158 BLAKE2B 083b153bc723b94aa543e02b275d1864dba5b2d7408266f8fe3813ba19302725aabc25e20e5b4df004055ea1ffa937f16f27307626cec137a253a6dab2b8f972 SHA512 ff3d95968a51a37a397342c013ebcc3bbfe7ff5b76fb35fead92e9a3b770c85f2f4720514aa68878b0b6e4fbd92629832dc1ddf925691529adf0c84c8f44d84c
EBUILD vagrant-2.1.5.ebuild 2278 BLAKE2B 0f9a9e8cbab0928c7ee1042577dc83efc00d4ec50114bdf93185483e21da24f99fe575da0b2e5844a7e5a343fe99ef3c43886ad0256221feecf60a8c49ba6878 SHA512 79b2752ec86feae5c21453a021ffe90c3734a1bcb4e313512a2fc89161d85e60d7b629818468df270c0cba43049b202535c6b4a9eed45659d64ab94d31a3203c
EBUILD vagrant-2.2.2-r2.ebuild 2453 BLAKE2B ced3f18626e649bf56e91b3deff46acc8d5cda0aeaefb5bd89357e688aae7fe5d7d339233a7e04e76c6d6e8a569741162d7b2b0bf6cf9bd266e397e39fb15b3e SHA512 8bbf87b8ddefffb6035caafa174e72942cc93277a4a57e42ee618914cebf1b1a1160bc9631057e3af28c14c0839f8d6ba57150f472d0196f5b04518dec828617
+EBUILD vagrant-2.2.3.ebuild 2453 BLAKE2B 432cac82d18a0e3b402d838fa4a9b38a66198ef027a88c4c4c5e0e1349da31f6cab1061681fde57210d5c312149b3b2ab91e42fb2d4ebbb8da16332266af1350 SHA512 2bb822310bd82cb95772c35b916f1c95aee50b4de9f0a75b0b323890f302d8bb0067c802212a00193fb2d2c5e1a2d4e279db1c7ec7cdc6e9aaf0215633bea501
MISC metadata.xml 413 BLAKE2B 1b57ae29cf2bcdf4bd7d97071e081818e114104bd5a22438e0fe47bd4bce9b2fc1b831c544579cc8b652860c9637caa9134e6f1a4abcb21216e39e62fa058862 SHA512 417deb9af12420ac037b15b526d77ea3fdad12d047c4ea9ede5465ea9ea772fe96ee1625714e74e6dbad6ee224916e9b9304c38293aec4c5e2a52555e1c9f4e8
diff --git a/app-emulation/vagrant/vagrant-2.2.3.ebuild b/app-emulation/vagrant/vagrant-2.2.3.ebuild
new file mode 100644
index 000000000000..a55cc3486a28
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.2.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.0.0
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/ed25519-1.2.4
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.1.1:1
+ >=dev-ruby/listen-3.1.5
+ <dev-ruby/log4r-1.1.11
+ <dev-ruby/mime-types-3:*
+ >=dev-ruby/net-ssh-5.1.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ dev-ruby/rest-client:2
+ >=dev-ruby/rubyzip-1.2.2
+ >=dev-ruby/vagrant_cloud-2.0.2
+"
+
+# upstream specifies rake>=12 but it apparently doesn't need something this
+# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
+# is tricky, we specify a lower dependency requirement here. This way, we'll be
+# able to stabilize vagrant sooner.
+ruby_add_bdepend "
+ >=dev-ruby/rake-10.5.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+}