summaryrefslogtreecommitdiff
path: root/app-emulation/spim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /app-emulation/spim
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'app-emulation/spim')
-rw-r--r--app-emulation/spim/Manifest1
-rw-r--r--app-emulation/spim/spim-8.0-r3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-emulation/spim/Manifest b/app-emulation/spim/Manifest
index 150814403c8a..1029fbcea0be 100644
--- a/app-emulation/spim/Manifest
+++ b/app-emulation/spim/Manifest
@@ -2,4 +2,5 @@ AUX spim-8.0-r1-respect_env.patch 5058 BLAKE2B dabd459ef87e3c9db6304703d2067297f
AUX xspim.svg 8364 BLAKE2B 0a2f13b78c87e821b6d669a750ea1be0003442f75c20c5387954c1e6c11f99f80b9e1a42ea88bc4e894011ff08cb8b40450674ec415d1be18eb63d5e2a9b0188 SHA512 1860705ef2677b5bd84b7cdf4daf3143033050e5ed014e22d63fc3bec48a0a296a9767fa7cbf7ab71f31c5cc712e40be0799a9c43b96c789273de7604d57c0d5
DIST spim-8.0.tar.gz 355204 BLAKE2B c7da952df552c5e070c601e7c3d251f15988d377e1c9943730f6cf8eee1e3b64ec4a05b56d4bdbc181b811aa349e3b08fccf0b9ccfc3efe2c0e410580e70dd7f SHA512 c4eb66863a931b74d6c6ecd92860d16fd6369c85caecba1e71a1149e73e708502d1070f17a9beb6d0af1368db1ee5a85c040b596866a1236275cdd410a661adf
EBUILD spim-8.0-r2.ebuild 1570 BLAKE2B 6a03d3b73d84f3a7bbf2b97d31f24465e23762fcb43b30239b5448ed9effce184d7bd6fc5e2ffd0714e3c5be44f0051f219b69a940d443d466bf7e76cd2d1fda SHA512 743da7bb89dcadb1be9bdbdebc86b64594d8b37d666230809f3440fb2df2f547ba25c78cfd43f6cc0d828e4071905f4f7915d2d78f8f98fa9be3e3145051888f
+EBUILD spim-8.0-r3.ebuild 1545 BLAKE2B 8ee89cd9e6ed068034adbb048d3c85bb4513113ca57b9402b87bc6487d7055455ef4f095911a26b450e1a9c1224c2abe4d21336ae01607958153dd8c462263f9 SHA512 21de18c91b8d1dcdfda5363b66fff47a42a117286697b7931c16f1a03790a7298bea59c5112d3a3bae3ace1e5ff3cc303219f7e895819c5ebb295b406263df13
MISC metadata.xml 465 BLAKE2B a26e388f7a6a0610e0fb4d4c59b0d1a60c3934927f41e0d953dfab8cef1c9fc5da06902263ba29d984db1f0d1d3f636d503b8fe605571f4976e9bbd3e28cf4be SHA512 624df1312b5a85232c892f18eb39a62877c085d79461cf875b46a107eeaf5b99a9062e8f175a62c80565d42b26144ab2227d2f97b2d67fe16e66890e2843fe6c
diff --git a/app-emulation/spim/spim-8.0-r3.ebuild b/app-emulation/spim/spim-8.0-r3.ebuild
new file mode 100644
index 000000000000..9fe7e6643e19
--- /dev/null
+++ b/app-emulation/spim/spim-8.0-r3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="MIPS Simulator"
+HOMEPAGE="http://spimsimulator.sourceforge.net/"
+SRC_URI="http://www.cs.wisc.edu/~larus/SPIM/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc X"
+
+RDEPEND="
+ X? (
+ media-fonts/font-adobe-100dpi
+ x11-libs/libXaw )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake
+ x11-proto/xproto )
+ sys-devel/bison
+"
+# test hangs forever, disabling it
+RESTRICT="test"
+
+src_prepare() {
+ # fix bugs 240005 and 243588
+ eapply "${FILESDIR}/${P}-r1-respect_env.patch"
+
+ #fix bug 330389
+ sed -i -e 's:-12-\*-75-:-14-\*-100-:g' xspim/xspim.c || die
+
+ default
+}
+
+src_configure() {
+ tc-export CC
+ emake -C spim configuration
+
+ if use X; then
+ emake -C xspim configuration
+ fi
+}
+
+src_compile() {
+ emake DESTDIR="${EPREFIX}" -C spim
+
+ if use X; then
+ emake DESTDIR="${EPREFIX}" EXCEPTION_DIR=/var/lib/spim \
+ -C xspim -j1 xspim
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C spim install
+ newman Documentation/spim.man spim.1
+
+ if use X; then
+ emake DESTDIR="${ED}" -C xspim install
+ newman Documentation/xspim.man xspim.1
+ fi
+
+ doicon "${FILESDIR}"/xspim.svg
+ make_desktop_entry xspim xSPIM xspim "ComputerScience;Science;Education"
+
+ dodoc Documentation/SPIM.html
+ dodoc ChangeLog Documentation/BLURB README VERSION
+ if use doc ; then
+ dodoc Documentation/TeX/{cycle,spim}.ps
+ fi
+}
+
+src_test() {
+ emake -C spim test
+}