summaryrefslogtreecommitdiff
path: root/app-emulation/spim/spim-8.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/spim/spim-8.0-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/spim/spim-8.0-r3.ebuild')
-rw-r--r--app-emulation/spim/spim-8.0-r3.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/spim/spim-8.0-r3.ebuild b/app-emulation/spim/spim-8.0-r3.ebuild
new file mode 100644
index 000000000000..2717b50ee23c
--- /dev/null
+++ b/app-emulation/spim/spim-8.0-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="MIPS Simulator"
+HOMEPAGE="http://spimsimulator.sourceforge.net/"
+SRC_URI="http://www.cs.wisc.edu/~larus/SPIM/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc X"
+
+RDEPEND="
+ X? (
+ media-fonts/font-adobe-100dpi
+ x11-libs/libXaw )
+"
+DEPEND="${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-misc/imake
+ )
+ sys-devel/bison
+"
+# test hangs forever, disabling it
+RESTRICT="test"
+
+src_prepare() {
+ # fix bugs 240005 and 243588
+ eapply "${FILESDIR}/${P}-r1-respect_env.patch"
+
+ #fix bug 330389
+ sed -i -e 's:-12-\*-75-:-14-\*-100-:g' xspim/xspim.c || die
+
+ default
+}
+
+src_configure() {
+ tc-export CC
+ emake -C spim configuration
+
+ if use X; then
+ emake -C xspim configuration
+ fi
+}
+
+src_compile() {
+ emake DESTDIR="${EPREFIX}" -C spim
+
+ if use X; then
+ emake DESTDIR="${EPREFIX}" EXCEPTION_DIR=/var/lib/spim \
+ -C xspim -j1 xspim
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C spim install
+ newman Documentation/spim.man spim.1
+
+ if use X; then
+ emake DESTDIR="${ED}" -C xspim install
+ newman Documentation/xspim.man xspim.1
+ fi
+
+ doicon "${FILESDIR}"/xspim.svg
+ make_desktop_entry xspim xSPIM xspim "ComputerScience;Science;Education"
+
+ dodoc Documentation/SPIM.html
+ dodoc ChangeLog Documentation/BLURB README VERSION
+ if use doc ; then
+ dodoc Documentation/TeX/{cycle,spim}.ps
+ fi
+}
+
+src_test() {
+ emake -C spim test
+}