summaryrefslogtreecommitdiff
path: root/app-emulation/ski/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/ski/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/ski/files')
-rw-r--r--app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch75
-rw-r--r--app-emulation/ski/files/ski-1.3.2-binutils.patch31
-rw-r--r--app-emulation/ski/files/ski-1.3.2-configure-withval.patch22
-rw-r--r--app-emulation/ski/files/ski-1.3.2-ncurses-config.patch25
-rw-r--r--app-emulation/ski/files/ski-1.3.2-no-local-ltdl.patch22
-rw-r--r--app-emulation/ski/files/ski-1.3.2-prototypes.patch31
-rw-r--r--app-emulation/ski/files/ski-1.3.2-remove-hayes.patch14
-rw-r--r--app-emulation/ski/files/ski-1.3.2-syscall-linux-includes.patch18
-rw-r--r--app-emulation/ski/files/ski-1.3.2-uselib.patch18
9 files changed, 256 insertions, 0 deletions
diff --git a/app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch b/app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch
new file mode 100644
index 000000000000..34a7d8183702
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch
@@ -0,0 +1,75 @@
+use standard AC_C_BIGENDIAN macro rather than trying to define it manually
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -155,52 +155,24 @@ AC_SUBST(GSKI_CFLAGS)
+ AC_SUBST(GSKI_LIBS)
+ AM_CONDITIONAL(WITH_GTK_INTERFACE, test "x$with_gtk" = "xyes")
+
+-dnl Target endianness
+-AC_ARG_ENABLE(bigendian,
+-AC_HELP_STRING([--enable-bigendian],
+- [the target is big endian default=no]),
+-ski_cv_c_target_bigendian=${enableval}, ski_cv_c_target_bigendian=no)
+-
+ dnl Check for host endianness
+ AC_CACHE_CHECK([whether host byte ordering is defined in sys/param.h],
+ ski_cv_c_bigendian_compile,
+ [AC_TRY_COMPILE([
+ #include <sys/types.h>
+ #include <sys/param.h>
+ ],[
+ #if !BYTE_ORDER || !BIG_ENDIAN || !LITTLE_ENDIAN
+ #error bogus endian macros
+ #endif
+ ],
+ ski_cv_c_bigendian_compile=yes, ski_cv_c_bigendian_compile=no)])
+
+ if test "x$ski_cv_c_bigendian_compile" = xyes; then
+ AC_DEFINE(ENDIANESS_IN_SYS_PARAM_H, 1,
+ [define if sys/param.h defines the endiness])
+-else
+-AC_CACHE_CHECK([whether host byte ordering is big endian],
+-ski_cv_c_bigendian,
+-[AC_TRY_RUN([int main () {
+- union {
+- long l;
+- char c[sizeof (long)];
+- } u;
+- u.l = 1;
+- return (u.c[sizeof (long) - 1] == 1);
+-}],
+-ski_cv_c_bigendian=no, ski_cv_c_bigendian=yes,
+-AC_MSG_ERROR([cannot detect host endianness]))])
+-
+-AC_DEFINE(BIG_ENDIAN, 4321, [define to 4321 if missing from sys/param.h])
+-AC_DEFINE(LITTLE_ENDIAN, 1234, [define to 4321 if missing from sys/param.h])
+-if test "x$ski_cv_c_bigendian" = xyes; then
+- AC_DEFINE(BYTE_ORDER, 4321,
+- [define to 4321 if host is big endian, 1234 if little endian])
+-else
+- AC_DEFINE(BYTE_ORDER, 1234,
+- [define to 4321 if host is big endian, 1234 if little endian])
+-fi
+ fi
++AC_C_BIGENDIAN
+
+ dnl Check for variables & functions
+
+--- a/src/std.h
++++ b/src/std.h
+@@ -62,6 +62,14 @@ extern unsigned long long __strtoull(const char *, char **, int);
+ # define BIG_ENDIAN 4321
+ # define LITTLE_ENDIAN 1234
+ # define BYTE_ORDER BIG_ENDIAN
++# else
++# define BIG_ENDIAN 4321
++# define LITTLE_ENDIAN 1234
++# ifdef WORDS_BIGENDIAN
++# define BYTE_ORDER BIG_ENDIAN
++# else
++# define BYTE_ORDER LITTLE_ENDIAN
++# endif
+ # endif /* !defined HAVE_CONFIG_H */
+ #endif /* !defined ENDIANESS_IN_SYS_PARAM_H */
+
diff --git a/app-emulation/ski/files/ski-1.3.2-binutils.patch b/app-emulation/ski/files/ski-1.3.2-binutils.patch
new file mode 100644
index 000000000000..71094f3bf4b6
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-binutils.patch
@@ -0,0 +1,31 @@
+From 30d3253c6b413ba22ca0ca30dcd4c4c24daec2e1 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue, 19 Aug 2014 09:42:43 +0300
+Subject: [PATCH] Fix build failure against binutils-2.16.1 and upper.
+
+Follow binutils' upstream change from 2004:
+
+ https://sourceware.org/git/?p=binutils.git;a=commitdiff;h=7e2dd9e4c3e0b69dcb7d471b891879b5fd28687e
+ > section.c (struct sec): Rename "_cooked_size" to "size".
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ src/linux/dwarf-linux.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/linux/dwarf-linux.c b/src/linux/dwarf-linux.c
+index 1941a1f..73be0e6 100644
+--- a/src/linux/dwarf-linux.c
++++ b/src/linux/dwarf-linux.c
+@@ -155,7 +155,7 @@ find_in_section (bfd * bfd, asection * sect, PTR obj)
+ first.function = function;
+ first.line = line;
+ first.num_lines = 1;
+- first.limit = sect->_cooked_size;
++ first.limit = sect->size;
+ last_line = line;
+ }
+ if (line > last_line
+--
+2.0.4
+
diff --git a/app-emulation/ski/files/ski-1.3.2-configure-withval.patch b/app-emulation/ski/files/ski-1.3.2-configure-withval.patch
new file mode 100644
index 000000000000..7bb3ce9fc85c
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-configure-withval.patch
@@ -0,0 +1,22 @@
+fix handling of 3rd/4th args to AC_ARG_WITH()
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -130,7 +130,7 @@ dnl See if we build X11
+ AC_ARG_WITH(x11,
+ AC_HELP_STRING([--with-x11],
+ [Enable the Motif based X11 interface default=no]),
+- [with_x11=yes],[with_x11=no])
++ [with_x11=$withval])
+
+ if test "x$with_x11" = "xyes"; then
+ dnl Check for motif, error out if not found
+@@ -144,7 +144,7 @@ dnl See if we build GTK
+ AC_ARG_WITH(gtk,
+ AC_HELP_STRING([--with-gtk],
+ [Enable building the GTK Ski interface default=no]),
+- [with_gtk=yes],[with_gtk=no]
++ [with_gtk=$withval]
+ )
+
+ if test "x$with_gtk" = "xyes"; then
diff --git a/app-emulation/ski/files/ski-1.3.2-ncurses-config.patch b/app-emulation/ski/files/ski-1.3.2-ncurses-config.patch
new file mode 100644
index 000000000000..4317df415efa
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-ncurses-config.patch
@@ -0,0 +1,25 @@
+use pkg-config to look up ncurses deps to support things like split tinfo
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -93,6 +93,7 @@
+ AC_PROG_SED
+ AC_PROG_YACC
+ AM_PROG_LEX
++PKG_PROG_PKG_CONFIG
+
+ AC_C_INLINE
+ AC_C_CONST
+@@ -304,9 +305,9 @@
+ fi
+
+ if test "x$check_curses" != xno; then
+-AC_CHECK_LIB(curses, tgetent, [],
+- [AC_CHECK_LIB(ncurses, tgetent, ,
+- [AC_MSG_ERROR(Required curses library not found.)])])
++ PKG_CHECK_MODULES([NCURSES], [ncurses])
++ CFLAGS="$CFLAGS $NCURSES_CFLAGS"
++ LIBS="$LIBS $NCURSES_LIBS"
+ fi
+
+ AC_CHECK_LIB(elf, elf_begin, [],
diff --git a/app-emulation/ski/files/ski-1.3.2-no-local-ltdl.patch b/app-emulation/ski/files/ski-1.3.2-no-local-ltdl.patch
new file mode 100644
index 000000000000..aa75146668b5
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-no-local-ltdl.patch
@@ -0,0 +1,22 @@
+build against the system ltdl rather than the local copy
+
+--- ski-1.3.2/src/Makefile.am
++++ ski-1.3.2/src/Makefile.am
+@@ -181,8 +181,7 @@
+ eparse.h \
+ libdas.h \
+ netdev.h \
+- osload.h \
+- ltdl.h
++ osload.h
+
+ EXTRA_linux_FILES = \
+ linux/dwarf-linux.c \
+@@ -279,7 +278,6 @@
+ eparse.y \
+ escan.l \
+ load.c \
+- ltdl.c \
+ platform.c \
+ libdas.c \
+ libsrs.c
diff --git a/app-emulation/ski/files/ski-1.3.2-prototypes.patch b/app-emulation/ski/files/ski-1.3.2-prototypes.patch
new file mode 100644
index 000000000000..b66614368708
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-prototypes.patch
@@ -0,0 +1,31 @@
+fix up prototypes to avoid -Wimplicit-function-declaration warnings
+
+--- a/src/coreui.h
++++ b/src/coreui.h
+@@ -177,6 +177,7 @@
+ void stepIt_setupGtk(CTR cnt);
+
+ void runIt_setupX(void);
++void runIt_setupGtk(void);
+
+
+ /*--------------------------------------------------------------------------
+--- a/src/ssGtk.c
++++ b/src/ssGtk.c
+@@ -82,6 +82,7 @@
+
+ /* externals */
+ extern dataStart;
++ADDR iAinstAddr(ADDR baseAddr, BYTE iAmode, int delta);
+
+ static GtkLabel* instcount_label;
+ /* sits in a background loop */
+@@ -100,7 +101,7 @@
+ }
+
+
+-void runIt_setupGtk(void *data)
++void runIt_setupGtk(void)
+ {
+ g_idle_add(runItGtk, NULL);
+ stopPressed = NO;
diff --git a/app-emulation/ski/files/ski-1.3.2-remove-hayes.patch b/app-emulation/ski/files/ski-1.3.2-remove-hayes.patch
new file mode 100644
index 000000000000..3e9de483fd17
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-remove-hayes.patch
@@ -0,0 +1,14 @@
+## Description: Remove references to HAYES
+## Origin/Author: Andreas Moog <amoog@ubuntu.com>
+## Bug-Ubuntu: https://bugs.launchpad.net/bugs/756157
+--- ski//src/linux/syscall-linux.c
++++ ski.new//src/linux/syscall-linux.c
+@@ -2250,8 +2250,6 @@
+ case TIOCSERSETMULTI: /* Set multiport config */
+ case TIOCMIWAIT: /* wait for a change on serial input line(s) */
+ case TIOCGICOUNT: /* read serial port inline interrupt counts */
+- case TIOCGHAYESESP: /* Get Hayes ESP configuration */
+- case TIOCSHAYESESP: /* Set Hayes ESP configuration */
+ case SIOCRTMSG: /* call to routing system */
+ case SIOCSIFLINK: /* set iface channel */
+ case SIOCGIFMEM: /* get memory address (BSD) */
diff --git a/app-emulation/ski/files/ski-1.3.2-syscall-linux-includes.patch b/app-emulation/ski/files/ski-1.3.2-syscall-linux-includes.patch
new file mode 100644
index 000000000000..e3c1083687ac
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-syscall-linux-includes.patch
@@ -0,0 +1,18 @@
+--- ski-1.3.2/src/linux/syscall-linux.c
++++ ski-1.3.2/src/linux/syscall-linux.c
+@@ -45,7 +45,6 @@
+ #include <linux/posix_types.h>
+ #include <linux/personality.h>
+ #include <linux/sockios.h>
+-#include <sys/io.h>
+
+ #include <sys/file.h>
+ #include <sys/fsuid.h>
+@@ -72,7 +71,6 @@
+ #include <sys/uio.h>
+
+ #include <linux/serial.h>
+-#include <asm/page.h>
+ #include <asm/unistd.h>
+
+ #include "std.h"
diff --git a/app-emulation/ski/files/ski-1.3.2-uselib.patch b/app-emulation/ski/files/ski-1.3.2-uselib.patch
new file mode 100644
index 000000000000..d600cb2ce3fa
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-uselib.patch
@@ -0,0 +1,18 @@
+https://bugs.gentoo.org/592226
+
+patch taken from Fedora
+
+glibc-2.23+ no longer exports the uselib function. make the syscall directly.
+
+--- ski-1.3.2/src/linux/syscall-linux.c
++++ ski-1.3.2/src/linux/syscall-linux.c
+@@ -554,7 +554,8 @@
+ extern void munmapSyms (ADDR, ADDR);
+ extern void dynBlock (ADDR, ADDR);
+ extern void memFree (ADDR);
+-extern int uselib (const char *libname); /* Linux specific */
++#include <sys/syscall.h>
++#define uselib(libname) syscall(__NR_uselib, libname)
+
+ extern int setresuid (uid_t, uid_t, uid_t);
+ extern int getresuid (uid_t *, uid_t *, uid_t *);