summaryrefslogtreecommitdiff
path: root/app-emulation/runv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/runv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/runv')
-rw-r--r--app-emulation/runv/Manifest3
-rw-r--r--app-emulation/runv/metadata.xml12
-rw-r--r--app-emulation/runv/runv-0.7.0.ebuild45
3 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/runv/Manifest b/app-emulation/runv/Manifest
new file mode 100644
index 000000000000..4dea666681c1
--- /dev/null
+++ b/app-emulation/runv/Manifest
@@ -0,0 +1,3 @@
+DIST runv-0.7.0.tar.gz 1143867 BLAKE2B b425060493567470bdc886c75a4edd1333094cf3479a06b63286e4ba391d1a3bb82b7c3331a1455f0a2545bebe4c2397112cba3bfb5573a3a62e380dcd69d473 SHA512 1303d4ca99186d9f5c1db4257acecf1702546a084942cc4c51de8685c6841da45be72c78f32ab38e2addb80dc40fe4d022d0fcae7b7d6b6d62a30f434cea178c
+EBUILD runv-0.7.0.ebuild 947 BLAKE2B ded3d6380428072c7961cf39e0e2b68384aad6a1569c019cd9f773c02836e9e85baa2d050de74672333620eac49b227764866895de6c724810af8cfb0ed8f316 SHA512 be820826c8ca3e46afef230444551dc4b4dd749692b4b6af136d33d7cb527278245346d6a7d4b8e1411219b9ef9212806c612a5dabe5166ecbaeff4cc2e18357
+MISC metadata.xml 388 BLAKE2B d1aa83ee5b10e9ea14b5cc41e7b1e125c0471e0a0eab3346d1dbad7d3bd53978dd37039659d2e99378058b98cd201203a97bcb161d68991ad8ef1e6d30acc284 SHA512 725bb42e13601ab25797d7343813a64cf214b4ab9c212621de2b91df0553817e428c6ec559b611c075746e273e003aac18b2ff23f66b36c65366efb73b60e06a
diff --git a/app-emulation/runv/metadata.xml b/app-emulation/runv/metadata.xml
new file mode 100644
index 000000000000..af5a58145e7f
--- /dev/null
+++ b/app-emulation/runv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="libvirt">Enable support for KVM via libvirt</flag>
+ <flag name="xen">Enable support for the Xen Hypervisor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hyperhq/runv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/runv/runv-0.7.0.ebuild b/app-emulation/runv/runv-0.7.0.ebuild
new file mode 100644
index 000000000000..3df1bcf0df82
--- /dev/null
+++ b/app-emulation/runv/runv-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/hyperhq/runv"
+
+inherit autotools golang-vcs-snapshot
+
+DESCRIPTION="Hypervisor-based Runtime for OCI"
+HOMEPAGE="https://github.com/hyperhq/runv"
+SRC_URI="https://github.com/hyperhq/runv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libvirt xen"
+
+RDEPEND="libvirt? ( >=app-emulation/libvirt-1.2.2 )
+ xen? ( app-emulation/xen )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ pushd src/github.com/hyperhq/runv/ || die
+ default
+ eautoreconf
+ popd
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with libvirt)
+ $(use_with xen) )
+ pushd src/github.com/hyperhq/runv/ || die
+ econf "${myeconfargs[@]}"
+ popd
+}
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" emake -C src/github.com/hyperhq/runv/
+}
+
+src_install() {
+ dodoc src/${EGO_PN}/README.md
+ dobin src/${EGO_PN}/runv
+}