summaryrefslogtreecommitdiff
path: root/app-emulation/runc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-emulation/runc
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/Manifest2
-rw-r--r--app-emulation/runc/runc-1.0.0_rc92.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
index fa78653a6fe9..c0d121ca40a9 100644
--- a/app-emulation/runc/Manifest
+++ b/app-emulation/runc/Manifest
@@ -1,3 +1,5 @@
DIST runc-1.0.0_rc10.tar.gz 1929802 BLAKE2B 8399c3d62726bbb6256efef7e15b7496a7172bf25170b12beb60be498967dec4fde2aebd073de4265e132ff864bafc4d2499ab677390a4f7c0a1605d83ae55e5 SHA512 598221071ef07d18bf34bf5d5c68b8ad78ee71716177fc3ce5b6909cd841d5aed93f17ebf1f3d134707d29eef1f54a4ddc21e79621a9bd957df28a8d2e028ab7
+DIST runc-1.0.0_rc92.tar.gz 2061469 BLAKE2B 06444eaf7602fe9ddaf7728c7f55bd718d1fe8f5f0ce6b21abc49a1d84eaa2fc3550d0d275ba5548ee9ebb6948a8ed415de8562a990d6085d1da8fb37e46afb9 SHA512 770a31736f5ab4ba359d91bd236750511f90b29af0af2bad5c238b611f465d7302e78b57ce8a702068440fda2d74588b92fd4d24c6d34e6fc1bd649ea3d8ee40
EBUILD runc-1.0.0_rc10-r1.ebuild 1837 BLAKE2B ffc28565f2daf8dbda38f643dfb2bd26596531a19b3087a17a3f59a9c535080ac93c530c21055716a5d4c36211a62e3aecce74ed385a0446bb47784bd49e8420 SHA512 cdceb2bf1583bdb678da403a3e47bd4cdcdf1af081889ca36da0bdf606e93d477950e1e8e58d51d7d36d78a4a7f482bdc49e677f106f53e8d4326fbc2e56b820
+EBUILD runc-1.0.0_rc92.ebuild 1775 BLAKE2B 0a82eb9eb4e9b70cf4679da76b9cc81a9bddfadd3137c905f46fa551e68d2b6f75adc72de725178675f77e73ae3f5b4c6d88b3c8355f7d7c23b657cd8f96613c SHA512 3fed1c9dc08706ec96d5315888b04f2558d2f004b8af595f74b2b0aa384b63c624144bf793ce3e6547975e536d919da3c2e949e3d42dba3d0b3b107fed76b664
MISC metadata.xml 876 BLAKE2B db5667a946ce043848f7cf87bcaa8c03594e9c4c35186fc905befd344202028742ab51a783751629086fc79cc3d6ee0d5b316978b2aa8677d6f47bd167fdca99 SHA512 0ad802b914d57523092f574450357bf90d54bce93d22e217061fce2817f68a43e5fd3402f80820c2b5e33ade763cb91ddb261250bfddf8ec4785e457981d69f0
diff --git a/app-emulation/runc/runc-1.0.0_rc92.ebuild b/app-emulation/runc/runc-1.0.0_rc92.ebuild
new file mode 100644
index 000000000000..2a192400ef49
--- /dev/null
+++ b/app-emulation/runc/runc-1.0.0_rc92.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module linux-info
+
+# update on bump, look for https://github.com/docker\
+# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/runc.installer
+RUNC_COMMIT=ff819c7e9184c13b7c2607fe6c30ae19403a7aff
+CONFIG_CHECK="~USER_NS"
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+MY_PV="${PV/_/-}"
+SRC_URI="https://github.com/opencontainers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="apparmor +ambient hardened +kmem +seccomp selinux test"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+
+RDEPEND="
+ ${DEPEND}
+ !app-emulation/docker-runc
+ apparmor? ( sys-libs/libapparmor )
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ test? ( "${RDEPEND}" )
+"
+
+# tests need busybox binary, and portage namespace
+# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
+# majority of tests pass
+RESTRICT+=" test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usev ambient)
+ $(usev apparmor)
+ $(usev seccomp)
+ $(usev selinux)
+ $(usex kmem '' 'nokmem')
+ )
+
+ myemakeargs=(
+ BINDIR="${ED}/usr/bin"
+ BUILDTAGS="${options[*]}"
+ COMMIT=${RUNC_COMMIT}
+ DESTDIR="${ED}"
+ PREFIX="${ED}/usr"
+ )
+
+ emake "${myemakeargs[@]}" runc man
+}
+
+src_install() {
+ emake "${myemakeargs[@]}" install install-man install-bash
+
+ local DOCS=( README.md PRINCIPLES.md docs/. )
+ einstalldocs
+}
+
+src_test() {
+ emake "${myemakeargs[@]}" localunittest
+}