summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 05:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 05:27:58 +0100
commit90cc39f2232ae2db1954af4df82965ad2960c174 (patch)
tree40a69f630c68a907a2114e099b74df3d4024bb8c /app-emulation/ruffle/ruffle-9999.ebuild
parent2f3183511d8fcc1dd014e08f7c2535790512213d (diff)
gentoo auto-resync : 15:10:2023 - 05:27:58
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index fbc440002e65..a54f26933afa 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -78,9 +78,20 @@ src_configure() {
exporter
$(usev test tests)
)
+
cargo_src_configure ${workspaces[*]/#/--package=}
}
+src_test() {
+ local skip=(
+ # may need more investigation, strangely "pass" (xfail) when
+ # RUSTFLAGS is unset, skip for now (bug #915726)
+ --skip from_avmplus/as3/Types/Int/wraparound
+ )
+
+ cargo_src_test -- "${skip[@]}"
+}
+
src_install() {
dodoc README.md