summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-16 14:53:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-16 14:53:46 +0000
commitf5588424e3182e3006f725536eebd7dc7b5bbfd4 (patch)
tree2c2ccb3df6c5e1039da984d110f02d0c2ec12cf1 /app-emulation/ruffle/files
parentd969fd257186a9d8083279276697f827331f0e46 (diff)
gentoo auto-resync : 16:12:2023 - 14:53:46
Diffstat (limited to 'app-emulation/ruffle/files')
-rw-r--r--app-emulation/ruffle/files/ruffle-0_p20231216-no-patch.patch10
-rw-r--r--app-emulation/ruffle/files/ruffle-0_p20231216-skip-render-tests.patch16
2 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/ruffle/files/ruffle-0_p20231216-no-patch.patch b/app-emulation/ruffle/files/ruffle-0_p20231216-no-patch.patch
new file mode 100644
index 000000000000..28a8c7b19ce9
--- /dev/null
+++ b/app-emulation/ruffle/files/ruffle-0_p20231216-no-patch.patch
@@ -0,0 +1,10 @@
+Prevent double-patching with GIT_CRATES usage.
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -86,6 +86 @@
+
+-[patch.crates-io]
+-# These are needed because https://github.com/gfx-rs/wgpu/pull/4778
+-# is not yet in the latest wgpu release. TODO: Remove when it is.
+-wgpu = { git = "https://github.com/gfx-rs/wgpu", branch = "v0.18" }
+-naga = { git = "https://github.com/gfx-rs/wgpu", branch = "v0.18" }
diff --git a/app-emulation/ruffle/files/ruffle-0_p20231216-skip-render-tests.patch b/app-emulation/ruffle/files/ruffle-0_p20231216-skip-render-tests.patch
new file mode 100644
index 000000000000..ef39453b7d58
--- /dev/null
+++ b/app-emulation/ruffle/files/ruffle-0_p20231216-skip-render-tests.patch
@@ -0,0 +1,16 @@
+Running renderer tests using mesa's software rendering has a tendency
+to misbehave (esp. on tinderboxes) and does not reflect usage on real
+hardware.
+
+These are auto-skipped if mesa[-gles2] and perhaps [-llvm], but pretend
+we lack support even if conditions are met.
+
+https://bugs.gentoo.org/903295
+https://bugs.gentoo.org/911320
+https://bugs.gentoo.org/911367
+--- a/tests/framework/src/options.rs
++++ b/tests/framework/src/options.rs
+@@ -170,2 +170,3 @@
+ if let Some(render) = &self.with_renderer {
++ if check_renderer { return false; }
+ // If we don't actually want to check the renderer (ie we're just listing potential tests),