summaryrefslogtreecommitdiff
path: root/app-emulation/qtrvsim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
commita5442e2318cb4df55867389654e322dbac82067e (patch)
tree6ee33490658219395df804dbba0ea77f8b0d8c3b /app-emulation/qtrvsim
parent5d8ffbc273ca664e15618d557ced3e02de1a884b (diff)
gentoo auto-resync : 08:07:2024 - 12:25:03
Diffstat (limited to 'app-emulation/qtrvsim')
-rw-r--r--app-emulation/qtrvsim/Manifest1
-rw-r--r--app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emulation/qtrvsim/Manifest b/app-emulation/qtrvsim/Manifest
index 0f54fcd43d6a..a7bfc5df04a2 100644
--- a/app-emulation/qtrvsim/Manifest
+++ b/app-emulation/qtrvsim/Manifest
@@ -1,3 +1,4 @@
DIST qtrvsim-0.9.7.tar.gz 1421805 BLAKE2B 9128dbe513860eafd01e0f37a99547797d385b57a404e06aea310404012e66e6be802920cdea62acb914d355fc842cd3759fc794d2cd417257b941f9ec62fbec SHA512 0d53e21681630cbf97db472472bd96dfe4914e0d275a1094cb18a7f0372cef23b0dea3c33092b6ab6d2403737070ef0b6f2b1f5d9d35eea8923b24a80ac6adfe
+EBUILD qtrvsim-0.9.7-r1.ebuild 635 BLAKE2B da059c78436cea896ea063c3376f097876d1f6c0042ee832bae0255a33a743003fe526ede2f037299bfd9e041eff1fab9d60308470b065e24d3ec2bef230c698 SHA512 f6240d50c2f88adcf606d1b7598f939b38ec7352af4ace285723df5ab81f00580c8b0aa84471ab4272fe0c37cc4e2e6df632ce15be62f4c7b24d4c27e4492340
EBUILD qtrvsim-0.9.7.ebuild 503 BLAKE2B 6d410a39d6233669a391c14fa854c1ca0bc5c1ac9454600d7eb0380465bcfa3048c24d81294bfbc9a2b366a447ae71d45b5c4a7201cfd35c4ff4e3f2db40b812 SHA512 1622a493e4ba9c9ce0d0579c6b0672b3abb576519e154836514abec1a1c244f35c4535d129dbec968a367b649da89f50eb8ea4e102a927e8b71217f0ebd5e92e
MISC metadata.xml 324 BLAKE2B 88e9410454f1433824206295d14983c6cd3121248db77d052d1aadce997e7fdcbfa982837bbe3ec01038af57e3d54ac0f025874c91f3e4b938a17d330b185e98 SHA512 be34381fedb16ca3f974824e0c7af4033cc1f3fd0089e93449fd04dc84624581a05ee9083dc23b12fa58f6a55994e77a0fe58b5a9263b55b36acdd52e071591f
diff --git a/app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild b/app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..a50f1b567a64
--- /dev/null
+++ b/app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="RISC-V CPU simulator for education"
+HOMEPAGE="https://github.com/cvut/qtrvsim"
+SRC_URI="https://github.com/cvut/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # Fails in 0.9.7, but not in master.
+ cli_stalls
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # ensure Qt6 build
+ sed "/^ *find_package.*QT NAMES/s/Qt5 //" \
+ -i CMakeLists.txt || die
+}