summaryrefslogtreecommitdiff
path: root/app-emulation/qt-virt-manager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/qt-virt-manager
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/qt-virt-manager')
-rw-r--r--app-emulation/qt-virt-manager/Manifest2
-rw-r--r--app-emulation/qt-virt-manager/metadata.xml14
-rw-r--r--app-emulation/qt-virt-manager/qt-virt-manager-9999.ebuild49
3 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/qt-virt-manager/Manifest b/app-emulation/qt-virt-manager/Manifest
new file mode 100644
index 000000000000..e7c79d5934fd
--- /dev/null
+++ b/app-emulation/qt-virt-manager/Manifest
@@ -0,0 +1,2 @@
+EBUILD qt-virt-manager-9999.ebuild 1021 BLAKE2B cc6a88b0d570b4da55372a887e1f4ded595daf79958f31052e977a1b0c6921a95b83dd231b738708b524af1bbe3aa28f088d2853f0ff753a1fac452d5ecbcc89 SHA512 f2bafb1bc9b57f4466c8acc1f0079e61c810972993887fa7890d5340daff29641a7714bcc07065bb3f67eb4498898833f822fa48fd5e129fa4eaa77d65291a5f
+MISC metadata.xml 471 BLAKE2B 7307e926dce20e9bdbb4cd61e7f0aca3db7dfd26d6a5513db65dafe0f650ed18ad91e331204d0850249fc335a8088870bdb8ed8666815d60108043bf1d7ffe11 SHA512 b0637d54fe36b6879123c672b7b0a2eeab9fb8c2c6d46618a10b17dd279165eef5fe3258efa5d73e096b088ebef0030da244e3ad3383074b7726de5da06234d2
diff --git a/app-emulation/qt-virt-manager/metadata.xml b/app-emulation/qt-virt-manager/metadata.xml
new file mode 100644
index 000000000000..911710bc8d2c
--- /dev/null
+++ b/app-emulation/qt-virt-manager/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <use>
+ <flag name="smartcard">Enable smartcard remoting using <pkg>app-emulation/libcacard</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">F1ash/qt-virt-manager</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/qt-virt-manager/qt-virt-manager-9999.ebuild b/app-emulation/qt-virt-manager/qt-virt-manager-9999.ebuild
new file mode 100644
index 000000000000..7eb26346c9a9
--- /dev/null
+++ b/app-emulation/qt-virt-manager/qt-virt-manager-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/F1ash/qt-virt-manager.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/F1ash/qt-virt-manager/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="A GUI application for managing virtual machines"
+HOMEPAGE="https://github.com/F1ash/qt-virt-manager"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="smartcard"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-qt/qtnetwork:5
+ >=x11-libs/qtermwidget-0.7.0
+ smartcard? ( >=app-emulation/libcacard-2.5.0 )
+ dev-libs/glib
+ net-misc/spice-gtk
+ net-libs/libvncserver
+ app-emulation/libvirt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT_VERSION=5
+ -DWITH_LIBCACARD="$(usex smartcard ON OFF)"
+ )
+ cmake-utils_src_configure
+}