summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/qemu-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 16:26:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 16:26:18 +0100
commit3221bf225fb68a31e281fcdbfde4cea0d576d946 (patch)
tree63e4f978840b705bebc18062b4d599ae75fd32e1 /app-emulation/qemu/qemu-9999.ebuild
parent64b277f858d171900cba8a53e675ef8c3ff893fc (diff)
gentoo auto-resync : 06:09:2023 - 16:26:18
Diffstat (limited to 'app-emulation/qemu/qemu-9999.ebuild')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index cca0a24a89c0..6ca0885e7e59 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -25,11 +25,7 @@ if [[ ${PV} == *9999* ]]; then
QEMU_DOCS_PREBUILT=0
EGIT_REPO_URI="https://gitlab.com/qemu-project/qemu.git/"
- EGIT_SUBMODULES=(
- tests/fp/berkeley-softfloat-3
- tests/fp/berkeley-testfloat-3
- subprojects/keycodemapdb
- )
+ EGIT_SUBMODULES=()
inherit git-r3
SRC_URI=""
else
@@ -440,6 +436,14 @@ check_targets() {
popd >/dev/null
}
+if [[ ${PV} == 9999 ]]; then
+src_unpack() {
+ git-r3_src_unpack
+ cd "${P}" || die
+ meson subprojects download keycodemapdb berkeley-softfloat-3 berkeley-testfloat-3 || die
+}
+fi
+
src_prepare() {
check_targets IUSE_SOFTMMU_TARGETS softmmu
check_targets IUSE_USER_TARGETS linux-user
@@ -454,7 +458,7 @@ src_prepare() {
MAKEOPTS+=" V=1"
# Remove bundled modules
- rm -r subprojects/dtc roms/*/ || die
+ rm -r roms/*/ || die
}
##