summaryrefslogtreecommitdiff
path: root/app-emulation/q4wine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /app-emulation/q4wine
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'app-emulation/q4wine')
-rw-r--r--app-emulation/q4wine/Manifest2
-rw-r--r--app-emulation/q4wine/q4wine-1.3.11.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/q4wine/Manifest b/app-emulation/q4wine/Manifest
index 5787945e3629..1a9307964684 100644
--- a/app-emulation/q4wine/Manifest
+++ b/app-emulation/q4wine/Manifest
@@ -1,3 +1,5 @@
+DIST q4wine-1.3.11.tar.bz2 2868845 BLAKE2B 98893b1f65bcb8b8f301d7046a650658a9537849818fddf4803471a626f24d8c812867daec1f167b1fa5cdce9f9c0c50323d715ea06c51f3d52f85904257d2b0 SHA512 95ac66632bc46b10659e1d0e5f3c68b73934a85ddcc6582abd367d28f9949ad0ca732a5596db800bbc76b40ae7cf05fd95febf6d8b44db20cf710c2c1e23288f
DIST q4wine-1.3.6.tar.bz2 2867547 BLAKE2B b35a638e514108e4ee4be34b446a7d2d5ba00415d8f54cfee293988707b637d41945d3197a2132147e09d5a05153fd47a55701dcba358f3a2b3a2e6037f78aaa SHA512 1ff0ea2a4523fc5582ec67f5e305622653c4e387ac5f2cecde52289117ef879a60261fdbf9ddf421812765539124d4c5b6b37ff401530d3e061723a3c35d57f8
+EBUILD q4wine-1.3.11.ebuild 1200 BLAKE2B fb469ac35923c88f8385d52518d05cc6f6a690e53a788b399ef11a8de0499b9a7b821640b435120b6dd871028a06b3ef4cf1f48a2fb512478fc24d817591fa00 SHA512 32b6adfa756ab4b9d45656b808c64aab15fd7d24280c6f6dbcbfcd3218af4278b6b2eaae14e020b8ce19b8415bbea17e7cba514cbf8347a05ec465dfcd369155
EBUILD q4wine-1.3.6-r1.ebuild 1360 BLAKE2B 1b5be13d28f3292a3ce36263b362cbd51099b51ced181866c5ea7bc88443fd83b561a9794b0ef767b9376ff7a469bb1089d20d9575c53d8938bd9ab4ca12aa3d SHA512 58a1a5adc2f3c3767d0168a78e3e7c90da2827dc630572a5f5b7e5139a6c69c3c6cde15d6328056ab547962d665837bd9364557c284b2aa4442aa033a92591c7
MISC metadata.xml 641 BLAKE2B af03073e86a430ccc228ba18c2dd18d4fe8d07438e5beec07f3712807a792829096cb3eeaa4e912a80c2634a1bb16ef20ddbc08684fc4fdf2b14d839cd520733 SHA512 707f77ef56bb3bcbe4bda434f1262f77c0b337a8789508e0df04d2cd791959ca7dc67b74ac81b6e248023f3da83c86bcf7f185ca689ab7b3bf346250850df8ed
diff --git a/app-emulation/q4wine/q4wine-1.3.11.ebuild b/app-emulation/q4wine/q4wine-1.3.11.ebuild
new file mode 100644
index 000000000000..3466e650c02d
--- /dev/null
+++ b/app-emulation/q4wine/q4wine-1.3.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake-utils
+
+# Upstream names the package PV-rX. We change that to
+# PV_pX so we can use portage revisions.
+MY_P=${PN}-${PV/_p/-r}
+
+DESCRIPTION="Qt GUI configuration tool for Wine"
+HOMEPAGE="https://q4wine.brezblock.org.ua/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+dbus debug +ico +iso +wineappdb"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ ico? ( >=media-gfx/icoutils-0.26.0 )
+"
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ >=sys-apps/which-2.19
+ iso? ( sys-fs/fuseiso )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEBUG=$(usex debug ON OFF)
+ -DWITH_ICOUTILS=$(usex ico ON OFF)
+ -DWITH_SYSTEM_SINGLEAPP=ON
+ -DWITH_WINEAPPDB=$(usex wineappdb ON OFF)
+ -DUSE_BZIP2=OFF
+ -DUSE_GZIP=OFF
+ -DWITH_DBUS=$(usex dbus ON OFF)
+ )
+ cmake-utils_src_configure
+}