summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 19:37:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 19:37:38 +0100
commitd01ca4361883c2aec4ffb1c2dcd75980773fdc31 (patch)
treeb918b6c397ceb2422bde7865f55fd37ff8eef908 /app-emulation/protontricks
parent7b02e37a04e4051a91a109814d386711f41f9a4b (diff)
gentoo auto-resync : 13:07:2022 - 19:37:38
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.9.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index e5da7072c0c9..bfdb661192e0 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,3 +1,5 @@
DIST protontricks-1.8.2.tar.gz 153142 BLAKE2B c0757973f7e1c442ab0bba27c2c739a7b24d45bab31ec308ec195290e35392d222369dbfe64f558e21ed1b61d13bdae629c0ba8b2f81b9af2b4f2f94c30ba9ea SHA512 9b83c34847e8ea8ae86f77330f626748a8ef5682c99619d90fea0c52de3ccd5b4285e5dfc676b8c046b9deec996847dbb0586596428507e162e255a852b28cd1
+DIST protontricks-1.9.0.tar.gz 154202 BLAKE2B e998bd899ec953ed7ee0bb0f3944da0212b71f2d0eef6c6996040e4d9c607f7bc73b52df4cbc6a70480b308473fa8c0978415a6202f498247bf91662761adf5c SHA512 43ffd2a5cd4d58c44696a2a66da0223a93d553822fdc92a476c661d69f7522d2aef12787bfc33610751bc1171fb1a3da169e3d40a2b60863a9f37ed205771835
EBUILD protontricks-1.8.2.ebuild 1561 BLAKE2B 8e363eb3c10b00c76e33654b1435d0e94d27941d53f17666dfa8450e9bf9a40f913fa9c66bd7d1f9d8f35e625c46ab0c50b20953734c370dfd770004c7a2c4d8 SHA512 dc3a8f17876d26da53bb9a8018aa6b754e503782bdde6b464e3353ba67ea51c9405f1b93c3d3f63f9aaa91cb7bf6542318ed3eba7bd111cd54ea58108d88882e
+EBUILD protontricks-1.9.0.ebuild 1562 BLAKE2B 301f4eb1b8aa3ca6801a560614f1eaee2f917791a74eeaf173a1f3373a9768c87d2308bd8089dcd7448c3658f580476063dbffc637a2b9aac82dadb2d55f761b SHA512 5152a113f79b6788996dceebe23a64ee3ff8db232c6d89fa02500e4f18013c96079e2aa58a441636d4286232a581744504a0c08e3b9338fac3fb7b7b590e4cb2
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.9.0.ebuild b/app-emulation/protontricks/protontricks-1.9.0.ebuild
new file mode 100644
index 000000000000..d33c17e8e46a
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.9.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}