summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-emulation/protontricks
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest3
-rw-r--r--app-emulation/protontricks/metadata.xml18
-rw-r--r--app-emulation/protontricks/protontricks-1.3.1.ebuild46
3 files changed, 67 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
new file mode 100644
index 000000000000..e4c6c77e96e3
--- /dev/null
+++ b/app-emulation/protontricks/Manifest
@@ -0,0 +1,3 @@
+DIST protontricks-1.3.1.tar.gz 57784 BLAKE2B ed013367a2cc2384e4340379e2c23999a556ed26920ad59dfd7a8f773e490ee76e253a5fe3216e651cdcdb3e225a2e394255500c611d24f6bf9029582d55bb1f SHA512 4e33334e219db2e6679b430ee42408529478834c80c7da3b9bece4756eb27b9331d49a6a884de8a7ced5ec29d78ce831fee4cfbf6d5adcd750666b7e7a1e5607
+EBUILD protontricks-1.3.1.ebuild 1165 BLAKE2B b25d9cba69e98b330a32331cdc22931682da7de171c518967b007a9ad29fb316f6294aa1e6bb32e9869d5f0f69028e572a63be005ff1a210167ca9fddb663cd1 SHA512 a8f5a346f99154c5bea0c1d3493e17dc8d49dad0290c215ff678ee833db0bec47b1b3bee5663250660c6fde75b2a7da2b9fb77097c158706b28eeba78d9888b9
+MISC metadata.xml 784 BLAKE2B 37e795944e32ef3f17022efa4ad352e3ee2d1819f3e7ee4ccf02f2366156c999290b4b309c924f54dfde4a5ffc017628c36ead987da2101d2eb38c1eaa767e3e SHA512 6bccb95acbe4cf3b64b4734f98dc4495bd20df294efa0b628f08f4c2ee6bb6c5d103bd323ac29dddb02d2a7ff4ac88ccccdce8a8c01b856aef051eaae6cdb0ae
diff --git a/app-emulation/protontricks/metadata.xml b/app-emulation/protontricks/metadata.xml
new file mode 100644
index 000000000000..e18d1ed94ac5
--- /dev/null
+++ b/app-emulation/protontricks/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription lang="en">
+ A simple wrapper script that allows you to easily run Winetricks commands for Steam Play/Proton
+ games. This is often useful when a game requires closed-source runtime libraries that are not
+ included with Proton, or to activate Gallium Nine (native Direct3D 9 support) for a Proton game,
+ without all the tedious messing around with Wine prefixes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Matoking/protontricks</remote-id>
+ <remote-id type="pypi">protontricks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/protontricks/protontricks-1.3.1.ebuild b/app-emulation/protontricks/protontricks-1.3.1.ebuild
new file mode 100644
index 000000000000..0b0e576d39a3
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://codeload.github.com/Matoking/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="${PYTHON_DEPS}
+ app-emulation/winetricks
+ dev-python/vdf[${PYTHON_USEDEP}]
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+DOCS=(CHANGELOG.md README.md)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}