summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emulation/protontricks
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.8.2.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 36f5e2f0c5c5..2c07486e0ac2 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,5 +1,7 @@
DIST protontricks-1.7.0.tar.gz 139203 BLAKE2B d93bbb672286d32743da1473e132508084bae527159911367c51e88686c38d3bad0a2f72a2c0f0feb09412e31e6d5bb20dfe113b9e71e4e655693bfbe663a968 SHA512 c12f211051bc23c8eb03c5385e8245361d72dcce1e641a7da1f87f344db5fdc7d698bd7691e0855ae025c1d94944db89b380805664d87123b6252d06259480ff
DIST protontricks-1.8.1.tar.gz 151972 BLAKE2B 1e7b600bfc22c46e879c5684229e374699548bc96d172c23d4b3c7c08871c0baf629436e81ad35d0d5e93e11515c8a20d4365658d10610cd60b04d6982b83b7c SHA512 246e65f61ef4fd6825e426aa2b4ed3df26ad1443fabca079194890a8115805ff2f51be96ce410854407b61451dafbec6abd1e26f029c1e442af10a209c75377a
+DIST protontricks-1.8.2.tar.gz 153142 BLAKE2B c0757973f7e1c442ab0bba27c2c739a7b24d45bab31ec308ec195290e35392d222369dbfe64f558e21ed1b61d13bdae629c0ba8b2f81b9af2b4f2f94c30ba9ea SHA512 9b83c34847e8ea8ae86f77330f626748a8ef5682c99619d90fea0c52de3ccd5b4285e5dfc676b8c046b9deec996847dbb0586596428507e162e255a852b28cd1
EBUILD protontricks-1.7.0.ebuild 1561 BLAKE2B e9d4a3c2b48ce79f6639d2c6efc146797fdfee1ce6d0dd68d61381e19c9ef3c6643b0737f0b982e5f2e395ef8668c01e49e5cb4de22c77e646caeac9fe9e2966 SHA512 5fbd53dd0a4ddcc4ef760225231fecd12603135aa4a4fda2cf5ae7f956bbb849c6fa2e4747fd4d1153a5c9772dd64f90b4b065b05361b49e9ba82f81842e7da6
EBUILD protontricks-1.8.1.ebuild 1562 BLAKE2B 2d1f12f2aaf762aa6ce807a25cda700ae81bf886ee18aff7c510e4caddb284403d16a94468e0288ab20e487363c69c276143e6b64569ea8128d1c3d5cfe96358 SHA512 a8603cb1daca3d04f068b66794c8bfb7fb50536dcb59d82422b47293ce13332ed04efc409c13fbd5044084f503455d793d968dbaf68cd883ceec2e0f162082fc
+EBUILD protontricks-1.8.2.ebuild 1562 BLAKE2B 301f4eb1b8aa3ca6801a560614f1eaee2f917791a74eeaf173a1f3373a9768c87d2308bd8089dcd7448c3658f580476063dbffc637a2b9aac82dadb2d55f761b SHA512 5152a113f79b6788996dceebe23a64ee3ff8db232c6d89fa02500e4f18013c96079e2aa58a441636d4286232a581744504a0c08e3b9338fac3fb7b7b590e4cb2
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.8.2.ebuild b/app-emulation/protontricks/protontricks-1.8.2.ebuild
new file mode 100644
index 000000000000..d33c17e8e46a
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.8.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}