summaryrefslogtreecommitdiff
path: root/app-emulation/playonlinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-emulation/playonlinux
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-emulation/playonlinux')
-rw-r--r--app-emulation/playonlinux/Manifest2
-rw-r--r--app-emulation/playonlinux/playonlinux-4.3.4.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/app-emulation/playonlinux/Manifest b/app-emulation/playonlinux/Manifest
index c5559b971fc2..6127fc3607c0 100644
--- a/app-emulation/playonlinux/Manifest
+++ b/app-emulation/playonlinux/Manifest
@@ -4,5 +4,7 @@ AUX playonlinux-4.2.6-stop-update-warning.patch 766 BLAKE2B 934a8600742d7030d22f
AUX playonlinux-pkg.1 643 BLAKE2B 80c5381aad102d81eebaa81d3ed83ed0fb16aa29b7f4a2e2b9dd349fe020112fd34e32ac9edab510852cb66bc402d9ef46ed0a2aed5c3369885161797e47aca8 SHA512 115f87cee7c6d56dbc54da9b120ca468fb29ae4be116101cfa3e8efd1efd9a372e6e8424462087807f6755d496575c44788914f4e45c901359ce52fbe37210a8
AUX playonlinux.1 886 BLAKE2B 903f21600540798a765ae209832c4f111380340f4c6305ca333b29e6508579e13b3df8c3d44bc56284cdce290b319d40294eaee7476630190c9b7fd24ece2e76 SHA512 44ba1a04a7e8dbf3d85d81bbcf92917b6fe7bd68478bbcfecfe0c30619b834cc6c973fc6dd7d637d7debc7ede2a206248feaca1a017834ba95f076fd16679c2d
DIST PlayOnLinux_4.2.12.tar.gz 3204230 BLAKE2B 80ef0e5763448da4a37263c64d408e8263771694666a7c704b5900dfe0e52cc18405c34d609d8c49a0d05a383fca2d035e956e3bbe9a9a0c92a4e43b319ed7ba SHA512 f4ededc8fe0117c66fd5672e136e19b9b48a41acdd3e1b1b3dd7fae2c354e77795f0a4f8286b09b7d1813363aee50fa0811c04c3194aaf745963a2e6115b3909
+DIST PlayOnLinux_4.3.4.tar.gz 3101890 BLAKE2B d724cbd90a0f1bbc94c6365fcf6511d39ea0e8e9de32f42716111324f69091874ab19d3fa88a6bd9f77ed6308bc03ca708406fdc24faa60bf662e6a4f5d15d86 SHA512 7f2089d37379adee01424777e9c3b7ec16dd56ba2f4b834b4f0447832c050b2df3218a7361e8e735d5cc359aec6a000fea88e11632c9434232e4f749bb21c173
EBUILD playonlinux-4.2.12.ebuild 2831 BLAKE2B 5726b4c84d423b8d2ea519fccfa29ed8bf26dab8e101ae94f33e83d5b49f57fa5056a9feaae41555d90d064620e0ddef4d268f29164e2332762318e6693e1eaa SHA512 7c851c95913c074a4b5ee35d6bdf7c93f8795ee6e42c25a0b4c6dc49c94977d2b041568789e85f3e7392e4a510fc6b2d13002021ae1b075380b4f9585e55b845
+EBUILD playonlinux-4.3.4.ebuild 2723 BLAKE2B 4ca0028850cc0ad5d219a8845276701daf7eb0897d60b32d03e504ca078bfd9238d8b4b0aa28e22ae7dd94b654913b5505a842859e1adbd5bd0c638b415505f2 SHA512 7c70363bf0fcd6a247e399814d0efa493799c91e31e2eeccb5e9a3965179928f770718fd9e21e58422c1f799ed1ed9454fa72990de69e9954160ae8bc835cf39
MISC metadata.xml 433 BLAKE2B 6ba322414d75d581231afedbb791ce71aff799da09be4e08aab6f4e7e2e88d19b6e8701e36599bd1760e7076558c733edfe19f603f7f9541d0197cf4f1d59e4a SHA512 1e1dbfa93723297b63288436eaa1ce87183de71847c0ce61767381f668f6ad0bf69119570f7c7e395866f15e176f7412378c09386f8ddb271f7b2ec39da2d295
diff --git a/app-emulation/playonlinux/playonlinux-4.3.4.ebuild b/app-emulation/playonlinux/playonlinux-4.3.4.ebuild
new file mode 100644
index 000000000000..f2a319b7bbeb
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-4.3.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop eutils python-single-r1 xdg
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows games and software"
+HOMEPAGE="https://playonlinux.com/"
+SRC_URI="https://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="winbind"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-crypt/gnupg
+ app-misc/jq
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ media-gfx/icoutils
+ || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
+ net-misc/wget
+ virtual/imagemagick-tools
+ virtual/wine
+ winbind? ( net-fs/samba[winbind] )
+ x11-apps/mesa-progs
+ x11-terms/xterm
+"
+
+S="${WORKDIR}/${PN}"
+
+# TODO:
+# Having a real install script
+# It will let using LANGUAGES easily
+# How to deal with Microsoft Fonts installation asked every time ?
+# How to deal with wine version installed ? (have a better mgmt of system one)
+# Look at debian pkg: https://packages.debian.org/sid/playonlinux
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.4-pol-bash.patch"
+ "${FILESDIR}/${PN}-4.2.4-binary-plugin.patch"
+ "${FILESDIR}/${PN}-4.2.6-stop-update-warning.patch"
+)
+
+src_prepare() {
+ default
+
+ python_fix_shebang .
+
+ # remove playonmac
+ rm etc/{playonmac.icns,terminal.applescript} || die
+
+ # remove desktop integration
+ rm etc/{PlayOnLinux.desktop,PlayOnLinux.directory,playonlinux-Programs.menu} || die
+}
+
+src_install() {
+ # all things without exec permissions
+ insinto "/usr/share/${PN}"
+ doins -r resources lang lib etc plugins
+
+ # bash/ install
+ exeinto "/usr/share/${PN}/bash"
+ find "${S}/bash" -type f -exec doexe '{}' +
+ exeinto "/usr/share/${PN}/bash/expert"
+ find "${S}/bash/expert" -type f -exec doexe '{}' +
+
+ # python/ install
+ python_moduleinto "/usr/share/${PN}"
+ python_domodule python
+
+ # main executable files
+ exeinto "/usr/share/${PN}"
+ doexe ${PN}{,-pkg,-bash,-shell,-url_handler}
+
+ # icons
+ doicon -s 128 etc/${PN}.png
+ for size in 16 22 32; do
+ newicon -s $size etc/${PN}$size.png ${PN}.png
+ done
+
+ doman "${FILESDIR}"/playonlinux{,-pkg}.1
+ dodoc CHANGELOG.md
+
+ make_wrapper ${PN} "./${PN}" "/usr/share/${PN}"
+ make_wrapper ${PN}-pkg "./${PN}-pkg" "/usr/share/${PN}"
+ make_desktop_entry ${PN} ${MY_PN} ${PN} Game
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Installed software and games with playonlinux have not been removed."
+ elog "To remove them, you can re-install playonlinux and remove them using it,"
+ elog "or do it manually by removing .PlayOnLinux/ in your home directory."
+ fi
+}