summaryrefslogtreecommitdiff
path: root/app-emulation/libguestfs/libguestfs-1.48.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
commit32c16465e56b0122cf6e5a4625e9c7b56b107b07 (patch)
tree600c43152c825fda5f210dd7cb52b357eb6f2602 /app-emulation/libguestfs/libguestfs-1.48.6.ebuild
parent607c0755d4f6476e326fb33795df7216a7bcff18 (diff)
gentoo auto-resync : 08:10:2023 - 06:02:21
Diffstat (limited to 'app-emulation/libguestfs/libguestfs-1.48.6.ebuild')
-rw-r--r--app-emulation/libguestfs/libguestfs-1.48.6.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/app-emulation/libguestfs/libguestfs-1.48.6.ebuild b/app-emulation/libguestfs/libguestfs-1.48.6.ebuild
index 11b39fa23a18..8ae034c328ef 100644
--- a/app-emulation/libguestfs/libguestfs-1.48.6.ebuild
+++ b/app-emulation/libguestfs/libguestfs-1.48.6.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Bump with app-emulation/guestfs-tools and app-emulation/libguestfs-appliance (if any new release there)
LUA_COMPAT=( lua5-1 )
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools flag-o-matic linux-info lua-single perl-functions python-single-r1 strip-linguas toolchain-funcs
@@ -24,8 +24,10 @@ KEYWORDS="amd64 ~x86"
IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua +ocaml +perl python ruby selinux static-libs systemtap test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
- python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
# Failures - doc
COMMON_DEPEND="
@@ -92,7 +94,8 @@ COMMON_DEPEND="
"
# Some OCaml is always required
# bug #729674
-DEPEND="${COMMON_DEPEND}
+DEPEND="
+ ${COMMON_DEPEND}
>=dev-lang/ocaml-4.03:=[ocamlopt]
dev-util/gperf
dev-ml/findlib[ocamlopt]
@@ -107,14 +110,16 @@ DEPEND="${COMMON_DEPEND}
ruby? ( dev-lang/ruby virtual/rubygems dev-ruby/rake )
test? ( introspection? ( dev-libs/gjs ) )
"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
+ ${COMMON_DEPEND}
app-emulation/libguestfs-appliance
acct-group/kvm
"
# Upstream build scripts compile and install Lua bindings for the ABI version
# obtained by running 'lua' on the build host
BDEPEND="
- app-alternatives/yacc
+ sys-devel/bison
+ sys-devel/flex
virtual/pkgconfig
lua? ( ${LUA_DEPS} )
"
@@ -144,6 +149,9 @@ src_configure() {
# bug #794877
tc-export AR
+ # Needs both bison+flex (bug #915339, see configure too)
+ unset LEX YACC
+
# Skip Bash test
# (See 13-test-suite.log in linked bug)
# bug #794874