summaryrefslogtreecommitdiff
path: root/app-emulation/kompose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/kompose
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/kompose')
-rw-r--r--app-emulation/kompose/Manifest7
-rw-r--r--app-emulation/kompose/kompose-1.13.0.ebuild30
-rw-r--r--app-emulation/kompose/kompose-1.14.0.ebuild30
-rw-r--r--app-emulation/kompose/kompose-1.15.0.ebuild30
-rw-r--r--app-emulation/kompose/metadata.xml11
5 files changed, 108 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
new file mode 100644
index 000000000000..38fb6960e616
--- /dev/null
+++ b/app-emulation/kompose/Manifest
@@ -0,0 +1,7 @@
+DIST kompose-1.13.0.tar.gz 5238799 BLAKE2B 8f51d9c4b162104636578b5b6b044060997d7c8fbd8a58fdf42d8db1e5fbce51cbfd2e010e84e80707462edc29603da3a6ac729f95873f2c84b7a43baeac8284 SHA512 6ec870f03762bde138e2c22e9b8a85a1e974897f3857f096e1fcd56bd402d1f3379936752b075ee57497e5d4f1c7c7d0c82b09d6c4e90860cc04aee434123419
+DIST kompose-1.14.0.tar.gz 5238716 BLAKE2B 27c054b58d2804fcb37627652d2d48ff377504203f9319c4321fcba08e9c8dd9c41f307ff599de3b65ae9a177370322d63314b70e5cb80edf1ce071eeaf15e24 SHA512 f356f2f38c99f0ca9d8f58a4dfa171ba0c41b3127b66ab887484c3bbc76b66470fbe8f52ca3eeba700b57a86e0ff264066ee92645f71a93bfe77077655f81e97
+DIST kompose-1.15.0.tar.gz 5239685 BLAKE2B fed8d978584e6f8006eac44c732476745520d28c83b122613baee24aba71723446c269b6e60197e0eec5f4e3cf481ed38756fb7c2c8840d3f885b9a790529f73 SHA512 55296b1227324e77c5febbb9a3701c8548049e8fb22b97c86e6a936024b00dcc55b7bc101469783656fdc05fdd72f8ba2282b3619e75e0f04ebe0d2446c1e245
+EBUILD kompose-1.13.0.ebuild 914 BLAKE2B 3d7a24dac2a68fda2454e96b829dd4b8bfb330939cf136283fa52fe2ee5f9636077c08cc86d1aec9495faf18a99df4659435eaa2a473833858093ee727a7ad33 SHA512 4b245704d29c8ad0fda59264a777133b92b75bdc84813280afff3740cea4f1b53bcea556f0f55548f6cef3e81f0133d9faaed35392ceaec8994450bb96abfb89
+EBUILD kompose-1.14.0.ebuild 914 BLAKE2B 0136b088d67eb8856ed41190273942f699d8a1fa5867d763b40e3ad6070dde0ffd5a266bd730dd456ffabfcc335f334f1c0549696aadfefff71326f0c0615dee SHA512 709f2ea7683c4aa2011a1f618f0425eaf96eb99c7f5cd8f7c0ac5bf9451e1f1bae56d6a32fd4f3344c7fc7412b0fe75702494e9c3a2ed542aa6dc273ad88a251
+EBUILD kompose-1.15.0.ebuild 914 BLAKE2B 92200964849693ad38399ec431ec8586b0a4f62df0ac2fa6186b925f81e906526a9c54eb1bd9344c7a25e32d528b0a795d577281cafcfc5c1864da90b34279d6 SHA512 82ef8d3fdcc7b80854841e2bd91a77dc76ba076c3e887c46958038e29835fea8981235aa0ed610da79ae3ba05a9f71aa80d7290661007313e9a21ee0e8282709
+MISC metadata.xml 328 BLAKE2B ad1e8cb1083ed13de1f3f341fdbe9bba7ba3ab4364c8c36c9e3b63f63688da6926fc6bebc9f72aada52dfac1a4834b11cb27eee04aaaae484192b8ed74214aa6 SHA512 e2091ec84a909ad6c2453bd832817461e39b7c355c28bd99c19d9e85dc4a621606c34066f596a68585c3762b6b156455ca012495c5c336b9ba929d163b923042
diff --git a/app-emulation/kompose/kompose-1.13.0.ebuild b/app-emulation/kompose/kompose-1.13.0.ebuild
new file mode 100644
index 000000000000..7e7e3b6934b7
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="84fa8267f38abbdaa9b46fbb6f800ccb5c246da3"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${GIT_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}
diff --git a/app-emulation/kompose/kompose-1.14.0.ebuild b/app-emulation/kompose/kompose-1.14.0.ebuild
new file mode 100644
index 000000000000..e0d3bde8bce1
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="fa706f2f1c715889cbfffdf7e4a65da4c58584cd"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${GIT_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}
diff --git a/app-emulation/kompose/kompose-1.15.0.ebuild b/app-emulation/kompose/kompose-1.15.0.ebuild
new file mode 100644
index 000000000000..fdd2f4718dcc
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.15.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e3cd4d459e62697f15a6a655bf17269adfb3cf23"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${GIT_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}
diff --git a/app-emulation/kompose/metadata.xml b/app-emulation/kompose/metadata.xml
new file mode 100644
index 000000000000..2d2b8a7dffac
--- /dev/null
+++ b/app-emulation/kompose/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kubernetes/kompose</remote-id>
+ </upstream>
+</pkgmetadata>