summaryrefslogtreecommitdiff
path: root/app-emulation/hercules
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/hercules
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/Manifest6
-rw-r--r--app-emulation/hercules/files/hercules-3.09-aliasing.patch41
-rw-r--r--app-emulation/hercules/hercules-3.10.ebuild48
-rw-r--r--app-emulation/hercules/hercules-3.12.ebuild48
-rw-r--r--app-emulation/hercules/metadata.xml14
5 files changed, 157 insertions, 0 deletions
diff --git a/app-emulation/hercules/Manifest b/app-emulation/hercules/Manifest
new file mode 100644
index 000000000000..2d69c547b42b
--- /dev/null
+++ b/app-emulation/hercules/Manifest
@@ -0,0 +1,6 @@
+AUX hercules-3.09-aliasing.patch 1721 BLAKE2B 556ef555ee61a470737bbb5214dec314d57aef3e5dd4312484fa47aba05ef3ae389b1db42899a25cb7f90c025e697f2d9f3e855085a50bbf849ca250373106dc SHA512 6f623193d126e6dcf21f6d93bff1a3b949236e2a10c71ca3c4fbdc2ad816894b673551b4dad65205f8b70a75f5c280ed0aa02d4ce0969592a31705e14e42d6e7
+DIST hercules-3.10.tar.gz 2608321 BLAKE2B df6dd9c93531ee3d68efbfad5b0152ef984e1804e211861e86ea5f7b271081abbd29664d4e97d0e887af10315549bdd7e890ec741baa7b69336f1f08be63c6cf SHA512 de8b3e2e90fdb745dea9c8ce4dbe506de2aba3bf08b3e937605798e6a8020576a949d6ea3496b7c42bd23d617fc96648d2d8ec05a66e8ed174ce46a3bc31c5d1
+DIST hercules-3.12.tar.gz 2569617 BLAKE2B e6b6dc2406bc198e25ddcbdc5dbf141e52cd15ddd690711fdd4ed69ca5baaddd582c437e28aa7793ac667c03f7617adb3bdf3a00cc7c3a28e3f28984f665eb9a SHA512 81d6e151c1c8534753f2db532a0a7bd36fb3806c1ffbab5d6e4a9af3eecea46b95105c37574910714dcfc0fe9b74a72140d573099c24fd44021159ce697414ef
+EBUILD hercules-3.10.ebuild 1304 BLAKE2B a9e27b0f8e3cdda60e440e34c144cfcabbf4088d57f86df014ec1735c428a6a2ebade93a04e2d3f158d5f146a20e613fe0514699e5ccc9ea2f34f682d78a72a5 SHA512 85357103014b806170df030f3464fe293c81e09542238f918f24d59810d53895c33631fc840092c135f9d097ffac4a1e1eff2377abb6e633497bdb0c06d7c8d7
+EBUILD hercules-3.12.ebuild 1310 BLAKE2B 5c300f1edec6212e11378a1de38040bead9e6a25027e4091ccb322c134eefbd843eda1d54324d057a02b86c77abbbf45f454b22917b0482a8318ef9d62799be2 SHA512 58c6e557e0a1a2961af9b0941aa5c1486abaea72179900e22dc680bbad9969ab2d26487bd41e943e2dbc8fc23229de410a81f37aa2eb347fdd32550720458978
+MISC metadata.xml 580 BLAKE2B 7b8d677b252db63214074827db7e3ba8bf2a93362c62793321d436268f8bc4c79a2c9a2fcfe92b17c2107ad61afa6bd2340441fb04a3ba786c7c01c449d7c1fa SHA512 ac91e21edfcaefcf36af5c15336d3371f503c43e727a92df3eb14a11279e0a66719a8879725c34d10ac17e80b83f940ac5a90fffe38448918d0a665408416794
diff --git a/app-emulation/hercules/files/hercules-3.09-aliasing.patch b/app-emulation/hercules/files/hercules-3.09-aliasing.patch
new file mode 100644
index 000000000000..3d03e9b6dc1b
--- /dev/null
+++ b/app-emulation/hercules/files/hercules-3.09-aliasing.patch
@@ -0,0 +1,41 @@
+From 7d3255a18ad845953cc8083371e8623e771ad4f5 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 27 Aug 2013 12:25:49 -0400
+Subject: [PATCH] sha: fix strict aliasing warnings
+
+sha256.c:492:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
+sha256.c:784:2: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
+sha256.c:785:2: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ crypto/sha256.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/crypto/sha256.c b/crypto/sha256.c
+index 1a6a243..b1e90b4 100644
+--- a/crypto/sha256.c
++++ b/crypto/sha256.c
+@@ -489,7 +489,7 @@ SHA256_Final(u_int8_t digest[], SHA256_CTX *context)
+ *context->buffer = 0x80;
+ }
+ /* Set the bit count: */
+- *(u_int64_t *)&context->buffer[SHA256_SHORT_BLOCK_LENGTH] = context->bitcount;
++ memcpy (&context->buffer[SHA256_SHORT_BLOCK_LENGTH], &context->bitcount, 8);
+
+ /* Final transform: */
+ SHA256_Transform(context, context->buffer);
+@@ -781,8 +781,8 @@ SHA512_Last(SHA512_CTX *context)
+ *context->buffer = 0x80;
+ }
+ /* Store the length of input data (in bits): */
+- *(u_int64_t *)&context->buffer[SHA512_SHORT_BLOCK_LENGTH] = context->bitcount[1];
+- *(u_int64_t *)&context->buffer[SHA512_SHORT_BLOCK_LENGTH+8] = context->bitcount[0];
++ memcpy (&context->buffer[SHA512_SHORT_BLOCK_LENGTH], &context->bitcount[1], 8);
++ memcpy (&context->buffer[SHA512_SHORT_BLOCK_LENGTH+8], &context->bitcount[0], 8);
+
+ /* Final transform: */
+ SHA512_Transform(context, context->buffer);
+--
+1.8.3.2
+
diff --git a/app-emulation/hercules/hercules-3.10.ebuild b/app-emulation/hercules/hercules-3.10.ebuild
new file mode 100644
index 000000000000..605f69a08dbb
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.eu/"
+SRC_URI="http://downloads.hercules-390.eu/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x64-macos ~x86-macos"
+IUSE="bzip2 custom-cflags +suid"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ net-libs/libnsl:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.09-aliasing.patch
+
+ # The local modules need local libs, so when doing a parallel install
+ # of the modules and libs breaks during relinking. Force the libs to
+ # install first, and then the modules that use those libs. #488126
+ echo "install-modexecLTLIBRARIES: install-libLTLIBRARIES" >> Makefile.in
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ ac_cv_lib_bz2_BZ2_bzBuffToBuffDecompress=$(usex bzip2) \
+ econf \
+ $(use_enable bzip2 cckd-bzip2) \
+ $(use_enable bzip2 het-bzip2) \
+ $(use_enable suid setuid-hercifc) \
+ --enable-custom="Gentoo ${PF}.ebuild" \
+ --disable-optimization
+}
+
+src_install() {
+ default
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES
+ dohtml -r html
+}
diff --git a/app-emulation/hercules/hercules-3.12.ebuild b/app-emulation/hercules/hercules-3.12.ebuild
new file mode 100644
index 000000000000..b9b49d82dbf8
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.eu/"
+SRC_URI="http://downloads.hercules-390.eu/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="bzip2 custom-cflags +suid"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ net-libs/libnsl:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.09-aliasing.patch
+
+ # The local modules need local libs, so when doing a parallel install
+ # of the modules and libs breaks during relinking. Force the libs to
+ # install first, and then the modules that use those libs. #488126
+ echo "install-modexecLTLIBRARIES: install-libLTLIBRARIES" >> Makefile.in
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ ac_cv_lib_bz2_BZ2_bzBuffToBuffDecompress=$(usex bzip2) \
+ econf \
+ $(use_enable bzip2 cckd-bzip2) \
+ $(use_enable bzip2 het-bzip2) \
+ $(use_enable suid setuid-hercifc) \
+ --enable-custom="Gentoo ${PF}.ebuild" \
+ --disable-optimization
+}
+
+src_install() {
+ default
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES
+ dohtml -r html
+}
diff --git a/app-emulation/hercules/metadata.xml b/app-emulation/hercules/metadata.xml
new file mode 100644
index 000000000000..cb2f36c44dd8
--- /dev/null
+++ b/app-emulation/hercules/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>s390@gentoo.org</email>
+ <name>Gentoo Linux s390 Development</name>
+ </maintainer>
+ <longdescription>
+ Hercules is an emulator for the IBM System/360, System/370, ESA/390, and
+ z/Architecture series of mainframe computer systems. It will run any
+ software that will run on those computers, provided the peripheral devices
+ the program requires are present in the configuration.
+ </longdescription>
+</pkgmetadata>