summaryrefslogtreecommitdiff
path: root/app-emulation/guestfs-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-emulation/guestfs-tools
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-emulation/guestfs-tools')
-rw-r--r--app-emulation/guestfs-tools/Manifest3
-rw-r--r--app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild151
-rw-r--r--app-emulation/guestfs-tools/metadata.xml5
3 files changed, 159 insertions, 0 deletions
diff --git a/app-emulation/guestfs-tools/Manifest b/app-emulation/guestfs-tools/Manifest
new file mode 100644
index 000000000000..6bbb27bf4f04
--- /dev/null
+++ b/app-emulation/guestfs-tools/Manifest
@@ -0,0 +1,3 @@
+DIST guestfs-tools-1.46.1.tar.gz 12665804 BLAKE2B 7800954dfa961900035b127f6ac2556f584dd2d156143bf82fd1ba9fd1f327091706987192d91cb4251295d9565e56f769ab06bdac677160ac31d2e8f9d9a488 SHA512 d2bd0790343d54a2517237e56d1b982cd41335654fd205cfeec42a1b7cbbf4c0923597b767b8769dfe74766e078a817d520db251895990b922522030806d0b85
+EBUILD guestfs-tools-1.46.1-r1.ebuild 3826 BLAKE2B e3717c4579fcbce5452659bde90d43d90fa7d8f73642e3d01271b1da85589efa5334064cbe84229df60084751dfb58535f75b84de163e283e57c763b1c019c00 SHA512 b992e2c1ee8e3caacea080e9e3854f3c1b4648ac3e874018a58a03942777411bac6b123877ecba854f9ea1b80a16e77574027f18b8352dfc9157b5c7f8525ea6
+MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild b/app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild
new file mode 100644
index 000000000000..1ac17ff9fb4e
--- /dev/null
+++ b/app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic linux-info perl-functions strip-linguas toolchain-funcs
+
+MY_PV_1="$(ver_cut 1-2)"
+MY_PV_2="$(ver_cut 2)"
+[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tools for accessing, inspecting, and modifying virtual machine (VM) disk images"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://download.libguestfs.org/${PN}/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/${MY_PV_1}"
+# Keyword with newer libguestfs, bug #816693
+#KEYWORDS="~amd64"
+IUSE="doc +ocaml +perl test"
+RESTRICT="!test? ( test )"
+
+# Failures - doc
+COMMON_DEPEND="
+ !<app-emulation/libguestfs-1.46.0-r1
+ app-arch/cpio
+ app-arch/lzma
+ app-arch/unzip[natspec]
+ app-arch/xz-utils
+ app-crypt/gnupg
+ >=app-emulation/libguestfs-${MY_PV_1}:=[ocaml?,perl?]
+ app-emulation/libvirt:=
+ >=app-emulation/qemu-2.0[qemu_softmmu_targets_x86_64,filecaps]
+ dev-lang/perl:=
+ dev-libs/libpcre2:=
+ dev-libs/libxml2:2
+ dev-libs/jansson:=
+ >=sys-apps/fakechroot-2.8
+ sys-fs/squashfs-tools:*
+ sys-libs/libxcrypt:=
+ virtual/libcrypt:=
+ ocaml? ( >=dev-lang/ocaml-4.03:=[ocamlopt] )
+ perl? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Getopt-Long
+ dev-perl/Module-Build
+ dev-perl/libintl-perl
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Sys-Virt-0.2.4
+ dev-perl/String-ShellQuote
+ test? ( virtual/perl-Test-Simple )
+ )
+"
+# Some OCaml is always required
+# bug #729674
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/ocaml-4.03:=[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ doc? ( app-text/po4a )
+ ocaml? (
+ dev-ml/ounit2[ocamlopt]
+ || (
+ <dev-ml/ocaml-gettext-0.4.2
+ dev-ml/ocaml-gettext-stub[ocamlopt]
+ )
+ )
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-emulation/libguestfs-appliance
+"
+
+DOCS=( AUTHORS BUGS ChangeLog HACKING README TODO )
+
+#PATCHES=(
+# "${FILESDIR}"/${MY_PV_1}/
+#)
+
+pkg_setup() {
+ CONFIG_CHECK="~KVM ~VIRTIO"
+ [[ -n "${CONFIG_CHECK}" ]] && check_extra_config
+}
+
+src_configure() {
+ # bug #794877
+ tc-export AR
+
+ if use test ; then
+ # Skip Bash test
+ # (See 13-test-suite.log in linked bug)
+ # bug #794874
+ export SKIP_TEST_COMPLETE_IN_SCRIPT_SH=1
+
+ # This test requires libvirt support in libguestfs and it makes
+ # no difference at runtime. Just gracefully skip it to make life
+ # easier for e.g. arch testing.
+ if ! has_version 'app-emulation/libguestfs[libvirt]' ; then
+ export SKIP_TEST_VIRT_ALIGNMENT_SCAN_GUESTS_SH=1
+ fi
+
+ # Needed for the inspector tests. Provided by libguestfs-appliance.
+ #export LIBGUESTFS_PATH="${BROOT}"/usr/share/guestfs/appliance/
+ # But the inspector tests seem fragile anyway...
+ export SKIP_TEST_VIRT_INSPECTOR_LUKS_SH=1
+ export SKIP_TEST_VIRT_INSPECTOR_SH=1
+ fi
+
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ # Give a nudge to help find libxcrypt[-system]
+ # We have a := dep on virtual/libcrypt to ensure this
+ # doesn't become stale.
+ # bug #703118, bug #789354
+ if ! has_version 'sys-libs/libxcrypt[system]' ; then
+ append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+ append-ldflags "-Wl,-R${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+ fi
+
+ econf \
+ $(usex doc '' PO4A=no) \
+ $(use_enable ocaml) \
+ $(use_enable perl)
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake DESTDIR="${D}" install "LINGUAS=""${LINGUAS}"""
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use perl ; then
+ perl_delete_localpod
+ fi
+}
+
+pkg_postinst() {
+ if ! use ocaml ; then
+ einfo "OCaml based tools and bindings (virt-resize, virt-sparsify, virt-sysprep, ...) NOT installed"
+ fi
+
+ if ! use perl ; then
+ einfo "Perl based tools NOT built"
+ fi
+}
diff --git a/app-emulation/guestfs-tools/metadata.xml b/app-emulation/guestfs-tools/metadata.xml
new file mode 100644
index 000000000000..115e9d64a669
--- /dev/null
+++ b/app-emulation/guestfs-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>