summaryrefslogtreecommitdiff
path: root/app-emulation/glean
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /app-emulation/glean
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'app-emulation/glean')
-rw-r--r--app-emulation/glean/Manifest4
-rw-r--r--app-emulation/glean/files/glean.initd15
-rw-r--r--app-emulation/glean/glean-1.10.3.ebuild27
-rw-r--r--app-emulation/glean/metadata.xml19
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/glean/Manifest b/app-emulation/glean/Manifest
new file mode 100644
index 000000000000..17e940582005
--- /dev/null
+++ b/app-emulation/glean/Manifest
@@ -0,0 +1,4 @@
+AUX glean.initd 241 BLAKE2B ea451713203da8dd61eef5155e2ab2d5fa7be5d9cd210ce2d0ce890fe54af05b461671702d1a2b60b8e6b8e0cb0f4d12f90ff2884409e9f2a3dcc380ba48bb60 SHA512 a5af77b16e1864158dfe858f932dd4eecb5633bd71fbdd00085863e56bd1862d7eba4500d0f4ac8c692b06750fcfe3f9f5b2bb7a4ca6a4ba72dbc43bb12856c5
+DIST glean-1.10.3.tar.gz 51898 BLAKE2B 95bcee5caae1bdcdc586c8d8ab8097b1dfaa35c521d7b90d128db14f496d4d31e1d0d4c540c4205861e5c7fa87d0e7038227ae9db0e898e3bf43b8b9b989e766 SHA512 27d4f29bf35585f73813e9efdea0253f0be3a8fa059c6ce524fbdd37b865d9c9e10d29bb8f970317ffe772c110cc76f10ae7debce5f7433461639dc63b9349db
+EBUILD glean-1.10.3.ebuild 606 BLAKE2B e0a740caf0e408d1ae436ce2e82a06241aea9d197e2701152e9443d888fbd6ba84141740750974b8f96e71891cc58899d771b6800bbff16dc341fe9f3d4c8a3d SHA512 a5a20e0dac0c6682a50681ab5bd7dd03b3a17eed88c4091d829f1044f0278ed8abded6254c2ddeeb0ed74b37c855dfed2288bcd0792f5bb15e869839425a810d
+MISC metadata.xml 641 BLAKE2B ee81e3a785b2622805b1d30e1283daf523d5c6577c313aa970c8745f870e5058af90a46c11a954a3f641b93b7ece772336be4330f7f1e77625ec9869053342bd SHA512 28e64d8afd054e05b0155773b4b35c8b03b1488be4aba776c0b6b23397e2e8ac35330be8da668c57239a0826c5af00d93a17ba4d00936829e9b67d4d53ee3c7a
diff --git a/app-emulation/glean/files/glean.initd b/app-emulation/glean/files/glean.initd
new file mode 100644
index 000000000000..16f7805957f2
--- /dev/null
+++ b/app-emulation/glean/files/glean.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+
+description="Simple program to write static config from config-drive"
+
+depend() {
+ need root localmount
+ before net
+}
+
+start() {
+ ebegin "Starting Glean"
+ /usr/bin/glean.sh
+ eend
+}
diff --git a/app-emulation/glean/glean-1.10.3.ebuild b/app-emulation/glean/glean-1.10.3.ebuild
new file mode 100644
index 000000000000..51ca92a7a2a4
--- /dev/null
+++ b/app-emulation/glean/glean-1.10.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://github.com/openstack-infra/glean"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
diff --git a/app-emulation/glean/metadata.xml b/app-emulation/glean/metadata.xml
new file mode 100644
index 000000000000..5f29d506900e
--- /dev/null
+++ b/app-emulation/glean/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Glean is a program intended to configure a system based on configuration provided in a configuration drive.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">glean</remote-id>
+ <remote-id type="github">openstack-dev/glean</remote-id>
+ </upstream>
+</pkgmetadata>