summaryrefslogtreecommitdiff
path: root/app-emulation/ganeti-instance-image
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /app-emulation/ganeti-instance-image
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'app-emulation/ganeti-instance-image')
-rw-r--r--app-emulation/ganeti-instance-image/Manifest2
-rw-r--r--app-emulation/ganeti-instance-image/files/ganeti-2.15.2-os-image-common_sh.patch43
-rw-r--r--app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r1.ebuild52
3 files changed, 97 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-image/Manifest b/app-emulation/ganeti-instance-image/Manifest
index 7b50ea0d1780..eef9a9f767d9 100644
--- a/app-emulation/ganeti-instance-image/Manifest
+++ b/app-emulation/ganeti-instance-image/Manifest
@@ -1,3 +1,5 @@
+AUX ganeti-2.15.2-os-image-common_sh.patch 1869 BLAKE2B 61c3ee20a7774874a85b773b221dfbfe6151d5849e677198a8657ef8a5244be5546caf8fdd1d1c771dfb195c7748c430689ab854a0d7998f7636d60456f81846 SHA512 5ed87c15884aae8ce23dae6e40ddf48e91c417bafd9e20b97acd5e20583bacfa9d37433466c2f91e27770f86f3b462c056e35f5ac4235e955348c52ba67b8e6b
DIST ganeti-instance-image-0.6.tar.gz 82534 BLAKE2B 8a16f1ead6307400031425c60dae2585ea9ad53e55276a73177b46652c9054c6c24ea7068347ecaeafa77cea27b1b97350420bd6cf0e69e5ac18692cede47bbc SHA512 92b5048fe8c40692e8e7c4cb73b21e764660d7cb5f585a8489fc4338eef7df8aae1147d38a849103585a884a0216a0bfb42473d5c1922130e5aada31f5d580c3
+EBUILD ganeti-instance-image-0.6-r1.ebuild 1057 BLAKE2B 232dcf827777247b952f2401d0adfac3c20df4b10ff521c29319167d08e13a6a899ae4d803512d2ec74118153ab51e7d83b75e1c655fe4323efa9f26bccd8ccb SHA512 1457c2beb8fd4eb5176285bb2ac67315675d810008842150fcef168b76a068d520067c376a0752fbbebf52dc1cd047532f112e7585ca8354d3cb46a86dbad946
EBUILD ganeti-instance-image-0.6.ebuild 990 BLAKE2B 79251b99b7a51045025577f5481c08cecbff9b8bfc860c243e83c6ab08f4f0d9b3d31f08fc78899bef632aa6bd7b362b139d75d9e421f263ca76a3105dd8c870 SHA512 98764555f1dfd871a16cc8cc65ce5e6682b01575b6746a6560c65434f2e95a1ddcade4ada125c75aa79f3bcdcf65c51d6c3eca40c1acedf1c7e682c38418b340
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/app-emulation/ganeti-instance-image/files/ganeti-2.15.2-os-image-common_sh.patch b/app-emulation/ganeti-instance-image/files/ganeti-2.15.2-os-image-common_sh.patch
new file mode 100644
index 000000000000..73e7ab8a923d
--- /dev/null
+++ b/app-emulation/ganeti-instance-image/files/ganeti-2.15.2-os-image-common_sh.patch
@@ -0,0 +1,43 @@
+--- a/common.sh.in 2018-09-05 23:23:07.811528673 +0000
++++ b/common.sh.in 2018-09-06 00:10:36.993693654 +0000
+@@ -284,13 +284,13 @@
+ blockdev="$1"
+ filesystem_dev_base=`$KPARTX -l -p- $blockdev | \
+ grep -m 1 -- "-1.*$blockdev" | \
+- $AWK '{print $1}'`
++ $AWK '{print $1}' | sed -r -e 's/-([0-9]{1,2})$/p\1/g'`
+ if [ -z "$filesystem_dev_base" ]; then
+ log_error "Cannot interpret kpartx output and get partition mapping"
+ exit 1
+ fi
+ $KPARTX -a -p- $blockdev > /dev/null
+- filesystem_dev="/dev/mapper/${filesystem_dev_base/%-1/}"
++ filesystem_dev="/dev/mapper/${filesystem_dev_base/%p1/}"
+ if [ ! -b "/dev/mapper/$filesystem_dev_base" ]; then
+ log_error "Can't find kpartx mapped partition: /dev/mapper/$filesystem_dev_base"
+ exit 1
+@@ -302,17 +302,17 @@
+ filesystem_dev="$1"
+ partition="$2"
+ if [ "${SWAP}" = "yes" -a -z "${KERNEL_PATH}" ] ; then
+- boot_dev="${filesystem_dev}-1"
+- swap_dev="${filesystem_dev}-2"
+- root_dev="${filesystem_dev}-3"
++ boot_dev="${filesystem_dev}p1"
++ swap_dev="${filesystem_dev}p2"
++ root_dev="${filesystem_dev}p3"
+ elif [ "${SWAP}" = "no" -a -z "${KERNEL_PATH}" ] ; then
+- boot_dev="${filesystem_dev}-1"
+- root_dev="${filesystem_dev}-2"
++ boot_dev="${filesystem_dev}p1"
++ root_dev="${filesystem_dev}p2"
+ elif [ "${SWAP}" = "yes" -a -n "${KERNEL_PATH}" ] ; then
+- swap_dev="${filesystem_dev}-1"
++ swap_dev="${filesystem_dev}p1"
+ root_dev="${filesystem_dev}-2"
+ elif [ "${SWAP}" = "no" -a -n "${KERNEL_PATH}" ] ; then
+- root_dev="${filesystem_dev}-1"
++ root_dev="${filesystem_dev}p1"
+ fi
+ echo "$(eval "echo \${$(echo ${partition}_dev)"})"
+ }
diff --git a/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r1.ebuild b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r1.ebuild
new file mode 100644
index 000000000000..6d10cc0ad0dd
--- /dev/null
+++ b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.osuosl.org/${PN}.git"
+ EGIT_BRANCH="master"
+ inherit git-r3 autotools
+else
+ SRC_URI="http://ftp.osuosl.org/pub/osl/ganeti-instance-image/${P}.tar.gz"
+fi
+
+DESCRIPTION="Scripts to build out CD or image based VMs using Ganeti"
+HOMEPAGE="http://code.osuosl.org/projects/ganeti-image"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dump
+ >=app-emulation/ganeti-2.15.2-r7
+ app-emulation/qemu
+ sys-apps/util-linux
+ sys-fs/multipath-tools
+ sys-fs/e2fsprogs"
+
+PATCHES=(
+ "${FILESDIR}/ganeti-2.15.2-os-image-common_sh.patch"
+)
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf --with-default-dir=/etc/ganeti
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc README.markdown NEWS ChangeLog
+ insinto /etc/ganeti
+ newins defaults ${PN}
+}