summaryrefslogtreecommitdiff
path: root/app-emulation/fuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/fuse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/Manifest5
-rw-r--r--app-emulation/fuse/fuse-1.5.3.ebuild68
-rw-r--r--app-emulation/fuse/fuse-1.5.5.ebuild68
-rw-r--r--app-emulation/fuse/metadata.xml21
4 files changed, 162 insertions, 0 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
new file mode 100644
index 000000000000..57d63ae0b1a1
--- /dev/null
+++ b/app-emulation/fuse/Manifest
@@ -0,0 +1,5 @@
+DIST fuse-1.5.3.tar.gz 1627487 BLAKE2B d942f0131ce713e8592abec6443015aca3f1ae73739f1db0eae84a19e4320fd8bffbd7d36afaf65b08cf059305f85a8854d39d46519ed7abd3705b11156d069c SHA512 6596f789a685c46752c46b2432953c0d9abb620b23541cdbfc066c224fcba47ac7be75db678e2ff76622a7d02cc81b7dfeae672dfdaee1085d2ae5f768a4d8c0
+DIST fuse-1.5.5.tar.gz 1629577 BLAKE2B b4765047507049b2fa3547d47384df2c5e6de75b74b7aa8d3549ca47ae6f3dad53a37fc48112db86426ce3d2d84711aa029d158c75eba89214761ed82d7ab57a SHA512 186635b632df9767b9ffcbba484370adc47833bd06240474db9c4dfe88b03209e15fc0c86a2f200b2cc7bd95ad93bf1f93f38d7f669b5c163f68e80802fb1041
+EBUILD fuse-1.5.3.ebuild 1711 BLAKE2B 91bd43861b0adc2e12b4e2db17d2f4c1909380b8b939b441ae4d34477ff9b7c317419c33abd17003f4c5e554c69f836425b33057f67d178e432f3ca7eb4ea784 SHA512 ac190f7174f18ae7c288a544b39724ce0014e2b38c95ff8f7626d64b96172ddbe27271a377fd5b3728f3d8d6c2984a17e2351d723d84e134d2827f30e7bb6404
+EBUILD fuse-1.5.5.ebuild 1711 BLAKE2B d81e148140fb353bb82cfef956bc946272e49f6c3e4fb121dfc0e75d472c3e0821b244529eaed00b4b4a251e776dbab62fbd99d042134ba0f88e501cc44fcfda SHA512 d2274c47e7ef1ee7a29c12d59033a2f2f34b33d7d7e9cd8a3a80402a7f5c38bd8b16e5a72cc1b71cd6d9cb334c56077571b719d6e85e89c3959f957c675d2c6a
+MISC metadata.xml 731 BLAKE2B d157625420632cf041ce0d877f243e6d2fcfd62f8b487691bca757ed38e5d5173aaec623528b3e33cbcc09347464f9c26c3c50190dd28ebdd2f3b86ea0609d51 SHA512 c0a922b5cc6900b9fa7d219dc1cecbed616af7f77d018065e8b5d6f6da6350c4d9d4ba3004b8f34ebc97da22c7d4f4f8b59119098877c199abcc334dff933342
diff --git a/app-emulation/fuse/fuse-1.5.3.ebuild b/app-emulation/fuse/fuse-1.5.3.ebuild
new file mode 100644
index 000000000000..913346a242fb
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.5.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
+
+RDEPEND="
+ >=app-emulation/libspectrum-1.4.2
+ dev-libs/glib:2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
+ !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
+ gpm? ( sys-libs/gpm )
+ joystick? ( media-libs/libjsw )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+ backend-fbcon? ( virtual/linux-sources )
+ dev-lang/perl
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+ local myconf=(
+ --without-win32
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with gpm)
+ $(use_with joystick)
+ $(use_enable joystick ui-joystick)
+ $(use_enable memlimit smallmem)
+ $(use_with png)
+ $(use_with xml libxml2)
+ )
+
+ if use backend-sdl; then
+ myconf+=("--with-sdl")
+ elif use backend-X; then
+ myconf+=("--without-gtk")
+ elif use backend-svga; then
+ myconf+=("--with-svgalib")
+ elif use backend-fbcon; then
+ myconf+=("--with-fb")
+ else
+ myconf+=("--with-gtk")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake test
+}
diff --git a/app-emulation/fuse/fuse-1.5.5.ebuild b/app-emulation/fuse/fuse-1.5.5.ebuild
new file mode 100644
index 000000000000..e93691a5006d
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.5.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
+
+RDEPEND="
+ >=app-emulation/libspectrum-1.4.4
+ dev-libs/glib:2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
+ !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
+ gpm? ( sys-libs/gpm )
+ joystick? ( media-libs/libjsw )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+ backend-fbcon? ( virtual/linux-sources )
+ dev-lang/perl
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+ local myconf=(
+ --without-win32
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with gpm)
+ $(use_with joystick)
+ $(use_enable joystick ui-joystick)
+ $(use_enable memlimit smallmem)
+ $(use_with png)
+ $(use_with xml libxml2)
+ )
+
+ if use backend-sdl; then
+ myconf+=("--with-sdl")
+ elif use backend-X; then
+ myconf+=("--without-gtk")
+ elif use backend-svga; then
+ myconf+=("--with-svgalib")
+ elif use backend-fbcon; then
+ myconf+=("--with-fb")
+ else
+ myconf+=("--with-gtk")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake test
+}
diff --git a/app-emulation/fuse/metadata.xml b/app-emulation/fuse/metadata.xml
new file mode 100644
index 000000000000..27879e601857
--- /dev/null
+++ b/app-emulation/fuse/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>0xe2.0x9a.0x9b@gmail.com</email>
+ <name>Jan Ziak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fuse-emulator</remote-id>
+ </upstream>
+ <use>
+ <flag name="backend-fbcon">Use framebuffer rendering backend</flag>
+ <flag name="backend-sdl">Use SDL rendering backend</flag>
+ <flag name="backend-svga">Use svgalib rendering backend</flag>
+ <flag name="backend-X">Use X11 rendering backend</flag>
+ </use>
+</pkgmetadata>