summaryrefslogtreecommitdiff
path: root/app-emulation/e-uae
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/e-uae
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/e-uae')
-rw-r--r--app-emulation/e-uae/Manifest4
-rw-r--r--app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild135
-rw-r--r--app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch18
-rw-r--r--app-emulation/e-uae/metadata.xml14
4 files changed, 171 insertions, 0 deletions
diff --git a/app-emulation/e-uae/Manifest b/app-emulation/e-uae/Manifest
new file mode 100644
index 000000000000..4f2f56847787
--- /dev/null
+++ b/app-emulation/e-uae/Manifest
@@ -0,0 +1,4 @@
+AUX e-uae-0.8.29_rc4-high-cpu-usage.patch 399 BLAKE2B 0b8d1126bafe49ecf1ca03c23efe51287a8b8b565084560caae054f2997d61c86f248e2bca3b511bf6e283fed8c47639d5ea266a147acc77cbb4b1cabc3b7f94 SHA512 a0d6dbe9dedbabb7700e2199d62814732a0d6f09be7758aa70565ba4d4cc1a86d848e3a9b5c743871a0052ee1b19b03615ee38a174634c7a339d218bab350b18
+DIST e-uae-0.8.29-WIP4.tar.bz2 1122718 BLAKE2B 4120e7d14e4ee1a8be04839680c30dc57286524a68eb8036a8f48a0724c3581884045c2ad11bb8409a88b2f43bd132b92083e1e1cc088c5b4768f3b6dfdef458 SHA512 63d5c60ca017ba7ffaba32c4d7edceba0410b773066cc58e226c8cc2c92152eb3689698b0affe478cc63c996c731fbbf56d9028dfd000394d904f193f860473f
+EBUILD e-uae-0.8.29_rc4-r3.ebuild 4150 BLAKE2B 4f58a33bff8d386a8e15c98484fea0360f415e549f1d1701fe94c00f9fa001b0a3a84fec8ddb81924a2b73ab8328f0893b5a79b49a08e4dfa6e451f4e5ca2beb SHA512 7e0c65952d5163d5f44412834f3f73c529c874c0d8e88ca25121f8eff5cbe4fb864a82ebc462dd5c06fedfeb85a4e7777683764c97b3765b3c8e997c384961ca
+MISC metadata.xml 465 BLAKE2B ddab23755d4ac531a0963f024bd4aff9b727f94a3aed47184a32a7e6f6c0b6b9d441c74cccd29028e831c9f290c8539a263317cc0e0d23928932a2f68c576429 SHA512 d66cf721c85633855983c22d2fd18e75635afe1fdd987b12a35f23caf1acb241398815ae643682864d3cd5099983b9b9c7581828ccd4668aca9d5b56fe9a8a00
diff --git a/app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild b/app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild
new file mode 100644
index 000000000000..63d99f142b49
--- /dev/null
+++ b/app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic pax-utils
+
+DESCRIPTION="The Ubiquitous Amiga Emulator with an emulation core largely based on WinUAE"
+HOMEPAGE="http://www.rcdrummond.net/uae/"
+# We support _rcX for WIPX versions and _preYYYYMMDD for CVS snapshots.
+if [[ "${PV%%_rc*}" = "${PV}" ]] ; then
+ # _pre is used, cvs version
+ my_ver=${PV%%_pre*}
+ snap_ver=${PV##*_pre}
+ S="${WORKDIR}"/${PN}-${my_ver}-${snap_ver}
+ SRC_URI="http://www.rcdrummond.net/uae/test/${snap_ver}/${PN}-${my_ver}-${snap_ver}.tar.bz2"
+else
+ my_ver=${PV%%_rc*}
+ WIP_ver=${PV##*_rc}
+ S="${WORKDIR}"/${PN}-${my_ver}-WIP${WIP_ver}
+ SRC_URI="http://www.rcdrummond.net/uae/${PN}-${my_ver}-WIP${WIP_ver}/${PN}-${my_ver}-WIP${WIP_ver}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X dga ncurses sdl alsa oss sdl-sound capslib"
+
+# Note: opposed to ./configure --help zlib support required! Check
+# src/Makefile.am that includes zfile.c unconditionaly.
+RDEPEND="X? ( x11-libs/libXt
+ x11-libs/libxkbfile
+ x11-libs/libXext
+ x11-misc/xkeyboard-config
+ dga? ( x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ )
+ !X? ( sdl? ( media-libs/libsdl )
+ !sdl? ( sys-libs/ncurses:0= ) )
+ alsa? ( media-libs/alsa-lib )
+ !alsa? ( sdl-sound? ( media-libs/sdl-sound ) )
+ capslib? ( >=games-emulation/caps-20060612 )
+ sys-libs/zlib
+ virtual/cdrtools"
+
+DEPEND="${RDEPEND}
+ X? ( dga? ( x11-base/xorg-proto ) )"
+
+src_prepare() {
+ default
+ # Fix for high cpu use when compiled with --disable-audio
+ use alsa || use sdl-sound || use oss || eapply "${FILESDIR}"/${P}-high-cpu-usage.patch
+}
+
+src_configure() {
+ strip-flags
+
+ local myconf
+
+ # Sound setup.
+ if use alsa; then
+ elog "Choosing alsa as sound target to use."
+ myconf="--with-alsa --without-sdl-sound"
+ elif use sdl-sound ; then
+ if ! use sdl ; then
+ ewarn "sdl-sound is not enabled because sdl USE flag is disabled. Leaving"
+ ewarn "sound on oss autodetection."
+ myconf="--without-alsa --without-sdl-sound"
+ else
+ elog "Choosing sdl-sound as sound target to use."
+ ewarn "E-UAE with the SDL audio back-end doesn't work correctly in Linux."
+ ewarn "Better use alsa... You've been warned ;)"
+ myconf="--without-alsa --with-sdl-sound"
+ fi
+ elif use oss ; then
+ elog "Choosing oss as sound target to use."
+ ewarn "oss will be autodetected. See output of configure."
+ myconf="--without-alsa --without-sdl-sound"
+ else
+ ewarn "There is no alsa, sdl-sound or oss in USE. Sound target disabled!"
+ myconf="--disable-audio"
+ fi
+
+ # VIDEO setup. X is autodetected (there is no --with-X option).
+ if use X ; then
+ elog "Using X11 for video output."
+ ewarn "Fullscreen mode is not working in X11 currently. Use sdl."
+ myconf="$myconf --without-curses --without-sdl-gfx"
+ use dga && ewarn "To use dga you have to run e-uae as root."
+ use dga && myconf="$myconf --enable-dga --enable-vidmode"
+ elif use sdl ; then
+ elog "Using sdl for video output."
+ myconf="$myconf --with-sdl --with-sdl-gfx --without-curses"
+ elif use ncurses; then
+ elog "Using ncurses for video output."
+ myconf="$myconf --with-curses --without-sdl-gfx"
+ else
+ ewarn "There is no X or sdl or ncurses in USE!"
+ ewarn "Following upstream falling back on ncurses."
+ myconf="$myconf --with-curses --without-sdl-gfx"
+ fi
+
+ # bug #415787
+ myconf="$myconf --disable-ui"
+
+ myconf="$myconf $(use_with capslib caps)"
+
+ myconf="$myconf --with-zlib"
+
+ # And explicitly state defaults:
+ myconf="$myconf --enable-aga"
+ myconf="$myconf --enable-autoconfig --enable-scsi-device --enable-cdtv --enable-cd32"
+ myconf="$myconf --enable-bsdsock"
+
+ econf ${myconf} \
+ --with-libscg-includedir="${EPREFIX}"/usr/include/scsilib
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # The emulator needs to be able to create executable heap
+ # - doesn't need trampoline emulation though.
+ pax-mark me "${ED}/usr/bin/uae"
+
+ # Rename it to e-uae
+ mv "${ED}/usr/bin/uae" "${ED}/usr/bin/e-uae"
+ mv "${ED}/usr/bin/readdisk" "${ED}/usr/bin/e-readdisk"
+
+ dodoc docs/* README ChangeLog
+}
diff --git a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch b/app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch
new file mode 100644
index 000000000000..ad73b34c062c
--- /dev/null
+++ b/app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch
@@ -0,0 +1,18 @@
+Index: src/sd-none/sound.c
+===================================================================
+RCS file: /cvsroot/uaedev/uae/src/sd-none/sound.c,v
+retrieving revision 1.4
+diff -u -r1.4 sound.c
+--- a/src/sd-none/sound.c 15 Feb 2007 04:47:38 -0000 1.4
++++ b/src/sd-none/sound.c 25 May 2007 14:47:35 -0000
+@@ -30,10 +30,6 @@
+ {
+ }
+
+-void update_sound (int freq)
+-{
+-}
+-
+ void reset_sound (void)
+ {
+ }
diff --git a/app-emulation/e-uae/metadata.xml b/app-emulation/e-uae/metadata.xml
new file mode 100644
index 000000000000..35a11c55489a
--- /dev/null
+++ b/app-emulation/e-uae/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ E-UAE is a fork of UAE which intends to merge all the new features of
+ WinUAE with UAE.
+ </longdescription>
+ <use>
+ <flag name="capslib">Add CAPS library support</flag>
+ <flag name="sdl-sound">Use <pkg>media-libs/sdl-sound</pkg> for audio
+ output</flag>
+ </use>
+</pkgmetadata>