summaryrefslogtreecommitdiff
path: root/app-emulation/dynamips
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/dynamips
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/dynamips')
-rw-r--r--app-emulation/dynamips/Manifest7
-rw-r--r--app-emulation/dynamips/dynamips-0.2.12.ebuild47
-rw-r--r--app-emulation/dynamips/dynamips-0.2.14-r1.ebuild41
-rw-r--r--app-emulation/dynamips/files/0.2.14-docs.patch20
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch11
-rw-r--r--app-emulation/dynamips/metadata.xml11
6 files changed, 137 insertions, 0 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
new file mode 100644
index 000000000000..17e81a2df73d
--- /dev/null
+++ b/app-emulation/dynamips/Manifest
@@ -0,0 +1,7 @@
+AUX 0.2.14-docs.patch 551 BLAKE2B 0e8b4ef51a247479d8306f5cc50619b32dbfe07bf04257ae633dc0ca8bcc6782fe092a6b2fe99c845e96cc2c87d5ac96d5a3bb981a379adc54891edfc67147b9 SHA512 31884a56bffd2bdfee76949ecc5c0d68fd10e30bea52315fbafb8e4c60b033f1baf2a380a67686af91b0ee49ae97f4012c778bf6f69d6dd583375d8f6b7e98de
+AUX dynamips-0.2.12-makefile.patch 458 BLAKE2B 706fc359aa844a87b4d9519b5355708a0c30c8511825381bc84f7ca567de1d6300c2733b550804d179eafd66b029ccafaf97bf2852e9650c4ad1b7778f6aeab6 SHA512 9f298052970a277221d9cf4a936290dcf832e633b72d860267128e898b882b3d84f6366a881ac736ba9e7c79639c3f429061c7c959f3d77121b36ff847eee91c
+DIST dynamips-0.2.12-source.zip 995877 BLAKE2B 0bfc709f49b196763e8a3dcfde214e1e26c9c735257d588b72aefc3ca8dec2b1325ce3cb634b59555365c9dbd3819d959ab6e51e986c2dd62595b5566d76b39c SHA512 08f388027e3234a44a75de77f30d6c96f0d881c4db60435a237f6ae6e3804872fda422ab11249f5c7283054f7d2d8466886dcd6056e59fc90802e67fa7cb8c55
+DIST dynamips-0.2.14-source.zip 961813 BLAKE2B 71da393bfd5624ad47eda578eafd0f5b8b535d9a93c3ebc8902901c0415168098bb27ea44e92cbb230d0cf2ebb904311665978f1b30e6d35c7792b813a5cd8d2 SHA512 8c3d85998a61cae1e3e82501a00e886c954686f9a19a44acb7dee8b13911c0155ce2cdfecbdc41ed5d279266abdf77a5c3f2753fde12217b138313ffa46dabf8
+EBUILD dynamips-0.2.12.ebuild 929 BLAKE2B 82fe256856b6eb41f7b1e6efcab247531369d6405462bb06b17321840f6087941785a1fe720d7f82bd71b5ca21f4efa0427782e3d35fd7720682abd4b8077a4c SHA512 c1e45f0fe9e1ea182f0aed2d9687e0d78a7d247c18766c11bd98db6175b7f2b2038bbb8e3ca3062b4da479969d6512f0b238fc08062377b5a35d4723ee6891bc
+EBUILD dynamips-0.2.14-r1.ebuild 816 BLAKE2B afd37e97b28167a417ca91c35c9ab21d60403a80260e0b636478b7db800a5ac320cc95abdebb6c1943464bc43f518e292315adee248fc72214070b518540f56d SHA512 5fe002c46f1f868e317c193c187db8ec7b63567561a1fd334c2cc32378f40cd3c14de5748da07626cad89c21b7163a9cae294a0f134beb152248f7f9c4d629b3
+MISC metadata.xml 322 BLAKE2B 6c1fdcec350e68782be9e9e4dff8c9c0a71e05ffba537772dc86d0843b57d58ac2993e361daf84f3e3a8d4f1d25d5f841efbcc6a02e545ec0af1d3cc69155b37 SHA512 cfb689b938923b74a3ba4b7101da915c2e9a4f96f23e26d7a3baf69d1593cd8c063ee76911d90104f7cce91c5df98defbacc35e6526aef0e66af575125bd6fbc
diff --git a/app-emulation/dynamips/dynamips-0.2.12.ebuild b/app-emulation/dynamips/dynamips-0.2.12.ebuild
new file mode 100644
index 000000000000..134ef537bf0d
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.gns3.net/dynamips/"
+SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ # enable verbose build
+ sed -i \
+ -e 's/@$(CC)/$(CC)/g' \
+ stable/Makefile || die 'sed on stable/Makefile failed'
+ # respect compiler
+ tc-export CC
+
+ epatch_user
+}
+
+src_compile() {
+ if use amd64 || use x86; then
+ emake DYNAMIPS_ARCH="${ARCH}"
+ else
+ emake DYNAMIS_ARCH="nojit"
+ fi
+}
+
+src_install () {
+ newbin dynamips.stable dynamips
+ newbin nvram_export.stable nvram_export
+ doman man/*
+ dodoc README README.hypervisor TODO
+}
diff --git a/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild b/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild
new file mode 100644
index 000000000000..792a84e1a963
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.gns3.net/dynamips/"
+SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ipv6"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( ChangeLog README RELEASE-NOTES )
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}/${PV}-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable ipv6 IPV6)
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/dynamips/files/0.2.14-docs.patch b/app-emulation/dynamips/files/0.2.14-docs.patch
new file mode 100644
index 000000000000..1d744062e5b5
--- /dev/null
+++ b/app-emulation/dynamips/files/0.2.14-docs.patch
@@ -0,0 +1,20 @@
+--- CMakeLists-orig.txt 2014-11-28 14:51:14.375913296 +0900
++++ CMakeLists.txt 2014-11-28 14:52:09.579369288 +0900
+@@ -37,16 +37,6 @@
+ add_subdirectory ( stable )
+ add_subdirectory ( unstable )
+
+-install_docs (
+- "ChangeLog"
+- "COPYING"
+- "MAINTAINERS"
+- "README"
+- "README.hypervisor"
+- "RELEASE-NOTES"
+- "TODO"
+- )
+-
+ # uninstall target - leaves behind any directory created during install
+ set ( _templatefile "${CMAKE_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in" )
+ set ( _scriptfile "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake" )
+
diff --git a/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch
new file mode 100644
index 000000000000..431f2df8ac74
--- /dev/null
+++ b/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch
@@ -0,0 +1,11 @@
+--- stable/origMakefile 2014-03-27 18:17:28.000000000 -0400
++++ stable/Makefile 2014-05-30 18:07:28.164255039 -0400
+@@ -19,7 +19,7 @@
+ PPC32_ARCH_INC_FILE=\"ppc32_$(DYNAMIPS_ARCH)_trans.h\"
+ OSNAME=unknown
+
+-CFLAGS+= $(INCLUDE) -Wall -O2 -fomit-frame-pointer \
++CFLAGS+= $(INCLUDE) -Wall \
+ -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
+ -DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
+ -DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \
diff --git a/app-emulation/dynamips/metadata.xml b/app-emulation/dynamips/metadata.xml
new file mode 100644
index 000000000000..a7daaaa0bc6f
--- /dev/null
+++ b/app-emulation/dynamips/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gns-3</remote-id>
+ </upstream>
+</pkgmetadata>