summaryrefslogtreecommitdiff
path: root/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild')
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
index 61a15bd1f53c..409834bb73d2 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
@@ -56,6 +56,7 @@ PATCHES=(
"${FILESDIR}"/${P}-fix-inline.patch
"${FILESDIR}"/${P}-lto.patch
"${FILESDIR}"/${P}-as.patch
+ "${FILESDIR}"/${P}-nm.patch
)
pkg_pretend() {
@@ -90,6 +91,8 @@ src_configure() {
fi
# sndfile support is unconditionally disabled in src/plugin/sndfile/snd_o_wav.c
+ # CPP has to be set explicitly to workaround autoconf-2.69
+ # CPP detection (fixed in 2.70). bug #762748.
econf $(use_with X x) \
$(use_with svga svgalib) \
$(use_enable debug) \
@@ -100,11 +103,12 @@ src_configure() {
--with-fdtarball="${DISTDIR}"/${P_FD}.tgz \
--sysconfdir="${EPREFIX}"/etc/dosemu/ \
--with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
- IA16_LDFLAGS_EXTRA=${nopie_flag}
+ IA16_LDFLAGS_EXTRA=${nopie_flag} \
+ CPP="$(tc-getCPP)"
}
src_compile() {
- # src/makefile.common is fritten manually, uses AR=ar
+ # src/makefile.common is written manually, uses AR=ar
emake AR=$(tc-getAR)
}