summaryrefslogtreecommitdiff
path: root/app-emulation/docker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /app-emulation/docker
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'app-emulation/docker')
-rw-r--r--app-emulation/docker/Manifest2
-rw-r--r--app-emulation/docker/docker-20.10.8.ebuild279
2 files changed, 281 insertions, 0 deletions
diff --git a/app-emulation/docker/Manifest b/app-emulation/docker/Manifest
index bd59e45544ef..ea74743992f3 100644
--- a/app-emulation/docker/Manifest
+++ b/app-emulation/docker/Manifest
@@ -1,5 +1,7 @@
AUX etcd-F_OFD_GETLK-fix.patch 868 BLAKE2B 478be67388bc9001c90031c47e001c8bcc0435433df44b42ea4c15cdb595d2169c0b2d05a4e774d20f7f971e64c08e132b736e8847cf0966c65bf1816f6a958c SHA512 4caf8a8a1f4363545d02695fed4a06ce96fdad181d5773188ae8c2ef95e4f4fbfee6d7906ece6bf0d85dd57e159f2a3774aa228f0e6e1da0cdfef63ced62a434
AUX ppc64-buildmode.patch 916 BLAKE2B c28a2fcfed4812f44b664dc9b24e87f3999fcb9b79b7f47c6fd5a6b024529c49ef71817d4c379c7a95832a44b9c2f45c9f7707cb580b31be18dff4ee9a110e44 SHA512 bc87464d9f3351b2791e6f86bc7f2101e652c25b99cdcc02e46e4ff18f4bfb7ffc35d338370656bde6ad09ed98805e045065012dc6a264967d26272f7de099ff
DIST docker-20.10.7.tar.gz 11077660 BLAKE2B 081b36668ead0fd727ebdabc0d07fdf1992f64e3ab1e7c09933130b37f9ad60876c36d1fcda5619ba1bffac7fadafe63d7fc647868c3c6ba30429487c2ebc31b SHA512 2341faa3ebb903d74fa434712fce45e7acf0423710b97cdca11e3999db2819c4385d9a7fb3850925592f20f02c6261edbade6c9d6a2fefbc32f05a6b44ec3073
+DIST docker-20.10.8.tar.gz 11080739 BLAKE2B 1e5c14e23c4e9c8b0568cf19c98cb4cdbedc43742357bed61201f0188d5e3f4949d5e2a2231fd89635290c8784678005dff707a4e00ececfb82d88c69d31d235 SHA512 17c0519c8938227c578e5fe37689dd5a362b9673fabe06f98145b6fd5ae99e099a304c5706a84df30a2810855987fd694ac9cae7574023710fd1d99b0ca1aaf8
EBUILD docker-20.10.7.ebuild 7898 BLAKE2B c70fd9e392d62c80a69783170a9d48ff0f17b817a5897b86c4bbf26e5e624b6cc62205ceecef1036400cce494c4ea46ced8b7107e1466d41b6295eaf6bce8a2a SHA512 683ceab1c02cb2a2db344a0574baae9673dfb414af2a10a6ea31b8221ed48b36540a510258a1ef8adcb811e093e88e7f948550ee6db2e6c0ae3a98f34dc6f34e
+EBUILD docker-20.10.8.ebuild 7900 BLAKE2B 1816d1f86f17064391e484415dcc35a901e205b96b492f5c24f77f18887c9c82b24229bc131815cc2faa070b635adf16bf38c1746adabc89bca717423956bf6a SHA512 35103eef847ac33c0f98e237dceb324b4fec0c65c4b844bd307ac5aae8a567464f2998fd2a4c6d815b21d2eb3f24c9f4123fcf9f36b8827e31e1c68f549d98f2
MISC metadata.xml 1730 BLAKE2B 119ca97015c54afc8ea75d64e41d550afbcad5a3a6951f059d005e9a5086b467b26b348f6d29a7af4ff86016ecd8978fd20c9cacad41eb85a18756fc395d8a1b SHA512 c204ff1a267cbf386fa35d08b6a3ed91dae745d6bcadcad6e4cb085a510c53c37bda488ec077cfb9cbe57f2387e52a0fd00c153b7ef8d88225dd3c7d4b26f7e3
diff --git a/app-emulation/docker/docker-20.10.8.ebuild b/app-emulation/docker/docker-20.10.8.ebuild
new file mode 100644
index 000000000000..827d5a2ed3fa
--- /dev/null
+++ b/app-emulation/docker/docker-20.10.8.ebuild
@@ -0,0 +1,279 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/docker/docker
+MY_PV=${PV/_/-}
+GIT_COMMIT=75249d88bc
+inherit bash-completion-r1 linux-info systemd udev golang-vcs-snapshot
+
+DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/moby/moby/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="apparmor aufs btrfs +cli +container-init device-mapper hardened overlay seccomp"
+
+DEPEND="
+ acct-group/docker
+ >=dev-db/sqlite-3.7.9:3
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( >=sys-fs/btrfs-progs-3.16.1 )
+ device-mapper? ( >=sys-fs/lvm2-2.02.89[thin] )
+ seccomp? ( >=sys-libs/libseccomp-2.2.1 )
+"
+
+# https://github.com/moby/moby/blob/master/project/PACKAGERS.md#runtime-dependencies
+# https://github.com/moby/moby/blob/master/project/PACKAGERS.md#optional-dependencies
+# https://github.com/moby/moby/tree/master//hack/dockerfile/install
+# make sure docker-proxy is pinned to exact version from ^,
+# for appropriate branchch/version of course
+RDEPEND="
+ ${DEPEND}
+ >=net-firewall/iptables-1.4
+ sys-process/procps
+ >=dev-vcs/git-1.7
+ >=app-arch/xz-utils-4.9
+ dev-libs/libltdl
+ >=app-emulation/containerd-1.4.9[apparmor?,btrfs?,device-mapper?,seccomp?]
+ ~app-emulation/docker-proxy-0.8.0_p20210525
+ cli? ( app-emulation/docker-cli )
+ container-init? ( >=sys-process/tini-0.19.0[static] )
+"
+
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
+BDEPEND="
+ >=dev-lang/go-1.16.6
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+# tests require running dockerd as root and downloading containers
+RESTRICT="installsources strip test"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
+PATCHES=(
+ "${FILESDIR}/etcd-F_OFD_GETLK-fix.patch"
+ "${FILESDIR}/ppc64-buildmode.patch"
+)
+
+# see "contrib/check-config.sh" from upstream's sources
+CONFIG_CHECK="
+ ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
+ ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
+ ~CGROUP_NET_PRIO
+ ~KEYS
+ ~VETH ~BRIDGE ~BRIDGE_NETFILTER
+ ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE ~NETFILTER_XT_MARK
+ ~NETFILTER_NETLINK ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK ~NETFILTER_XT_MATCH_IPVS
+ ~IP_NF_NAT ~NF_NAT
+ ~POSIX_MQUEUE
+
+ ~USER_NS
+ ~SECCOMP
+ ~CGROUP_PIDS
+ ~MEMCG_SWAP
+
+ ~BLK_CGROUP ~BLK_DEV_THROTTLING
+ ~CGROUP_PERF
+ ~CGROUP_HUGETLB
+ ~NET_CLS_CGROUP
+ ~CFS_BANDWIDTH ~FAIR_GROUP_SCHED
+ ~IP_VS ~IP_VS_PROTO_TCP ~IP_VS_PROTO_UDP ~IP_VS_NFCT ~IP_VS_RR
+
+ ~VXLAN
+ ~CRYPTO ~CRYPTO_AEAD ~CRYPTO_GCM ~CRYPTO_SEQIV ~CRYPTO_GHASH ~XFRM_ALGO ~XFRM_USER
+ ~IPVLAN
+ ~MACVLAN ~DUMMY
+
+ ~OVERLAY_FS ~!OVERLAY_FS_REDIRECT_DIR
+ ~EXT4_FS_SECURITY
+ ~EXT4_FS_POSIX_ACL
+"
+
+ERROR_KEYS="CONFIG_KEYS: is mandatory"
+ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
+ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
+
+ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
+ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
+ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
+ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
+ERROR_XFRM_ALGO="CONFIG_XFRM_ALGO: is optional for secure networks"
+ERROR_XFRM_USER="CONFIG_XFRM_USER: is optional for secure networks"
+
+pkg_setup() {
+
+ if kernel_is lt 4 5; then
+ CONFIG_CHECK+="
+ ~MEMCG_KMEM
+ "
+ ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
+ fi
+
+ if kernel_is lt 4 7; then
+ CONFIG_CHECK+="
+ ~DEVPTS_MULTIPLE_INSTANCES
+ "
+ fi
+
+ if kernel_is lt 5 1; then
+ CONFIG_CHECK+="
+ ~NF_NAT_IPV4
+ ~IOSCHED_CFQ
+ ~CFQ_GROUP_IOSCHED
+ "
+ fi
+
+ if kernel_is lt 5 2; then
+ CONFIG_CHECK+="
+ ~NF_NAT_NEEDED
+ "
+ fi
+
+ if kernel_is lt 5 8; then
+ CONFIG_CHECK+="
+ ~MEMCG_SWAP_ENABLED
+ "
+ fi
+
+ if use aufs; then
+ CONFIG_CHECK+="
+ ~AUFS_FS
+ ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
+ "
+ ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs is patched to kernel instead of using standalone"
+ fi
+
+ if use btrfs; then
+ CONFIG_CHECK+="
+ ~BTRFS_FS
+ ~BTRFS_FS_POSIX_ACL
+ "
+ fi
+
+ if use device-mapper; then
+ CONFIG_CHECK+="
+ ~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
+ "
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ export DOCKER_GITCOMMIT="${GIT_COMMIT}"
+ export GOPATH="${WORKDIR}/${P}"
+ export VERSION=${PV}
+
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
+
+ # let's set up some optional features :)
+ export DOCKER_BUILDTAGS=''
+ for gd in aufs btrfs device-mapper overlay; do
+ if ! use $gd; then
+ DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
+ fi
+ done
+
+ for tag in apparmor seccomp; do
+ if use $tag; then
+ DOCKER_BUILDTAGS+=" $tag"
+ fi
+ done
+
+ if use hardened; then
+ sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
+ grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
+ sed "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
+ -i hack/make/dynbinary-daemon || die
+ grep -q -- '-fno-PIC' hack/make/dynbinary-daemon || die 'hardened sed failed'
+ fi
+
+ # build daemon
+ ./hack/make.sh dynbinary || die 'dynbinary failed'
+}
+
+src_install() {
+ dosym containerd /usr/bin/docker-containerd
+ dosym containerd-shim /usr/bin/docker-containerd-shim
+ dosym runc /usr/bin/docker-runc
+ use container-init && dosym tini /usr/bin/docker-init
+ newbin bundles/dynbinary-daemon/dockerd dockerd
+
+ newinitd contrib/init/openrc/docker.initd docker
+ newconfd contrib/init/openrc/docker.confd docker
+
+ systemd_dounit contrib/init/systemd/docker.{service,socket}
+
+ udev_dorules contrib/udev/*.rules
+
+ dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
+ dodoc -r docs/*
+
+ # note: intentionally not using "doins" so that we preserve +x bits
+ dodir /usr/share/${PN}/contrib
+ cp -R contrib/* "${ED}/usr/share/${PN}/contrib"
+}
+
+pkg_postinst() {
+ udev_reload
+
+ elog
+ elog "To use Docker, the Docker daemon must be running as root. To automatically"
+ elog "start the Docker daemon at boot:"
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog " systemctl enable docker.service"
+ else
+ elog " rc-update add docker default"
+ fi
+ elog
+ elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
+ elog ' usermod -aG docker <youruser>'
+ elog
+
+ if use device-mapper; then
+ elog " Devicemapper storage driver has been deprecated"
+ elog " It will be removed in a future release"
+ elog
+ fi
+
+ if use overlay; then
+ elog " Overlay storage driver/USEflag has been deprecated"
+ elog " in favor of overlay2 (enabled unconditionally)"
+ elog
+ fi
+
+ if has_version sys-fs/zfs; then
+ elog " ZFS storage driver is available"
+ elog " Check https://docs.docker.com/storage/storagedriver/zfs-driver for more info"
+ elog
+ fi
+
+ if use cli; then
+ ewarn "Starting with docker 20.10.2, docker has been split into"
+ ewarn "two packages upstream, so Gentoo has followed suit."
+ ewarn
+ ewarn "app-emulation/docker contains the daemon and"
+ ewarn "app-emulation/docker-cli contains the docker command."
+ ewarn
+ ewarn "docker currently installs docker-cli using the cli use flag."
+ ewarn
+ ewarn "This use flag is temporary, so you need to take the"
+ ewarn "following actions:"
+ ewarn
+ ewarn "First, disable the cli use flag for app-emulation/docker"
+ ewarn
+ ewarn "Then, if you need docker-cli and docker on the same machine,"
+ ewarn "run the following command:"
+ ewarn
+ ewarn "# emerge --noreplace docker-cli"
+ ewarn
+ fi
+}