summaryrefslogtreecommitdiff
path: root/app-emulation/docker-registry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /app-emulation/docker-registry
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'app-emulation/docker-registry')
-rw-r--r--app-emulation/docker-registry/Manifest2
-rw-r--r--app-emulation/docker-registry/docker-registry-2.7.1-r1.ebuild (renamed from app-emulation/docker-registry/docker-registry-2.7.1.ebuild)39
2 files changed, 23 insertions, 18 deletions
diff --git a/app-emulation/docker-registry/Manifest b/app-emulation/docker-registry/Manifest
index 9689a4dbb252..27682cd9a3d3 100644
--- a/app-emulation/docker-registry/Manifest
+++ b/app-emulation/docker-registry/Manifest
@@ -4,5 +4,5 @@ AUX registry.initd 606 BLAKE2B ed8af2651d91be13578edb561c067cfd3e72dfe42a6111be8
AUX registry.logrotated 89 BLAKE2B c16fab4c6a3c4fd9f48370ae30505408a49e07c2a7ea7fc119717efcd840ad489c92855e27a5546219b3cdeb257642eb65abc2d544859295688925ae2e94ecb3 SHA512 f824b33a1fa38802a8aa79599843b0ea065603799823352e9515c50bfc61c43a03e9eb5327f9c687b8c3864fc633ad1a46bff9e91f4c54a46a09e67d2f6f833b
AUX registry.service 323 BLAKE2B 1be481d08a283793d10ef870fc299e1c284087878e67ec54f44e662c616127bc411fdde19659cf7acd69787054c624c5c5206434c36b4e5a0fcceaf79c2e78f0 SHA512 67d2b69c1fc497774e3171628fa73b9b9521e19c76414e32721994f2ba614bd3c6896c578c9d9b8af0ad4972b9da0c504ef787a7585a550be4bfe1bd40eafc15
DIST docker-registry-2.7.1.tar.gz 1996699 BLAKE2B 2e22db69f476be5a4688f5b3d6b41fbbf71460351543ae849f707dd5b3d56624f674815a25214002886b057f0859f75fd197bb275a7b3cc8a7787422f716ad0e SHA512 f6baf0e7aa96ebe828c628f7dfd84ee899331c3c1bdab86662aef595b092702b6d9b2c9be766a6de6d153ff4ca55d85c5fd8785a0968f285f56a32a50092c754
-EBUILD docker-registry-2.7.1.ebuild 1490 BLAKE2B 5bed77a7d89bacec35ffd08b0c582df8a64f48d373b6f756263484acd5959a04b033815787d5095d78e12dad5b68d08b70ba7571815f2d772cddd16fd1cac7f5 SHA512 eb4c39ae5b02508846c19948ac7331abb5223defaecf0ee817f6b7e3d844d13eca370c63b37780807a0150b20bfa9860707f8050b18332390280789d9f2aa852
+EBUILD docker-registry-2.7.1-r1.ebuild 1463 BLAKE2B 21bbb8b8842540b479e22f7b7e5ce6c2c0f4f4c5ac37a64718c87c6abdef2a550b97ed495d35360d92d9545fe003656366713b27eff9b217859f83aaf834d48c SHA512 da38b17318bc05a0de3980dc1e4815dee8b459dab435993ac2b94c75a1fecfbbcd855c04809627e5d08b477a8bfe381425bdb9f85c6ff5558316e44b65fed80b
MISC metadata.xml 310 BLAKE2B b7a4e4e347c4b262857668fb0bba20e1efce6abc449cf3614538b34f03c897ce78e637db513a66e8e5ff9b1262df44d864aa41904ef7e86eee384bdafbb014cb SHA512 bcf043907e7e2ad9ef21a4b02b4aeb0f50bd17b1e5315653b2339036d4775bde661d711d4e84536f657c7bf9247ef446f1c95abdf14699620e44a104c9e1fe0a
diff --git a/app-emulation/docker-registry/docker-registry-2.7.1.ebuild b/app-emulation/docker-registry/docker-registry-2.7.1-r1.ebuild
index 76e7bd12811a..78708f327413 100644
--- a/app-emulation/docker-registry/docker-registry-2.7.1.ebuild
+++ b/app-emulation/docker-registry/docker-registry-2.7.1-r1.ebuild
@@ -1,32 +1,37 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit golang-vcs-snapshot systemd user
+EAPI=7
+
+inherit golang-vcs-snapshot systemd
-KEYWORDS="amd64 ~arm64"
-EGO_PN="github.com/docker/distribution"
EGIT_COMMIT="2461543d988979529609e8cb6fca9ca190dc48da"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGO_PN="github.com/docker/distribution"
+
DESCRIPTION="Docker Registry 2.0"
HOMEPAGE="https://github.com/docker/distribution"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 MIT ZLIB"
SLOT="0"
-IUSE=""
-SVCNAME=registry
+KEYWORDS="amd64 ~arm64"
-pkg_setup() {
- enewgroup ${SVCNAME}
- enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
-}
+DEPEND="
+ acct-group/registry
+ acct-user/registry
+"
+RDEPEND="${DEPEND}"
+
+SVCNAME="registry"
src_prepare() {
default
pushd src/${EGO_PN} || die
eapply "${FILESDIR}"/${PN}-2.7.0-notification-metrics.patch
- sed -i -e "s/git describe.*/echo ${PV})/"\
- -e "s/git rev-parse.*/echo ${EGIT_COMMIT})/"\
- -e "s/-s -w/-w/" Makefile || die
+ sed -e "s/git describe.*/echo ${PV})/" \
+ -e "s/git rev-parse.*/echo ${EGIT_COMMIT})/" \
+ -e "s/-s -w/-w/" \
+ -i Makefile || die
popd || die
}
@@ -43,8 +48,8 @@ src_install() {
newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
systemd_dounit "${FILESDIR}/${SVCNAME}.service"
- keepdir /var/{lib,log}/${SVCNAME}
- fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
+ keepdir /var/log/${SVCNAME}
+ fowners ${SVCNAME}:${SVCNAME} /var/log/${SVCNAME}
insinto /etc/logrotate.d
newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
}