summaryrefslogtreecommitdiff
path: root/app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild
deleted file mode 100644
index aff3fde4d8a1..000000000000
--- a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20210525.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-EGO_PN="github.com/docker/libnetwork"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- EGIT_COMMIT=64b7a4574d1426139437d20e81c0b6d391130ec8
- SRC_URI="https://github.com/docker/libnetwork/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv ~x86"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="Docker container networking"
-HOMEPAGE="https://github.com/docker/libnetwork"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-# needs dockerd
-RESTRICT="strip test"
-
-src_compile() {
- GO111MODULE=auto GOPATH="${WORKDIR}/${P}" \
- go build -o "bin/docker-proxy" ./cmd/proxy || die
-}
-
-src_install() {
- dodoc README.md CHANGELOG.md
- dobin bin/docker-proxy
-}