summaryrefslogtreecommitdiff
path: root/app-emulation/docker-machine/docker-machine-0.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/docker-machine/docker-machine-0.12.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/docker-machine/docker-machine-0.12.2.ebuild')
-rw-r--r--app-emulation/docker-machine/docker-machine-0.12.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/docker-machine/docker-machine-0.12.2.ebuild b/app-emulation/docker-machine/docker-machine-0.12.2.ebuild
new file mode 100644
index 000000000000..1697e3defa68
--- /dev/null
+++ b/app-emulation/docker-machine/docker-machine-0.12.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN=github.com/docker/machine
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Machine management for a container-centric world"
+HOMEPAGE="https://docs.docker.com/machine/"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+RESTRICT="test"
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ default
+ # don't pre-strip binaries
+ sed -e 's|\(GO_LDFLAGS := $(GO_LDFLAGS) -w\) -s|\1|' -i mk/main.mk ||die
+}
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${WORKDIR}/${P}" emake build || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md ROADMAP.md
+}