summaryrefslogtreecommitdiff
path: root/app-emulation/cloud-init
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-07 03:23:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-07 03:23:23 +0000
commitfc0e6a4667fb69a392aa649bf9d6261a30f53373 (patch)
tree81e0142dfcfc0a32ec945aa10dc396ab808c5030 /app-emulation/cloud-init
parent7842f444601c620f190db9801e59c4f11e686f15 (diff)
gentoo auto-resync : 07:02:2023 - 03:23:23
Diffstat (limited to 'app-emulation/cloud-init')
-rw-r--r--app-emulation/cloud-init/Manifest4
-rw-r--r--app-emulation/cloud-init/cloud-init-22.4.ebuild95
-rw-r--r--app-emulation/cloud-init/cloud-init-9999.ebuild2
3 files changed, 99 insertions, 2 deletions
diff --git a/app-emulation/cloud-init/Manifest b/app-emulation/cloud-init/Manifest
index d7a10884e7db..67ac1bc76073 100644
--- a/app-emulation/cloud-init/Manifest
+++ b/app-emulation/cloud-init/Manifest
@@ -1,4 +1,6 @@
DIST cloud-init-22.2.2.tar.gz 1349451 BLAKE2B fdb6669e9762984614fefe787834f20f056345d304327679fa8bc7b4d6566509a23ecc4a7ac4e6368b9b9078a72fe6fe35533a67e7aeb0c0accbf5ad014f8aae SHA512 18b75ebbb5e808e19df5ceddb6402cc881c33443fb169f736f54837254ba43836994f2392a26febbd8df3342b3467ee72759b6942cfeb96d07c0e452c11dd0bf
+DIST cloud-init-22.4.tar.gz 1494295 BLAKE2B 5f961c895c0d6c78a7cee47d2b52acd57d959baeb5172cea89d75ffe23424e3a8a3170a0ecdcad729c6cb0c898477ea94c43a5f8bdf200fc3f122c32fdb2e96d SHA512 6151d1d5e4be241219cb5804ca2bad2dd790f366bc847d286a8840faad1fb4adf5d780c9418ce574c2cfcefc16851a49961f33c5da1fbc84bb8299cf138bfcfc
EBUILD cloud-init-22.2.2.ebuild 2349 BLAKE2B 7d07d812fd91251e685abc7896c27d37f6b73c8fe6459fbb844e009fac79b29621f4f6dfc1e5f53f62dea78f3e49ebf44fc27ba486e3d0df0ba59978a60e3608 SHA512 561c83ee47dbb3ea4c6265cfcf79b10e9feff76a1ed3c9a7cc6d09e7b1cb730e3684c89bc12eff0d3cd943cc0529aad469aeedf2a953f86782cbe363d6103982
-EBUILD cloud-init-9999.ebuild 2315 BLAKE2B ce2b1a5c34955b5e7daf45ff253a7249e0df6233bd0e5fa26b7b9acd0a1e7839932b6dac6d5cb594ce7900398d2ce460106ff019202de3e8f2eb00aa7dd87866 SHA512 7d9206afd80e8e76a18f9c4cc8b249d3bf21528a80941278788ab42ba3f7cf26b6103b15ed8c3b43ff85a466f8e01b47b197897020c45765bd2ed461e6d0534e
+EBUILD cloud-init-22.4.ebuild 2349 BLAKE2B e6815bfda96be0576a3e59c13212fac4f8e31e25e6c6d641c822e193b5600fe38914dbc8e64a9f6dd5b89ab4831c785e9b445c3767106f3e0460e255c24a392d SHA512 abeccfc3deed7bef47369759771763047a22a42db520ec38eb364380e1ebcc2fcc37f90bfcdffc7098505424512dfd4681e584082e417910b70054e64843d9ef
+EBUILD cloud-init-9999.ebuild 2315 BLAKE2B 5ef920c2d14b2f6f31ad2e71018d913fff27549240050e8c58de3ad3dd4407b675e2c06948c61f4edc701791d4ec42d30338c51a0034734aa7524cb5bad6e5d8 SHA512 3d7e7b47ace63467173f0143e2e1c2684649c2d8e21ade1c7ddeac6fca1a6a9ecf51a1a2c459c5a851555ee95e8b3dd3376e093c3b8c9bcebd2c57a4b67a9a2f
MISC metadata.xml 714 BLAKE2B 22888016216cea9e471f7cef63e94022c344961263a3319508d5b23db64eeaaeb34a470fc51482bf7a0a4cb658dd814f5655393ee4498a7212ccec28caee5256 SHA512 3bd7be60f29d5a1e4a830577c0afc8c5925123f1258a78b82dbc36c8f76f096149db8bcebfaf3b6db5feeab0bc82ccb65d7d71ec12feb4f56027f05eeb930401
diff --git a/app-emulation/cloud-init/cloud-init-22.4.ebuild b/app-emulation/cloud-init/cloud-init-22.4.ebuild
new file mode 100644
index 000000000000..8ab2c561a20e
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-22.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Disabled for now: bug #850628
+# https://bugs.launchpad.net/cloud-init/+bug/1978328
+#DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1 udev
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
+else
+ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+ KEYWORDS="amd64 arm64 ppc64 x86"
+fi
+
+DESCRIPTION="Cloud instance initialisation magic"
+HOMEPAGE="https://launchpad.net/cloud-init"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/netifaces[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ net-analyzer/macchanger
+ sys-apps/iproute2
+ sys-fs/growpart
+ virtual/logger
+ selinux? ( sec-policy/selinux-cloudinit )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Fix location of documentation installation
+ sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
+
+ if [[ ${PV} == *9999 ]] ; then
+ sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
+}
+
+python_install_all() {
+ keepdir /etc/cloud
+
+ distutils-r1_python_install_all
+
+ # installs as non-executable
+ chmod +x "${D}"/etc/init.d/* || die
+}
+
+pkg_prerm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+
+ elog "cloud-init-local needs to be run in the boot runlevel because it"
+ elog "modifies services in the default runlevel. When a runlevel is started"
+ elog "it is cached, so modifications that happen to the current runlevel"
+ elog "while you are in it are not acted upon."
+}
diff --git a/app-emulation/cloud-init/cloud-init-9999.ebuild b/app-emulation/cloud-init/cloud-init-9999.ebuild
index db06a885bdae..9e43ae61d54e 100644
--- a/app-emulation/cloud-init/cloud-init-9999.ebuild
+++ b/app-emulation/cloud-init/cloud-init-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Disabled for now: bug #850628
#DISTUTILS_USE_PEP517=setuptools
# https://bugs.launchpad.net/cloud-init/+bug/1978328
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_11 )
inherit distutils-r1 udev